none
Outlook 2010: "Cannot open your default e-mail folders..."

    Question

  • When I open Outlook 2010 I receive the message: "Cannot open your default email folders.  There is not enough memory to perform the operation.", after which the program closes.  This is on a network running SBS 2003, with about 25 users, and I am the only with this problem.  System resources on the exchange server are fine, so I can only imagine a disk usage quota has been exceeded somewhere.  Storage limits for my account looked fine.  I've tried restarting exchange services, restarting the server itself, restarting my desktop, etc etc, to no avail.

    This specific problem just started yesterday, but I've been having memory issues for months now.  Usually, the Send and Receive dialogue will tell me that there are not enough resources on the server, but mail comes and goes just fine.  It's never simply refused to let me open outlook before, like it is now. 

    I also tried logging in through another computer and using Outlook 2003, which actually let me open the program, but did not sync mail properly.

    Also, we use cached exchange mode, so I tried creating a new ost file, but no dice. 

    Anyone know what the deal might be? 

    Thursday, December 29, 2011 5:00 PM

All replies

  • Hi,

    the most common cause I've seen for this symptom, is a damaged user environment (e.g. PST file, MAPI profile, Windows Profile - all on the client pc).

    Try a (temporary) alternate profile - to prove that out.
    http://office.microsoft.com/en-au/outlook-help/introduction-to-profiles-HA010355553.aspx

    Also, have a look at the ExchangeServerClients forum:
    http://social.technet.microsoft.com/Forums/en-US/exchangesvrclients/thread/8824e170-c833-4722-91ac-00e2c107a826


    Don
    • Edited by DonPick Thursday, December 29, 2011 9:23 PM
    Thursday, December 29, 2011 9:16 PM
  • Ah, i think we're on the right track here.  I tried opening mail, but it throws out the error: "You need more memory or system resources. Close some windows and try again.", despite having plenty of resources available.  After doing some googling, I found a a technet member recommend deleting the windows messaging subsystem key in the HKCU and HKLM.  I did so, but I'm still getting the error.  I'll try removing office completely and reinstalling it to see what happens.
    Friday, December 30, 2011 12:44 AM
  • Hi,

    I agree with Don’s guess of damaged PST file or MAPI profile. Analyzed your description(sync mail improperly on another computer and using cache mode), this problem might occur when your Outlook messaging profile includes a Microsoft Exchange account that is configured to Use Cached Exchange Mode, and you have lots of cached public folders. Usually, this problem occurs when you exceed approximately 1,000 public folders, or a gigabyte of space is taken.

    To prevent this problem, keep the number of cached public folders to fewer than 1,000. Or, reduce the number of folders until the error or errors stop occurring. If you are experiencing this problem, delete some public folder favorites by using the Outlook client. In some cases, if you have too many favorites, you may be unable to delete the folders because the error occurs when you click the public folder favorites folder.
     
    To delete the public folder favorites, follow these steps:

    1.Download MFCMAPI from http://mfcmapi.codeplex.com.
     2.Run MFCMAPI.exe.
     3.On the Session menu, click Logon and Display Store Table.
     4.If you are prompted for a profile, select your profile name, and then click OK.
     5.In the top pane, locate the line that corresponds to your mailbox, and double-click it.
     6.In the navigation pane (left-side pane), expand Root - Mailbox, and select the Shortcuts folder.
     7.In the results pane (right-side pane), locate the PR_FOLDER_CHILD_COUNT properties. The value contains the number of public folder favorites.
     8.In the navigation pane, right-click the Shortcuts folder, and then select Empty Items and Subfolders from Folder.
     9.Keep the default options, and then click OK.

    Good Luck.

    Tony Chen

    TechNet Community Support

    Monday, January 02, 2012 5:20 AM
    Moderator
  • So I load my profile, and when I select my store to bring up the navigation pane it throws up this error: 

     

    Error: 
    Code: MAPI_E_NOT_ENOUGH_MEMORY == 0x8007000E
    Function CallOpenMsgStore( lpMAPISession, (ULONG_PTR)m_hWnd, lpEntryID, ulFlags, (LPMDB*) lppMAPIProp)
    File MainDlg.cpp
    Line 354

    I logged off and created a new profile, using an alternate email account, then logged back in.  It let me access  the navigation pane, through which I checked out PR_FODLER_CHILD_COUNT, which had an unsigned decimal value of 9.  It should read this value regardless of what profile I'm logged into, correct?  If so, would that mean that having too many public folders is not the issue here?

     


    Tuesday, January 03, 2012 5:00 PM
  • So I was finally able to open the Mail tool in the control panel.  I disabled cached exchange mode and selected "Disable Offline Use" in the Outlook Data Files Settings dialogue, and Outlook opened just fine.  I also tried re-enabling cached mode and creating a new datastore, but when I opened Outlook it hungup on "preparing for first time use".  Repairpst didn't fine find any errors, either.... 
    Tuesday, January 03, 2012 10:40 PM