none
unable to add a databese copy on another DAG server

    Question

  • Hello everyone

    I'm trying to add another copy of database on another server but I'm receiving the following error:

    <label style="font-weight:bold;">ERROR</label>
    DB1

    The seeding operation failed. Error: An error occurred while running prerequisite checks. Error: Database 'DB1' is not mounted. Use Mount-Database to mount the database before seeding database copies. [Database: ARCHDB1, Server: EX2.mydomain.local]

    I'm sure that that the database is mounted and it's functioning properly I tried it on another database and I'm still receiving the same error.

    I only have two exchange server ex1 and ex2 both are 15.0 ‎(Build 1178.4)‎

    I noticed a weird error when I go to servers in the exchange web interface and click on ex2, under databases and database availability groups when I click on view details I receive the following error:

    error The operation couldn't be performed because object '*\EX2' couldn't be found on 'DC2.my.local'.I checked in Active directory and I found that ex2 is already in the servers OU in DC2 and DC1

    any suggestion please

    Friday, April 12, 2019 8:35 AM

All replies

  • Hi,

    Seems that there is some problem in AD replication.

    Try to put a static domain controller on both exchange (Just for testing purpose and then check).

    Use set-exchangeserver with statisdomaincontroller parameter to put a static DC (Put DC1 in your case).

    Also seems that you are running on Exchange 2013 CU12 which is very old. Please update to latest one.

    https://docs.microsoft.com/en-us/powershell/module/exchange/organization/set-exchangeserver?view=exchange-ps

    https://social.technet.microsoft.com/wiki/contents/articles/15776.exchange-server-2013-2016-and-2019-build-numbers-with-cumulative-updates.aspx


    Thanks,

    Ashish

    MCITP, MCT, MCSE

    “Tell me and I forget, teach me and I may remember, involve me and I learn.”

    Note:- Please remember to vote and mark the replies as answers if they help.

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees and confers no rights.

    Friday, April 12, 2019 12:21 PM
  • thanks for your reply

    I tried to upgrade ex2 but I received the following error:

    This computer does not belong to a valid active directory site. check the site subnet and definitions.

    Setup can't use the domain controller '' because it belongs to Active Directory site 'mysite'. Setup must use a domain controller in the same site as this computer (DC2.mydomain.local).

    I checked in active directory sites and services and i couldn't find any problem the two domain controllers are in the same site

    any suggestion what should I do

    Saturday, April 13, 2019 7:06 AM
  • Hi,

    Do you specify static domain controllers for EX2? Please run the following command to check.

    Get-ExchangeServer EX2|fl *static*

    If you do not configure the parameter or use another domain controller, you can set StaticDomainControllers to an appropriate domain controller (DC2.mydomain.local) for EX2 as the error indicated. 

    Set-ExchangeServer -Identity EX2 -StaticDomainControllers DC2.mydomain.local

    For your reference:

    [RESOLVED] Setup can't use the domain controller because it belongs to Active Directory site

    Please note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information. And the changes made in the above blog is not supported officially by Microsoft.

    Regards,

    Dawn Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, April 15, 2019 8:53 AM
    Moderator
  • Hi,

    How is everything going? Do you try above methods?

    If there is anything unclear or any update, please feel free to let us know. If the reply helps, kindly mark it as answer, which will be beneficial for answer searching in the forum.
     
    Thanks for your understanding.


    Regards,

    Dawn Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, April 18, 2019 9:46 AM
    Moderator