none
Why is it the Search Fails due to Timer Service. Then Timer Service Account needs password to be reentered and service restarted? RRS feed

  • Question

  • Hi,

    MOSS 2007 using 3 Virtual Machines (DB, Sharepoint and Web)

    I have a <domain>\sharepointadmin account used as the login for the Timer Service on the WEB VM and Sharepoint VM. They start off fine until I get in the next day and find that the login has failed for the Sharepoint Search (OWSTIMER.EXE). I then need to go in and reenter the same password and restart the TIMER service. This fixes the issue-until the next day. Is there some TIMER lockout going on here? I have come to the conclusion that the Search Service sets up the Search, but the TIMER service executes it, but for some reason the <domain>\sharepointadmin account gets locked out - why?

    Your help would be appreciated.

    Thanks.

    John.





    Wednesday, November 30, 2011 11:32 AM

Answers

  • Hi,

     

    Please post the detailed error message into the forum for further analysis.

     

    According to your description, please verify that the timer service account has logon as a service and Log on as a batch job rights:

     

    1. Click Start, click Run, type gpedit.msc, and then click OK.

    2. Expand Local Computer Policy, expand Computer Configuration, expand Windows

    Settings, expand Security Settings, expand Local policies, and then click User Rights Assignment.

    3. Double-click Log on as a batch job, click Add user or group, type the name of the service account, and then click OK two times.

    4. Double-click Log on as a service, click Add user or group, type the name of the service account, and then click OK two times.

    3) Note that if the domain group policy forbids this, the issue will reoccur the next time the policy is applied. Verify that this is not the case and correct if needed.

     

    For the detailed information about permissions for SharePoint service account, see

    http://www.dotnetmafia.com/blogs/dotnettipoftheday/archive/2011/05/23/corey-s-guide-to-sharepoint-service-accounts.aspx

     

    Thanks,

    Rock Wang

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Regards, Rock Wang Microsoft Online Community Support
    • Marked as answer by John Guilbert Monday, December 12, 2011 10:02 AM
    Thursday, December 1, 2011 3:05 AM

All replies

  • Hi,

     

    Please post the detailed error message into the forum for further analysis.

     

    According to your description, please verify that the timer service account has logon as a service and Log on as a batch job rights:

     

    1. Click Start, click Run, type gpedit.msc, and then click OK.

    2. Expand Local Computer Policy, expand Computer Configuration, expand Windows

    Settings, expand Security Settings, expand Local policies, and then click User Rights Assignment.

    3. Double-click Log on as a batch job, click Add user or group, type the name of the service account, and then click OK two times.

    4. Double-click Log on as a service, click Add user or group, type the name of the service account, and then click OK two times.

    3) Note that if the domain group policy forbids this, the issue will reoccur the next time the policy is applied. Verify that this is not the case and correct if needed.

     

    For the detailed information about permissions for SharePoint service account, see

    http://www.dotnetmafia.com/blogs/dotnettipoftheday/archive/2011/05/23/corey-s-guide-to-sharepoint-service-accounts.aspx

     

    Thanks,

    Rock Wang

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Regards, Rock Wang Microsoft Online Community Support
    • Marked as answer by John Guilbert Monday, December 12, 2011 10:02 AM
    Thursday, December 1, 2011 3:05 AM
  • Hi Rock,

    I spoke to out IT Services Guys who said both <domain>\spsearch (used for Search) and <domain>\sharepointadmin (used for Timer Service and is login for Administrator) both have "Log on as batch job" and "Log on as Service" enabled.

    I came in this morning to get exactly the same problem. Checked to see Central Admin Application Pool was running under <domain>\sharepointadmin and it was. 

    Any other ideas while I trail through logs to see where it  

    (Disappointed that 'The Rock' never took over from Arnold Schwarzenegger - just thought I would add this useless bit of information as it's been on my mind a while - wish he would stop doing kids movies ;) )

    Thanks.

    John.

    Friday, December 2, 2011 10:07 AM
  • Hi,

     

    Thanks for your reply.

     

    I suggest that you check the following settings:

     

    1.       Look at the domain\sharepointadmin account, make sure you don’t set lockout setting on this account. If so, remove this option, then test again.

    2.       Go through the following article to check if both accounts have right permissions.

     

    http://technet.microsoft.com/en-us/library/cc263445.aspx

     

    Thanks,

    Rock Wang

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Regards, Rock Wang Microsoft Online Community Support
    • Marked as answer by Wayne Fan Thursday, December 8, 2011 2:04 AM
    • Unmarked as answer by Wayne Fan Thursday, December 8, 2011 2:04 AM
    Wednesday, December 7, 2011 9:59 AM
  • Hi,

    How is it going? If you need any help, feel free to reply to us.

    Thanks,

    Rock Wang

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Regards, Rock Wang Microsoft Online Community Support
    Friday, December 9, 2011 8:52 AM
  • I'll check this first thing Monday Morn. On a Learning Tree Course this week....thanks.

    Course Over.....checked the services this morning and voila....no log in as service errors. I suppose this goes to show if it looks like it's right, smells like it's right then it probably is right. IT Services gave domain privs (on Sharepoint Servers only) to allow 'Log in as Service' to be enabled, then they could add users to "Log in as service" list on domain.

    Thanks Rock.   



    Friday, December 9, 2011 2:18 PM
  • Thank you! This just solved my problem!
    Friday, December 5, 2014 3:00 PM
  • Hi John,

    For me after trying all the options i came to conclusion to update the registry of the service here

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\myGmsaservice\

    Update ServiceAccountManaged key to 01 00 00 00. 

    Reboot.


    Farookh21

    Wednesday, July 17, 2019 9:25 PM