locked
Office 365 Room allowing double booking of meetings RRS feed

  • Question

  • Hi All,

    We have Office 365 (E3) in cloud-only mode with no on-prem exchange. There are a lot of resources (rooms) that we create in Office 365. For some of the rooms, we want to restrict booking to only a group of users.

    This is the command I executed to create the room and restrict it a specific set of users.

    Create Room
    New-Mailbox -Name "CR-1AR 02 NorthWest" -Room -ResourceCapacity "8" -Office "Hartford" -Phone "" -PrimarySmtpAddress "1AR02NorthWest@XXXXX.com"

    Set processing parameters and restrict room booking to a set of users.
    Set-CalendarProcessing "1AR02NorthWest@XXXXX.com" -AllowConflicts $True -MaximumConflictInstances 25 -AutomateProcessing AutoAccept -BookingWindowInDays 365 -DeleteComments $true -AddOrganizerToSubject $true -ConflictPercentageAllowed 50 Set-CalendarProcessing "1AR02NorthWest@XXXXX.com" -AllBookInPolicy $false -BookInPolicy dnagpal@XXXXX.com,clyons@XXXXX.com,ewetherell@XXXXX.com,efoley@XXXXX.com,bmantilla@XXXXX.com,kmeinert@XXXXX.com,lmoua@XXXXX.com,toconnell@XXXXX.com,mkulinski@XXXXX.com,tstpierre@XXXXX.com

    Permission on calendar for all users to see limited details and or facility managers to look at bookings.
    Set-MailBoxFolderPermission -AccessRights LimitedDetails  "CR-1AR 02 NorthWest:\Calendar" -User default

    Add-MailBoxPermission "1AR02NorthWest@XXXXX.com" -User "O365-Facility-Managers" -AccessRights FullAccess

    The problem that We are facing is that the room now allow conflicting bookings for the people who are in the policy. Even if the room is blocked, or has a booking.

    Is there any issues with the room creation or is there a way we can prevent this from happening?

    Thanks

    Friday, April 28, 2017 1:11 PM

All replies

  • Well, considering you have set the -AllowConflicts parameter to $True, why would you expect it to behave differently? Refer to the Set-CalendarProcessing help to better understand the effect of the *conflict* parameters.

    For a more detailed explanation, you can refer to this blog article: https://blogs.technet.microsoft.com/exchange/2011/02/07/automatic-processing-of-recurring-meeting-requests-with-conflicting-instances/

    • Proposed as answer by Jason.Chao Tuesday, May 2, 2017 6:07 AM
    Friday, April 28, 2017 7:12 PM
  • Hi ,

    Setting AllowConflicts to true will allow conflicts on room mailbox. In your case, there is a delegate on that room mailbox which must approve the booking. So you had use BookInPolicy for that user as well.

    If you want to prevent this, set it to false.

    Hope it helps.


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, May 2, 2017 6:17 AM
  • We have the same issue after MS changed the default behaviour for room booking so if a room isnt available one day for a reoccuring meeting with 10 different day bookings, its rejects it all, it used to just reject the one that wasnt available.

    we implemented something similar to above and are now facing the same issues.

    Friday, September 1, 2017 12:05 PM
  • so we have the allow conflicts turned off but the calendar seems to allow double booking.

    RunspaceId                          : 806627f3-a5e4-4aba-a886-afa9d41da186
    AutomateProcessing                  : AutoAccept
    AllowConflicts                      : False
    BookingType                         : Standard
    BookingWindowInDays                 : 180
    MaximumDurationInMinutes            : 1440
    AllowRecurringMeetings              : True
    EnforceSchedulingHorizon            : True
    ScheduleOnlyDuringWorkHours         : False
    ConflictPercentageAllowed           : 0
    MaximumConflictInstances            : 0
    ForwardRequestsToDelegates          : False
    DeleteAttachments                   : False
    DeleteComments                      : False
    RemovePrivateProperty               : True
    DeleteSubject                       : False
    AddOrganizerToSubject               : True
    DeleteNonCalendarItems              : True
    TentativePendingApproval            : False
    EnableResponseDetails               : True
    OrganizerInfo                       : True
    ResourceDelegates                   : {}
    RequestOutOfPolicy                  : {}
    AllRequestOutOfPolicy               : False
    BookInPolicy                        : {}
    AllBookInPolicy                     : True
    RequestInPolicy                     : {}
    AllRequestInPolicy                  : True
    AddAdditionalResponse               : True
    AdditionalResponse                  : <html>

    Thursday, June 7, 2018 1:35 PM
  • Same issue.  All mailboxes, shares, room resources in Exchange Online but we have 1 on-prem for management.  Still have double booking.
    Tuesday, June 12, 2018 12:47 PM
  • We're also having the same issue. Shared Resource Mailboxes with AllowConflicts : False and yet the calendar is allowing double booking.

    Has anyone resolved this issue yet?

    Tuesday, July 31, 2018 6:57 PM
  • Same exact issue, Allow Conflicts: False. Has anyone heard back on a resolution for this?
    Wednesday, August 22, 2018 9:02 PM
  • RESOLVED:

    Our goal was to accept repeat meetings to a resource where there were less than 25% of meeting conflicts and just decline the conflicts so a user could book a different resource on that dates/times.  We did not want to double-book any resources and not decline all meetings if a user booked a repeat meeting that had a conflict on 1 instance of the meeting, only a decline for that instance.  This was resolved by setting allow conflicts to false and maximum conflict instances to 1000.  Here is a sample config:

    PS C:\Users\demo> Get-CalendarProcessing conf_room1 | Format-List


    RunspaceId : xxxxxxxxxxxxxxxxxxxxx
    AutomateProcessing : AutoAccept
    AllowConflicts : False
    BookingType : Standard
    BookingWindowInDays : 180
    MaximumDurationInMinutes : 1440
    AllowRecurringMeetings : True
    EnforceSchedulingHorizon : True
    ScheduleOnlyDuringWorkHours : False
    ConflictPercentageAllowed : 25
    MaximumConflictInstances : 1000
    ForwardRequestsToDelegates : True
    DeleteAttachments : True
    DeleteComments : False
    RemovePrivateProperty : False
    DeleteSubject : False
    AddOrganizerToSubject : False
    DeleteNonCalendarItems : True
    TentativePendingApproval : True
    EnableResponseDetails : True
    OrganizerInfo : True
    ResourceDelegates : {}
    RequestOutOfPolicy : {}
    AllRequestOutOfPolicy : False
    BookInPolicy : {}
    AllBookInPolicy : True
    RequestInPolicy : {}
    AllRequestInPolicy : False
    AddAdditionalResponse : False
    AdditionalResponse :
    RemoveOldMeetingMessages : True
    AddNewRequestsTentatively : True
    ProcessExternalMeetingMessages : False
    RemoveForwardedMeetingNotifications : False
    MailboxOwnerId : conf_room1
    Identity : conf_room1
    IsValid : True
    ObjectState : Changed

     

    • Proposed as answer by mmhmillermi Friday, June 26, 2020 9:15 PM
    Tuesday, September 4, 2018 5:08 PM