none
COMDLG32.OCX Failed to load on Windows 8.1

    Question

  • I tried typing into command prompt "regscr32 comdlg32.ocx" and it says "The module "comdlg32.ocx" may not compatible with the version of Windows that you're running. Check if the module is compatible with an x86 (32-bit) or an x64 (64-bit) version of regsvr32.exe."

    What should I do now? Does anybody have any suggestions?

    Friday, April 18, 2014 2:04 AM

Answers

All replies

  • Hi,

    Here is same issue, should place it in  SysWOW64 folder:

    c:windows\system32\comdlg32.ocx failed to load

    http://social.technet.microsoft.com/Forums/en-US/8bb8f428-3c43-4b01-a909-480e265dacf2/cwindowssystem32comdlg32ocx-failed-to-load?forum=w7itproinstall


    Alex Zhao
    TechNet Community Support

    Monday, April 21, 2014 2:38 AM
    Moderator
  •  

    Tony 5665,

    Another solution if the one already posted doesn’t work is to download the latest ComDlg32.ocx which is included in VB60SP6-KB2708437-x86-ENU.msi.

    You can’t install the VB60SP6-KB2708437-x86-ENU.msi on Windows 8.1 unless you already have VB6 SP6 installed so you may need to extract the MSI installation file to a new folder.  Then you can copy ComDlg32.ocx to C:\Windows\System (not System32).

    From an elevated command prompt, go to C:\Windows\System and register the file using this command:

    regsvr32 comdlg32.ocx

    I hope this helps!

    Mike

    Windows Outreach Team – IT Pro


    Tuesday, April 22, 2014 7:21 PM
    Moderator
  • This was the only that worked for me.

    Steps I've followed twice for Windows 8.1 Single Laguage

    1.- download .msi from http://www.microsoft.com/en-us/download/details.aspx?id=7030

    2.- don't install the .msi, but "Extract to" (winzip, winrar, 7-zip, ...) some folder

    3.- open a Command Prompt as "Administrator" (Windows key, type CMD, right click, open as administrator)

    4.- change current directory to SYSTEM, not SYSWOW64, not SYSTEM32, yes, just SYSTEM

    5.- copy files from folder created in step 2.-, all files if you are not sure (old schoool style is: copy "c:\my user\my docs\my folder\*" then hit enter)

    6.- regsvr32.exe mscomctl.ocx and hit enter

    7.- regsvr32.exe comctl32.ocx and hit enter

    8.- regsvr32.exe comdlg32.ocx and hit enter

    Thanks Mike

    Wednesday, July 30, 2014 8:36 AM
  • I tried all the options in Windows 8.1. comdlg32.ocx gets registered after placing the same at recommended locations, but the msg "comdlg32.ocx is missing etc.." continues to recur and the application does not run. What could be the problem/ solution. The software worked in windows 8 but this problem surfaced after upgrading to 8.1
    Thursday, January 22, 2015 12:28 PM