none
The program can't start because MSVCR80.dll is missing from your computer.. MS Visio 2007

    Question

  • Hi

     

    After I've installed Microsoft Visio 2007 with SCCM. Visio works fine.

    A day or two after, Visio can't start because of a missing DDL file.

     

    ::: Error Message :::

    The program can't start because MSVCR80.dll is missing from your computer. Try reinstalling the program to fix this problem.

    ::: Error Message :::

     

    I'v tried to install Visio 2007 SP 3 after re-installing Visio.

     

    The same error box appears, when SP 3 is installed.

    The program can't start because MSVCR80.dll is missing from your computer. Try reinstalling the program to fix this problem.

     

    Any ideas.. ??

     


    Best Regards, Sebastian Davidge IT Specialist
    • Moved by Jennifer ZhanModerator Tuesday, February 08, 2011 1:58 AM (From:Office 2007 Planning and Deployment)
    Monday, February 07, 2011 9:29 PM

All replies

  • HI,

    This means several things.
    a) your console application does not have manifest. Either embedded inside or external. To check this, do the following:
          1. Check for <appname>.exe. manifest next to exe. If it is not there, it may be embedded. Go to step 2.
          2. Open appname.exe in VS. See if it has RT_MANIFEST. Save it as a file and see if it has this line in it:      
    <assemblyIdentity type="win32" name="Microsoft.VC80.DebugCRT" version="8.0.50215.4652" processorArchitecture="amd64" publicKeyToken="1fc8b3b9a1e18e3b"></assemblyIdentity>
            If no RT_MANIFEST resource is present in the binary, go to step 3. If it is there, then go to step 4.
          3. You are building with /manifest:no. Don't do this, it is not supported scenario. Remove this linker switch and it all should work.
          4. msvcr80d.dll is not on the system. We need to know what version of VS is installed, what OS, what parts of VC++ have you selected during installations. Go ahead and file a bug on this on lab.msdn.microsoft.com.

    Hope this helps.

    Tuesday, February 08, 2011 2:00 AM
    Moderator
  • MSVCR80 - microsoft visual C++ runtime/redistributable r8 may be a pre-req (probably available on ms download.

    al

     


    If this answer solves your problem, please check Mark as Answered. If this answer helps, please click the Vote as Helpful button. Al Edlund Visio MVP
    Tuesday, February 08, 2011 12:31 PM
  • Hi Jennifer,

     

    Many thanks for your reply.

    visio.exe.manifest contains the following.

     

    ::::: START :::::

    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>

    <assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0"><noInherit></noInherit><assemblyIdentity version="12.0.0.0" processorArchitecture="X86" name="Microsoft.Visio.Visio.Exe" type="win32"></assemblyIdentity><description>Microsoft Visio VISIO.EXE</description><dependency><dependentAssembly><assemblyIdentity type="win32" name="Microsoft.VC80.CRT" version="8.0.50608.0" processorArchitecture="x86" publicKeyToken="1fc8b3b9a1e18e3b"></assemblyIdentity></dependentAssembly></dependency><trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">

                                 <security>

                                                              <requestedPrivileges>

                                                                                           <requestedExecutionLevel level="asInvoker" uiAccess="false"></requestedExecutionLevel>

                                                              </requestedPrivileges>

                                 </security>

    </trustInfo></assembly>

     

    ::::: END :::::

     

    If I open Visio with /manifest:no, Visio opens fine.

    Or Start -> Run - > Visio [Enter]

    If I use the Application link - Start - All Program - Office - Visio 2007. I still get the error.

    ::: Error Message :::

    The program can't start because MSVCR80.dll is missing from your computer. Try reinstalling the program to fix this problem.

    ::: Error Message :::

     

    /Sebastian 


    Best Regards, Sebastian Davidge IT Specialist
    Tuesday, February 08, 2011 6:14 PM
  • ROFL... I am so glad I found this, and talk about timing... I am getting the EXACT same issue...

    Environment:
    Windows XP SP3
    .Net 1.1 through 4 installed
    Vanilla XP installation, no other apps installed
    Can give more details upon request

    I found this while testing my deployment packages that I have created..

    I take a Microsoft Visio Standard 2007 source, with the SP2 msp's added to the Upgrade folder and install it, I do a customized installation and tell it to Run All From Local, basically install EVERYTHING.

    Let the installation complete. I execute Visio and everything runs as necessary.

    I then run a installation from a Microsoft Visio Professional 2007 source with the SP2 msp's also added to the Upgrade folder, I so a customized installation as well telling it to Run All From Local, aka install Everything. This is to validate an upgrade process which may happen.

    The install completes asking me to reboot. I have tested from this point with and without rebooting, but when you execute Visio I receive the following error msg:

    "The application has failed to start because MSVCR80.dll was not found. Re-installing the application may fix this problem."

    If I go into Add/Remove Programs and execute Visio and run a repair, everything works, but I obviously don't want to have to do that on an upgrade.

    When I tested on install sources with the msp's NOT in the upgrade folder, everything appeared to work, but that defeats the purpose of the upgrade folder...

    Please Advise...

    Thanks!!

     

    Wednesday, February 16, 2011 5:28 PM
  • I have the log files of a Visio Pro 2007 installation and a visio std 2007 to pro 2007 upgrade to compare the deltas against.. Let me know if you want them...


    TIA

    Wednesday, February 16, 2011 8:42 PM
  • wow. it did not help.  It made things worse.  If I understood what was just typed I would have figured it out on my own.  This is a tech consultant consulting another tech consultant.  Us mere mortals have the same problem also.

    Friday, November 02, 2012 3:37 AM