none
Installing fails on 2008 R2 (lync)

    Question

  • Hello Guys,

     

    in my lad i am installing a Lync Server. As req. i installed an blank 2008 R2 (come only in 64 Bit) on my Vmware ESX platform.

    Donwloaded Lync mounted the CD and now i get the message, nope u are nto running 64 bit plz check and fix...

    What can i do? I could install the client, but not the server app.

    Must I install some other roles, not mentioned in the guide or i over read it, to make this work?

     

    Thx alot!

    • Edited by SonicSW Monday, September 20, 2010 2:28 PM typo
    • Changed type Ben-Shun Zhu Tuesday, September 21, 2010 9:06 AM
    Monday, September 20, 2010 2:23 PM

All replies

  • Hi,

    Here are the prerequisites we have documented:

    ·         Microsoft Internet Information Services (IIS) 7.0 Rewrite package

    ·         SQL Server 2008 Native Client

    ·         SQL Server 2005 Backwards Compatibility tool

    ·         Microsoft Visual C++<sup>®</sup> 2008 Redistributable Package

    ·         Microsoft Silverlight<sup>®</sup>

    ·         Microsoft .NET Framework 3.5 with SP1

    ·         Microsoft Windows PowerShell<sup>®</sup> 2.0

    The following features:

    ·         Message Queuing

    ·         IIS 7.0 was installed with the following command:

    ServerManagerCmd.exe -Install Web-Server Web-Http-Redirect Web-Scripting-Tools Web-Windows-Auth Web-Asp-Net Web-Log-Libraries Web-Http-Tracing Web-Basic-Auth

    • AD DS Tools

    ·         Desktop Experience (needed for Lync Server 2010 (RC)on Windows Server 2008 R2)

     

    You should change this from a General Discussion to a question. FYI


    Thom Foreman, MCSE, MCSA, MCTS
    Tuesday, September 21, 2010 5:32 AM
  • Communications Server supports Windows Server 2008 Service Pack 2 and Windows Server 2008 R2. If you have an existing Windows Server 2008 Service Pack 1 server running, it must first be upgraded to either Windows Server 2008 Service Pack 2 or Windows Server 2008 R2.

    Communications Server 2010 is supported on the following editions of Windows Server 2008:

    • Windows Server 2008 Standard Edition
    • Windows Server 2008 Enterprise Edition
    • Windows Server 2008 Datacenter Edition

    Communications Server 2010 is not supported on the following editions of Windows Server 2008:

    • Windows Server 2008 Core Edition
    • Windows Server 2008 Web Server Edition
    • Windows Server 2008 High Performance Computing (HPC) Edition

    Best regards,
    Tuesday, September 21, 2010 9:11 AM
  • this does not realy help that the installation thinks it is an 86Bit system.

    its a blank 2008 R2 x64 OS. Some of the install fieles can be installed like the SQl Server other stat as well that the host is not 64 BIT a bit odd isnt it?

     

    Error Message:

    The version of this file is not compatible with the verion of windows you re running.

    Check your computers system info to see wherthere you need an x86 or x64 version of the programm.

    ->So Lync is only x64 and an 2008 R2 ENT is also only x64

     

    What should i do? Any clues for me?

     

     

     

    Thursday, September 23, 2010 1:01 PM
  • What is the Vmware ESX version you are using ?
    Thursday, September 23, 2010 1:25 PM
  • This seems odd, but it's worth checking.  The error definately reeks of a 64bit app trying to install on a 32bit OS.  From a command prompt, run msinfo32.  In System Summary, check the System Type.  It should say x64-based PC as opposed to x86-based PC
    Thursday, September 23, 2010 3:05 PM
  • @SonicSW

    I am facing the same issue and I'm not even using vmware. if you have found a solution for this please mention it.

     

    Microftot guys please help!


    Mohsin Khalid
    Friday, May 27, 2011 5:14 AM
  • I also have same issue. Any resolutions yet?
    • Proposed as answer by ryanhark Friday, July 8, 2011 8:11 PM
    • Unproposed as answer by ryanhark Friday, July 8, 2011 8:12 PM
    Thursday, July 7, 2011 2:35 PM
  • Re-downloaded the ISO worked for me. took almost an hour though
    Friday, July 8, 2011 8:12 PM
  • Wow, the only times I've seen this error on an ESX system is when the virtualization technology is not enabled in BIOS on the physical ESX server.
    Monday, July 11, 2011 11:09 AM