none
room booking not working by users from a federated Org RRS feed

  • Question

  • We recently acquired a company and both of us are on Exchange 2016 on-prem.  We have set Exchange federation and have MIM to sync GAL across the org.  All is working fine except room booking across the org.  For example, user A from Company A Exchange Org submitted a meeting request to a conference room at Company B Exchange Org she won't get any email for approved or declined.  I have verified that the room is set to auto approval or decline. And it worked fine if the request was from the same org.  I can see the emails from user A in the room resource mailbox.  Same happened if user B from Company B Exchange org sent a request to a conference room in Company A Exchange org.  

    I think the problem is due to across org but is there a fix or workaround?

    Thanks,

    Wednesday, July 17, 2019 6:49 PM

Answers

  • Hi Chris,

    Do you enable the external users to book the room calendars? Please run the following command to check this:

    Get-Mailbox -RecipientTypeDetails RoomMailbox | Get-CalendarProcessing | fl Identity,ProcessExternalMeetingMessages

    If the ProcessEernalMeetingMessages is set to 'False', run the command below to set it to 'True' and re-book the room calendar in the federated Org.

    1> Set it for one room calendar: 

    Get-Mailbox <RoomMailbox> | Set-CalendarProcessing -ProcessExternalMeetingessages $true

    2> Set it for all rooms:

    Get-Mailbox -RecipientTypeDetails RoomMailbox | Set-CalendarProcessing -ProcessExternalMeetingessages $true


    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, July 18, 2019 4:21 AM
    Moderator

All replies

  • Hi Chris,

    Do you enable the external users to book the room calendars? Please run the following command to check this:

    Get-Mailbox -RecipientTypeDetails RoomMailbox | Get-CalendarProcessing | fl Identity,ProcessExternalMeetingMessages

    If the ProcessEernalMeetingMessages is set to 'False', run the command below to set it to 'True' and re-book the room calendar in the federated Org.

    1> Set it for one room calendar: 

    Get-Mailbox <RoomMailbox> | Set-CalendarProcessing -ProcessExternalMeetingessages $true

    2> Set it for all rooms:

    Get-Mailbox -RecipientTypeDetails RoomMailbox | Set-CalendarProcessing -ProcessExternalMeetingessages $true


    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, July 18, 2019 4:21 AM
    Moderator
  • Just checking in to see if above information was helpful. Please let us know if you would like further assistance.

    Regards, 

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, July 22, 2019 10:22 AM
    Moderator
  • Thanks, Manu.  I checked the room mailbox and it was set not to accept external meeting request.  I made the change and asked the user to try.  I think it will work.  One more question about the PS cmdlet.  For the following command how to only list the rooms with the option set to $true?

    Get-Mailbox -RecipientTypeDetails RoomMailbox | Get-CalendarProcessing | fl Identity,ProcessEernalMeetingMessages

    Thanks again.

    Monday, July 22, 2019 4:54 PM
  • Thanks, Manu.  I checked the room mailbox and it was set not to accept external meeting request.  I made the change and asked the user to try.  I think it will work.  One more question about the PS cmdlet.  For the following command how to only list the rooms with the option set to $true?

    Get-Mailbox -RecipientTypeDetails RoomMailbox | Get-CalendarProcessing | fl Identity,ProcessEernalMeetingMessages

    Thanks again.

    Sorry, a typo here, it is ProcessExternalMeetingMessages, not ProcessEernalMeetingMessages.

    Please use the following command to list the option set to $true:

    Get-Mailbox -RecipientTypeDetails RoomMailbox | Get-CalendarProcessing | ? {$_.ProcessExternalMeetingMessages -like "true"}

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, July 23, 2019 2:14 AM
    Moderator