none
Error when using office automation RRS feed

  • Question

  • Any program that tries to do any form of Office Automation crashes with a Microsoft Software Installer error 0x80004023.  I have found the error occurs when trying to create an object.  Example  ob=createobject("word.application").  I have tried this in a couple of languages.  It fails for Word, Excel, PowerPoint, Outlook, and Access.  One Note works.

    If the application is already open, I can attach to it and then automate it just fine.

    I am running Windows 7 64 and Office 2010 Pro 32 bit.  I had originally installed the 64bit version of office and automation worked.  I uninstalled the 64 bit and installed the 32bit because of plugin compatibility issues.  I have tried uninstalling and reinstalling multiple times to no avail.  I have used the "Fix It" utility in addition to the Control Panel uninstall.  The applications work just fine on their own.

    Any ideas on the cause?

    Thursday, September 16, 2010 6:01 PM

Answers

All replies

  • Hi,

     

    For the development issue, you need to ask the question in Office for Developers forum:

    http://social.msdn.microsoft.com/Forums/en-US/category/officedev,oldevelopment,sharepoint2010,sharepoint,projectserver2010,projectprofessional2010,uc/ \

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    • Marked as answer by Sally Tang Tuesday, September 28, 2010 8:57 AM
    Friday, September 17, 2010 6:15 AM
  •  

    Hi,

     

    I am writing to see how everything is going with this issue. Is the problem resolved? If there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com   

    Monday, September 20, 2010 6:31 AM
  • We are having the same problem. I also have uninstalled the product and reinstalled, repaired, patched and still have the issue. I removed Office 2010 and re-installed Office 2007 and the problem went away. I then re-installed Office2010 and the problem re-appeared.

    I have also deleted the registry key at HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Excel and let it rebuild and the problem persists.

    Another note: we have Office 2010 installed on other workstations and the problem does NOT occur.

    Has anyone solved this issue?

    Marvin Crossnoe

    nQativ

    Thursday, September 23, 2010 8:27 AM
  • I had excactly the same problem after replacing a previously installed Office x64 by the x86 version. It seems to be a problem of the Office 2010 x64 uninstaller, which does not remove the x64 COM registration properly. In my case, removing the registry key

    HKEY_CLASSES_ROOT\CLSID\{00024500-0000-0000-C000-000000000046}

    did solve the problem for Excel. There are similar keys for the other Office programs (which can be identified by the sub key 'ProgId'), but I did not tried them out.

    Please try first to rename the key, which has the same effect as deleting it - but this enables you to restore easily the previous state.

    Jürgen Weber

    • Proposed as answer by Djuu Tuesday, May 3, 2011 6:29 PM
    Wednesday, February 9, 2011 11:21 AM
  • Thx. It works for me.
    Tuesday, May 3, 2011 3:01 PM
  • Juergen,

     

    Many Many thanks!!

    It solves the problem, but not the cause. Who knows what else is left in the registry....

     

    Tuesday, May 3, 2011 6:30 PM
  • Hi,

    Firstly, I want to say a big "Thank You!" for writing the solution here. I was stuck receiving the same error, when trying to paste a picture into a MS Access form (in a picture box). After I read your post, I have opened Regedit, located the above key and deleted it... Instantly the message stopped to appear and now I am able to insert/paste pictures in that form!

    All my best,

    Florin

    Thursday, February 9, 2012 11:29 AM
  • To demystify the registry info this may help:

    Found at

    http://support.microsoft.com/kb/828550

    To examine the path key that is stored for the server, start the Windows Registry Editor, as follows:

    1. Click Start, and then click Run.
    2. Type regedit, and then click OK.
    3. Move to the HKEY_CLASSES_ROOT\CLSID key. 

      The CLSIDs for the registered automation servers on the system are under this key.
    4. Use the following values of the CLSID key to find the key that represents the Office application that you want to automate. Examine the LocalServer32 key of the CLSID key for the path.
      Office Server CLSID key
      Access.Application {73A4C9C1-D68D-11D0-98BF-00A0C90DC8D9}
      Excel.Application {00024500-0000-0000-C000-000000000046}
      FrontPage.Application {04DF1015-7007-11D1-83BC-006097ABE675}
      Outlook.Application {0006F03A-0000-0000-C000-000000000046}
      PowerPoint.Application {91493441-5A91-11CF-8700-00AA0060263B}
      Word.Application {000209FF-0000-0000-C000-000000000046}
    Thursday, March 21, 2013 3:53 AM
  • hi,

    i tried your solution by deleting 

    "HKEY_CLASSES_ROOT\CLSID\{00024500-0000-0000-C000-000000000046}" the i tried to run my app and got following :

    "Retrieving the COM class factory for component with CLSID {00024500-0000-0000-C000-000000000046} failed due to the following error: 80040154."

    Any solution?


    Aruna Bhayani

    Thursday, March 26, 2015 9:20 AM
  • Hi,

    Can you recall any solution to this issue?

    Thanks,

    Deepakkv

    Friday, May 29, 2015 1:21 PM
  • Hi,

    I too have automation problems. I am using Windows 8.1 and Office 365. After Office was activated, I lost automation.

    Using Access I get Automation error #-2147467229!!!

    I checked HKEY_CLASSES_ROOT\CLSID and found none as listed by jas051. He goes:

    "Examine the LocalServer32 key of the CLSID key for the path. " but there is no such key. How can I get the structure of those keys?


    • Edited by JLC_007 Tuesday, June 9, 2015 5:42 PM
    Tuesday, June 9, 2015 5:40 PM
  • Like other users here, when the user in our financial software attemps to email a PDF Accounting report, she gets the Microsoft Installer Error 0x80004023. She is using Outlook 2013 on a 64-bit machine.

    I attempted deleting (or renaming) the Outlook CLSID key as mentioned in this thread (0006F03A-0000-0000-C000-000000000046) but when I restart the Accounting program, it starts with error messages, like it is expecting that registry key. When I put the Registry Key back, then the program starts OK, but it doesn't solve the emailing/Outlook problem out of it.

    Any other suggestions or workarounds to fix this problem?

    Thanks

    Bill R

    Friday, March 25, 2016 8:04 PM
  • Regarding my post above, I should mention that the Accounting program has link buttons to launch both Outlook, Excel and Word. The Excel and Word buttons launch fine. It is only the Outlook that gives me the Windows uninstaller error 0x800004023.

    Thanks

    Bill R

    Friday, March 25, 2016 8:53 PM