none
Audience Membership and Rules RRS feed

  • Question

  • Hi all

    Im having trouble adding a rule to my audience that includes all members of a distribution list or security group in AD. 

    This is how it looks in 2007: http://img716.imageshack.us/img716/6788/moss2007.gif

    The members of the audience are populated by users being a member of 'NTU All Staff' as seen here: http://img716.imageshack.us/img716/3535/moss20072.gif

    Im trying to emulate that in SP 2010 but cannot seem to surface this (or any other) distribution/security group when i add a rule to an audience.  On creating a new audience called 'All Staff' and assigning an owner (not sure what this actually does, or who should own an audience), i go to create a rule to includes members of a group and get the following:

    http://img36.imageshack.us/img36/906/moss2010.gif

    Is there something i am missing here?  Can anyone shed any light?

    Cheers

    Asher 


    Fast, Cheep, Good. Choose any Two!
    Friday, July 30, 2010 10:21 AM

Answers

  • I don't remember exactly, but I know it wasn't for OUs.  I don't know how to assign entire OUs for permissions, but I do use security groups.  I would have only tested AD security groups when doing audiences.

    My users and groups show up as expected for permissions everywhere, but the groups do not show up in the profile database by DisplayName.


    SharePoint Architect || Microsoft MVP || My Blog
    • Marked as answer by Wayne Fan Thursday, August 12, 2010 10:03 AM
    Monday, August 2, 2010 5:53 PM

All replies

  • 86 views and nothing so far :(

    Can i add that i do have Users and Groups set in configure synchronization settings > Synchronization Entities.

    Also, i have no issue viewing these groups on my default site 80 when i want to manage permissions there. 

    So am i missing some permissions on central admin web app. maybe?  What and where anyone?

    Ash


    Fast, Cheep, Good. Choose any Two!
    Monday, August 2, 2010 1:35 PM
  • It's very likely related to the issue in my thread that you found, but MSFT is ignoring it completely - I have never seen this type of behavior on a bug report.  All the bug reports I gave during Beta were replied to like clockwork, but this one is being ignored, and I'm being told to call PAID support just to get help.  Unbelievable...
    SharePoint Architect || Microsoft MVP || My Blog
    Monday, August 2, 2010 1:58 PM
  • Hi Clayton

    I read through your post and the replies that were given make me think MS have some work to do on this.

    In your post you state that:

     'Security groups are working for permissions and audience targeting.  Confirmed my users are affected properly by the use of Security Groups'

    Does this mean you were able to create an audience and apply rules that allowed you to select AD accounts and/or OU's?

    Further confusion for me is that i can edit permissions in central admin for say, a document library, and all the AD users and groups appear as expected.

     

     


    Fast, Cheep, Good. Choose any Two!
    Monday, August 2, 2010 2:20 PM
  • I don't remember exactly, but I know it wasn't for OUs.  I don't know how to assign entire OUs for permissions, but I do use security groups.  I would have only tested AD security groups when doing audiences.

    My users and groups show up as expected for permissions everywhere, but the groups do not show up in the profile database by DisplayName.


    SharePoint Architect || Microsoft MVP || My Blog
    • Marked as answer by Wayne Fan Thursday, August 12, 2010 10:03 AM
    Monday, August 2, 2010 5:53 PM
  • Are you using claims based authentication? I ask because I have the same problem and I just found this blog post that states:

    Using Audiences with Claims Auth Sites in SharePoint 2010

    " You won’t be able to use a user-based for the audience, like member of a group (at least not without writing more code, which is beyond what I’m going to discuss in this posting).  Instead you’ll use the property-based audience."

    If this is true, I'm going to be kinda ticked, because this technet document says:

    "For new implementations of SharePoint Server 2010, use claims-based authentication. With this option, all supported authentication types are available for Web applications. There is no practical reason to select classic-mode authentication for new deployments, even if your environment includes only Windows accounts. Windows authentication is implemented the same way regardless of the mode that is selected. There are no additional steps to implement Windows authentication when you use the claims-based authentication mode."
    Wanting to keep the user-based audience feature seems like a pretty practical reason to me.
    Thursday, August 12, 2010 1:47 PM
  • I had a similar issue with particular groups not being able to be displayed under security groups, however I had forgot when I was setting up my UPS Service, I used this command in the SharePoint Powershell:

    stsadm -o setsiteuseraccountdirectorypath -path "DC=Domain, OU=People DC=ca" -url http://yoursite  enter your domain, enter the OU where you store your user accounts and then the site you are setting this for. I set this for oth my main site and the user mysites.

    Upon realizing this, I had to move a few groups I needed from another OU to my People OU under the specific area they would go, then I ran the synch and gave it a few minutes after and  then I was able to select them for audience targeting afterwards.

    Be sure you use iisreset after running the powershell command.

    Hope this is helpful - although I have not learned how to create Audiences within SharePoint as yet, so if anyone has a link/tutorial or otherwise, please post.

    Thanks


    SGGordy
    Thursday, September 16, 2010 3:01 PM
  • With some help from the InfoPath team, this became a real support ticket and eventually a Design Change Request.  The hope is that this change/fix will be implemented in SP2.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, December 29, 2010 6:09 AM