none
Cannot associate files with Word 2010

    Question

  • I loaded Office 2010 beta and have been able to associate xls files with Excel (that was not by default however), but I have not been able to figure out how to associate .doc files.  I tried associating them with the exe file that opens the application to no avail.  It just won't open.
    • Moved by Alicia CalesMicrosoft employee Wednesday, April 28, 2010 9:33 PM Forums Consolidation (From:Microsoft Office 2010 Application Compatibility)
    Saturday, December 19, 2009 1:09 AM

Answers

All replies

  • Mike, can you open the .doc files from within Word 2010?
    Saturday, December 19, 2009 1:16 AM
  • i have the same problem but i open files within word and have no idea how to associate them and everytime i save a document within word i can't open in the normal double click but can only open within word itself
    any help please
    Wednesday, January 20, 2010 5:01 PM
  • im having the exact same problem as well. as im sure everyone else who downloaded this program is.
    not a single microsoft office program comes up when you try to choose your default program.
    my biggest concern is word since the other programs appear to set themselves as the default program for opening files with a double click.
    i have not seen or been able to figure out a resolution to this problem. ive been at it for 3 hours now!!
    Thursday, January 28, 2010 12:03 AM
  • I too have this problem. Has anyone found a solution to this yet? I can't find the actually word program itself to associate it with in the default programs list. Any help appreciated.
    Monday, February 15, 2010 1:12 PM
  • I can open files from within Word 2010, but it is impossible to select Word 2010 as the "open with" application when right-clicking a document name. Word 2010 is not an option, not even with "Browse."
    Saturday, March 13, 2010 8:40 PM
  • Is there an answer here?  I'm having the same trouble.  I cannot associate .doc with Word2010

     

    Thursday, April 1, 2010 10:18 PM
  • I am having the same problem as everyone else here. I can only open doc, docx, and xls files from within the programs. I can't just double click the file icons. No Office programs show up when I try to associate the filetypes with an application.
    Wednesday, April 7, 2010 8:30 PM
  • I am having the same problem as everyone else here. I can only open doc, docx, and xls files from within the programs. I can't just double click the file icons. No Office programs show up when I try to associate the filetypes with an application.
    Wednesday, April 7, 2010 8:30 PM
  • Anyone could find a solution for this? Microsoft launched the official released with this problem unsolved? Anyone in MS has an answer?

    I have the same problem with all Office docs (xls, xslx, ppt, pptx, doc, docx). I can´t associate it even through "Open With"...ATB

    Friday, April 30, 2010 1:28 PM
  • Yep! I'm having the same problem.
    Monday, May 10, 2010 6:20 PM
  • same problem here, wtf
    Friday, May 14, 2010 12:32 AM
  • I had the same problem, managed to fix it by right-clicking on the file that i want to open (ie the one that wont open by default), clicking properties.

    on the general tab, click change, then choose microsoft microsoft office visualization handler.

    for some reason this didnt work with 'open with..' etc.

    Hope that helps, took me ages..

     

     

    • Proposed as answer by dyson34 Thursday, August 19, 2010 9:22 AM
    Friday, May 14, 2010 9:17 AM
  • What is that file name for microsoft microsoft office visualization handler?  and is found in the Microsoft Applications virtualization client folder?

    Thursday, May 27, 2010 5:28 PM
  • We are currently upgrading user to Office 2010,  to this we are un-installing previous versions of Office and using a batch file to install the new version.

    On some of the installations we are encountering a problem where .doc files loose their association with Word. When a user tries to double click an existing .doc file or an attachment it will not open - I can open Word and do a file an open and this does allow me to open the files.

    When I go back and try to re-associate .doc to Word it will not associate.  I can browse to Winword.exe in the Office14 directory and select Winword.exe as the file time to open .doc files.  When I get back to the main association dialog box Word does not appear in the list.

    This only seems to affect .doc files .docx are working fine.

    I am doing the install by making the user a local admin and completing the installation then removing the local admin rights.


    Thanks
    Thursday, June 10, 2010 1:57 PM
  • In case someone is still looking for an answer for this problem,

    - right click the document file that you're unable to open
    - select Properties
    - on the General tab, see if Microsoft Word is the program listed as "Opens with:".
    - if it's not associated with Word, click the Change button on the General tab.
    - click Browse and navigate to the installation location of Word 2010 (it will likely be under Program Files (x86), then Microsoft Office. Be sure to choose Office14 for Word 2010.)
    - select WinWord and click Open
    - click Ok then Apply, then Ok.

    That should do it! From now on, those .doc files will be associated with Word 2010.

    HTH.
    Tess


    Tess_H
    • Proposed as answer by denis hebert Tuesday, July 3, 2012 6:59 AM
    • Unproposed as answer by denis hebert Tuesday, July 3, 2012 7:03 AM
    • Proposed as answer by vanamala1 Saturday, July 21, 2012 10:51 PM
    Monday, June 14, 2010 5:44 PM
  • Well i tried that and it still won't work. Could it be the fact that i have a trial version.
    Friday, June 18, 2010 12:21 AM
  • Tried this & now OpenOffice is associated with .doc files !@#$%^
    Friday, June 18, 2010 12:57 AM
  • I spent about 4 hours on the phone over the last 2 days with MS Support.  The only solution that seemed to work was making a new user account and opening MSOffice from that user.  On the new account, .doc and .docx were correctly associated with Word, and Word appeared on the list when I selected "Open With"  However this meant I had to recopy everything from one user folder to another, which is a hassle and a time sink.  It makes me think it has to be something that can be fixed a different way, maybe within the registry.  The sad part was both support technicians seemed clueless as to this being a real issue and not something I was stupidly doing wrong, which makes me feel like MS is not really addressing it as a legitimate problem.
    Friday, June 18, 2010 2:37 AM
  • another one here with the same problem... I have a trial version too...

    Thursday, June 24, 2010 1:12 PM
  • doesn't work tess... the Office14 directory only has OneNote in it... perhaps it is related to the Virtualisatin engine...
    Thursday, June 24, 2010 1:15 PM
  • Ditto on having the same problem.  A friend of mine bought a new Sony laptop about two months ago.  It came with a 2007 trial version of Office Home and Business.  She was within two days of running out of the trail period so asked me to purchase the full version.  I chose to download Office Home and Business 2010.  After checking it out briefly (no didn't test Open With); I deleted the 2007 trial version.  I've tried almost everything listed above with no change.  This is a real issue especially for unsophisticated user who depend on double clicking on doc files or templates... neither one opens in Word... 

    This seems to have been going on for months... is there any prognosis for when a real fix will be available?

     

    Wednesday, June 30, 2010 1:16 PM
  • Thank you!! Your solution worked perfect! I did have to reinstall the software from disc though. At first I had downloaded the trial version and it was missing the WinWord so I installed from disc and it worked perfectly!
    Wednesday, June 30, 2010 3:16 PM
  • Reinstall from disc. Initially, I downloaded the trial version and also only had OneNote so I installed from disc and WinWord appeared.
    Wednesday, June 30, 2010 3:18 PM

  • Reinstall from disc. Initially, I downloaded the trial version and also only had OneNote so I installed from disc and WinWord appeared.

    Really? We have to reinstall? What about repair? I have the full version of Office pro 2010 and had an old word 2007 originally associated with my doc files. I uninstalled word 2007 after installing 2010.

     

    So are you saying for people who had a program associated with a doc file that did not uninstall it first before installing 2010 have to uninstall 2010 and reinstall or should it just be reinstalled over the current one?

    Saturday, July 3, 2010 2:45 PM
  • I had the same problem on Windows 7 OS.  I managed to fix it by simply going to Control Panel/Uninstall Program,  right clicking on MS Office and choosing the "change" option, this then performed a "repair" of the application and the association issue was fixed.
    • Proposed as answer by chapoutier Saturday, July 10, 2010 12:34 AM
    Sunday, July 4, 2010 8:55 PM
  • Adrianfarrell:

     

    THANK YOU!!!

     

    I am currently using a trial version of Office 2010 and your solution worked like a charm!  Only wish I would have found it 3 hours ago.

    Saturday, July 10, 2010 12:34 AM
  • Thanks Adrianfarrell for that advice.  I called technical support and they were clueless and referred me to this site.  After using your method, Microsoft Client Virtualization Handler appeared which allowed me to open the .doc extension file.  I now have assigned it to open those types of files.  Good job.
    Friday, July 23, 2010 10:10 PM
  • Thanks Adrianfarell!!!

    Thursday, August 5, 2010 2:22 PM
  • Hello Tess,

     

    When I follow your instructions, I get to Office14 and click, then I get an icon for OneNote, nothing else. What might I be doing wrong?

     

    Thanks,

     

    Markinsanfran

    Sunday, August 15, 2010 1:29 AM
  • I had the same problem, managed to fix it by right-clicking on the file that i want to open (ie the one that wont open by default), clicking properties.

    on the general tab, click change, then choose microsoft microsoft office visualization handler.

    for some reason this didnt work with 'open with..' etc.

    Hope that helps, took me ages..

     

     


    I was having the same problems as everyone else on this.

    .doc files couldn't be doubled clicked and opened in word 2010, only onenote appears in office14 file etc...

    Although the .doc files already appear to be associated with "microsoft office visualization handler"

    Not in word, go into a folder that contains a .doc file.  Right Click.  Choose Properties and on the general tab click change.

    Although it shows "microsoft office visualization handler" as being associated with the file already, select it again and hit okay.

    It's a miracle, all my files now show a little blue W and can be opened in 2010.

    Took me a long time to find this solution, thanks Fuz_au

    This is the only solution that worked for me, hope it works for you.

    • Proposed as answer by dyson34 Thursday, August 19, 2010 9:28 AM
    Thursday, August 19, 2010 9:28 AM
  • Adrianfarrell:

     

    Thanks for the post.  Worked like a charm.  This solution made my day!

    Sunday, August 22, 2010 12:10 PM
  • I had the same problem on Windows 7 OS.  I managed to fix it by simply going to Control Panel/Uninstall Program,  right clicking on MS Office and choosing the "change" option, this then performed a "repair" of the application and the association issue was fixed.

    So pleased this worked!!! thanks so much!!!
    Sunday, August 29, 2010 9:08 PM
  • I was having the same issue. Now although I still get an error when I double click at least it opens.
    Tuesday, September 14, 2010 4:21 AM
  • I don't know who you are but I LOVE you..........IT WORKED

    I have been tentatively trying to solve this for week, (on and off), as I am no Techie and was terrified I would lose everything!!!

    I've been closed to tears and had no one to ask.

    Thank you

    Wednesday, September 15, 2010 9:37 PM
  • @Fuz_au This procedure worked exactly as you described and solved my problem! 

    My situation started liked this:  New PC.  Trial Version of Office 2007.  2010 Came out.  I bought a licensed copy of MSOffice 2010 Home and Business.  I had purchased the Product Key only so I wouldn't spend an extra $80 for a CD.  But, I had to uninstall Office2007 and then the trial version of Office2010 that I had downloaded was Professional, so I had to uninstall that and download Office Home and Business.  Somehow along the way I lost the file association.  Your fix worked perfect, thanks for saving me a call to tech support!!! 

    • Edited by New2MS2010 Thursday, September 30, 2010 3:14 PM referenced the user I responded to
    • Proposed as answer by New2MS2010 Thursday, September 30, 2010 3:14 PM
    Thursday, September 30, 2010 3:13 PM
  • Tess,

    thank you, thank you, thank you!!!!  You are a genius.  I had spent two days trying to get the answer from Microsoft to no avail and you solved my problem in five minutes.

    Monday, October 4, 2010 10:41 PM
  • I've "repaired" Office 2010 and rebooted, but when I right-click on a file, click properties, and click change, microsoft office visualization handler does not appear (I just get OpenOffice and WordPerfect options).  The file is a .doc file.
    Monday, October 18, 2010 2:33 PM
  • I did that but Microsoft Client Visualization Handler did not appear. How do I get that thing to appear so I can associate files with it?
    Monday, October 18, 2010 2:36 PM
  • What if "microsoft office visualization handler" does not appear? Any way to ensure that thing pops up?
    Monday, October 18, 2010 2:37 PM
  • SUPER!! THANK YOU for the fix. Kudos to you for sharing this :)
    Thursday, October 28, 2010 6:48 AM
  • Amazing! This did it. As a note, I had to resassociate the files a few times with the newly revealed Client Visualization Handler for it to actually "take" after performing Adrian's fix. When the icons magically became the Word "Ws" we were finally good.

    What a bizarre problem to have though. 

    Tuesday, November 2, 2010 3:50 AM
  • I have MS Office 2010 Professional.  I tried everything on this forum including Open With, Properties, Repair, and the rest.  Nothing worked. 

    I found a free program that will enable you to change file associations.  I can only assume it alters the Windows registry, because it works.  It can do several other things as well.  I used it to add Winword to the Open With list, then was able to use the standard Open With command to associate Winword with .doc files, permanently.  (Whoo Hoo!).

    Good luck, here is the program. 

    Default Programs Editor for Windows

    http://www.nirmaltv.com/2010/02/23/default-programs-editor-for-windows/ 

    Wednesday, December 1, 2010 2:22 PM
  • I bought Microsoft Office Pro 2010 and when I first installed the components ran properly. I could open a doc file from the internet with Word and everything ran fine. For the last month or so, everytime I try to open a .doc file it gives me some bullcrap about how I don't have a program that will run the .doc file. When I click on the file from the internet it says i need to save it or find a program online to open it with. I dont know what changed to make it start doing this but its a hassel to have to save the file everytime just so i can view it. Any help would be nice.     THANKS
    Friday, December 3, 2010 5:35 PM
  • Good luck, here is the program. 

    Default Programs Editor for Windows

    http://www.nirmaltv.com/2010/02/23/default-programs-editor-for-windows/ 

    Friday, December 3, 2010 9:00 PM
  • I also had same problem .doc file not opening with Office 2010. From the file, i right clicked selected properties and from general tab below advanced button available under the group attributes there was a button called unblock. When I clicked unblock, system warns that the file was created in other machine and when you allow it, that file is opened in Office 2010. Hope this may help in some cases where office visualization handler is not a problem.

    Regards,

    Lakshmi Narasimhan.

    Tuesday, December 7, 2010 11:44 AM
  • HERE is the answer thank GOD

    Adrianfarrell Users Medals Users Medals Users Medals Users Medals Users Medals is my hero

    Sunday, January 2, 2011 8:04 AM
  • This is what worked for me:

    "I had the same problem on Windows 7 OS.  I managed to fix it by simply going to Control Panel/Uninstall Program,  right clicking on MS Office and choosing the "change" option, this then performed a "repair" of the application and the association issue was fixed."

    by Adrianfarrell Users Medals Users Medals Users Medals Users Medals Users Medals quoted from below

    :)
    Sunday, January 2, 2011 8:08 AM
  • Wasted hours and hours over several days on this problem before finding this message board. Haven't tried Adrian's fix or any other here yet.... it's after midnight and I have to get up at 6am. Saved this site to My Faves and I'll come back and try these fixes later.

    Heads should roll at Microsoft over this.

    Wednesday, January 5, 2011 6:50 AM
  • I had the same problem on Windows 7 OS.  I managed to fix it by simply going to Control Panel/Uninstall Program,  right clicking on MS Office and choosing the "change" option, this then performed a "repair" of the application and the association issue was fixed.

    Andrianfarrell i wanna thank you personally for sharing this valuable information. I have no idea if this will help people with the same system configuration as me.

    Vista home Premium 32 bit and have trial version of Office too.

    Followed Andrian's advice and Virtualization Handler came out from nowhere for me to select after i rebooted.

    Now the association is made for doc files through my email too.

    Good luck and many thanks to our mentor ANDRIAN!

    Friday, January 21, 2011 11:43 AM
  • Wonderful idea but it doesn't work. Any other ideas?
    Tuesday, February 8, 2011 3:20 AM
  • That's not new. :(
    Tuesday, February 8, 2011 3:21 AM
  • That doesn't work, at least not for everyone here. I have Windows 7 if that makes a difference.
    Tuesday, February 8, 2011 3:24 AM
  • Hi,

    To everyone who's still stuck with this problem I have the Pro Plus 2010 version activated running on windows 7 and the suggestions of repairing, changing details in the properties etc. never worked. Even after using the repair and restarting the files never associated with word but all others within office were fine. On a whim i tried the 'default programs editor for windows' and just added winword to the list of options for 'open with' and forced it to associate that way. It actually worked, so if you have windows 7 and nothing else has worked try that program.

    Cheers,

    Cillista

    Sunday, May 22, 2011 3:41 PM
  • How did you add winword to the "default programs editor for windows"?
    Wednesday, September 7, 2011 6:17 PM
  • Windows 7 Pro OS, 2010 Office Starter Edition.

    Even thought the xls and doc file extensions are associated with the virtualization handler, they will not open the program when double clicked.

    I used the default programs editor, associated the xls and doc file extensions with wordpad ( I suppose any other program will do) tried to open the files, they did but were garbage, closed the files, used the default programs editor to associate the extensions with the virtualization handler, double clicked the files to open and it worked.

    Repair didn't work, editing the registry did not work nor did any of the other suggestions in this thread.

    Microsoft should be ashamed for creating this issue.

    Wednesday, October 5, 2011 12:34 AM
  • Thank you very much for letting me know about Default Programs Editor because I had tried the 'repair' suggestion above  and unfortunately it did not work. Scrolling down this list I found your suggestion. I downloaded the program and it worked. It is definitely worth a Whoo Hoo!
    Tuesday, November 8, 2011 9:44 AM
  • Yes! It worked for me too (although I don't know why). Thank you!
    Sunday, February 5, 2012 6:28 PM
  • Hi Tess,

    Thanks a lot, problem gone.

    I appreciate.

    Naresh.

    Saturday, July 21, 2012 10:50 PM