none
Excel 2013 error on open: "We're sorry, but Excel has run into an error that is preventing it from working correctly. Excel will need to be closed as a result."

    Question

  • I installed Office 2013 (365 subscription-based) on a Windows 8 computer that had Office 2010 installed previously. After the install I also uninstalled the old version. Everything runs perfectly well except Excel, which on running (both normal and safe mode) delivers an error: "We're sorry, but Excel has run into an error that is preventing it from working correctly. Excel will need to be closed as a result.".

    The options presented (except close) are to repair it (online or offline). I tried both repair options, none worked. 

    Last step: I uninstalled completely the Office 365 and re-installed it again from office.com/setup. Same final result.

    The only possibility now to use Excel is through web apps, which is pretty limited. Please, any solution other then re-installing the entire Windows from scratch?!

    Thanks!

    Thursday, June 13, 2013 1:11 PM

Answers

  • I found the issue: the excel.exe was configured to run in compatibility mode for windows 7... I have windows 8. In order to correct it: excel.exe -> right click -> properties -> compatibility -> make sure the "run this program in compatibility mode for" is unchecked if you have windows 8 installed. :)
    Thursday, June 20, 2013 10:54 AM

All replies

  • Hi,

    Then start Windows in clean boot to check whether the issue is caused by some third party services.


    Jaynet Zhang
    TechNet Community Support

    Friday, June 14, 2013 3:38 AM
    Moderator
  • Thanks for the quick reply, I just tried that... Excel would not start at all in that moment... is there a service that I should allow it to run? I disabled all of them for the clean boot. 
    Friday, June 14, 2013 8:52 AM
  • I found the issue: the excel.exe was configured to run in compatibility mode for windows 7... I have windows 8. In order to correct it: excel.exe -> right click -> properties -> compatibility -> make sure the "run this program in compatibility mode for" is unchecked if you have windows 8 installed. :)
    Thursday, June 20, 2013 10:54 AM
  • Do you have bins (http://www.1upindustries.com/bins) installed? If yes, uninstall it... I know it sounds stupid, but it seems there is an incompatibility with it.
    Friday, March 28, 2014 3:22 PM
  • Nope.
    Friday, March 28, 2014 8:36 PM
  • You are the best! I wasted TONS of time this weekend uninstalling/reinstalling Office, messing with video drivers (apparently some NVidea graphics drivers can cause issues w/Excel), etc. Not sure how my compatibility setting got changed in the first place, but bottom line is, your fix did it!

    Thanks very much, GREATLY appreciated!

    Monday, January 26, 2015 6:15 PM
  • I had similar issues but due to some reasons 'compatibility' tab was non-existent in my properties tab. I thus did the following-  Right Click on Excel.exe-->Trouble Shoot Compatibility-->Troubleshoot Program-->Check the program worked in earlier version-->Check windows 8-->test it--->(if it works, you are done!). Uptil, my excel seems to be working fine.
    Sunday, May 10, 2015 4:30 AM
  • When I right click properties, there is no option of 'compatibility'. I am now on Windows 10.
    Friday, August 07, 2015 3:44 AM
  • Ran in to the same thing on my desktop, however my laptop does have the compatibility option. Both are on Windows 10. Checking the Window 7 compatibility option on my laptop produces the same error that appears on the desktop, so unchecking that option is the fix. Why don't I have that option on my desktop?!
    Friday, August 07, 2015 4:23 PM
  • I had a user that put Windows 10 on her PC and once she installed Office 13 / 365 she ran into the same issue.

    The above mentioned solution worked for her as well on windows 10.

    Thanks

    Nathan

    Wednesday, August 26, 2015 9:26 PM
  • Try changing the properties to give Administrator privelages.  I'm using Windows 7, but this should work across all platforms.  In Properties, choose the Shortcut Tab.  Click "Advanced" and check the box that says "Run as Administrator".  Hopefully you should only have to do this once.  Run Excel.  Then close, repeat above steps but uncheck the box.  Then try re-opening Excel.  This worked for me. 

    If you are using the Office 365 subscription-based version, try signing out before you complete the above steps.

    Monday, September 21, 2015 2:34 AM