none
Outlook 2016 will not save drafts RRS feed

  • Question

  • I noticed this problem back in 2016 but was too busy to report this. When I create emails and save them they don't save to draft.

    I then close the client and email is lost forever. Why isn't this saving and what is causing this?

    • Edited by ResidentX10 Friday, August 25, 2017 5:34 PM
    Friday, August 25, 2017 5:29 PM

Answers

  • I see the problem now. The "drafts" ARE being saved but not into the rich client only the web client. 

    Notice the screenshots:

    Outlook Rich Client(OWA saved draft at 9:27 came down to rich client):

    Outlook Web Client(This showed my original 8:23 draft and the ones I saved at 9:26):


    • Edited by ResidentX10 Friday, February 2, 2018 2:37 AM
    • Marked as answer by ResidentX10 Friday, February 2, 2018 2:37 AM
    Friday, February 2, 2018 2:36 AM

All replies

  • 1. Also, what is the difference between 'Save' and "Save As?"  "Save" I thought saved to the local Draft folder but I guess "Save As" Lets you save it anyway with a different format?
    Friday, August 25, 2017 5:37 PM
  • Hi ResidentX10,

    I tested in my Outlook 2016 (16.0.7726.1049) by creating a new email and pressing the Save button, the email can be saved into Draft folder as expected:

    If I press "Save As", a Save As dialogue box pops up asking me to save the email into some where as .msg or other formats:

    In your situation, please try to search in all Mailboxes to see if the drafts are saved to other folders. It is also suggested to try running Outlook in safe mode (Press Win + R, type "outlook /safe", press Enter.) and see if there will be any improvement.

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, August 28, 2017 3:35 AM
    Moderator
  • I just did it again and the drafts are not saving consistently. My version is a click to run version 1707 build 83262076

    Outlook Version: 16.0.8326.2076

    • Edited by ResidentX10 Monday, August 28, 2017 9:55 AM
    Monday, August 28, 2017 9:54 AM
  • Hi ResidentX10,

    Is this a recently happened issue in your situation?

    I tested further in both Version 1707, Build 8326.2073 and Version 1707, Build 8326.2076, but still cannot reproduce the issue. 

    Please have a check via File > Options > Mail > Save Messages, make sure the folder is set as Draft:

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    • Marked as answer by ResidentX10 Monday, August 28, 2017 12:46 PM
    • Unmarked as answer by ResidentX10 Monday, August 28, 2017 5:15 PM
    Monday, August 28, 2017 12:10 PM
    Moderator
  • Thanks for the screenshot, Yuki. I adjusted the time from 3 minutes down to 1 minute. 

    I did have it saved to Drafts but I know I was not waiting 3 minutes. This would also explain the haphazard saving of the emails. I had some that saved but others didn't. 

    Thanks for your help. 

    Monday, August 28, 2017 12:46 PM
  • Hi ResidentX10,

    You re welcome :)

    You can also mark your resolution above as answer so that others who stuck with the same situation can more easily find the useful information.

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, August 28, 2017 12:59 PM
    Moderator
  • I marked it...
    Monday, August 28, 2017 1:19 PM
  • This still not saving automatically or manually...we need to open a case
    • Edited by ResidentX10 Monday, August 28, 2017 5:15 PM
    Monday, August 28, 2017 5:15 PM
  • Hi ResidentX10,

    Does this issue affect all users in your environment?
    Have you checked in safe mode to see the result?

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Tuesday, August 29, 2017 1:58 AM
    Moderator
  • Yes. This is a problem on all click to run versions. Originally, I had installed the on-premise version but I guess Microsoft converted them when it updates. This could possibly be the problems. Are there different locations to get updates for Office On-premise vs. Office Cloud now?  Basically, I'm asking if there is a way to manually install patches so I can get off automatic updates. 

    Tuesday, August 29, 2017 1:05 PM
  • Hi ResidentX10,

    >> Are there different locations to get updates for Office On-premise vs. Office Cloud now?  Basically, I'm asking if there is a way to manually install patches so I can get off automatic updates. 

    By "Office On-premise vs. Office Cloud", do you mean the MSI version of Office vs Click-to-run version? 

    If this is the case, for MSI edition, we can turn on automatic updating for Windows through Microsoft Update to get Office updates. See this article for more information. For C2R edition, by default, Click-to-Run installations of Office 2016 are configured to automatically update your Office installation when new updates are made publicly available. 

    Regarding your concern about getting off automatic updates, you may refer to the following article to disable the automatic updates via Group Policy:

    https://support.office.com/en-us/article/Configure-update-settings-for-Office-365-ProPlus-a073ea21-62ed-40ef-8405-fd287f7d0b11

    Best regards,
    Yuki Sun

    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, August 30, 2017 6:23 AM
    Moderator
  • This is happening in the web client too. How did a MSI product get converted to click to run?
    Thursday, August 31, 2017 12:29 AM
  • Hi ResidentX10,

    >> This is happening in the web client too.

    By this, do you mean the missing draft cannot be found in OWA? Or do you mean you tested in OWA by creating a new message and clicking Save Draft, but the draft did not appear in OWA?

    Best regards,
    Yuki Sun 


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, September 1, 2017 5:04 AM
    Moderator
  • The latter...
    Friday, September 1, 2017 5:08 AM
  • Hi ResidentX10,

    Have you checked in Deleted Items folder to see if the drafts are there?
    Does this issue occur to all users' Exchange accounts in your environment?

    As the problem persists in OWA, I am assuming that the issue might be more related to the Exchange sever side.
    What's the version of your Exchange sever? It is suggested to post a new thread with the current finding into the Exchange forum for further assistance.

    By the way, for security concern, I'd like to recommend you to remove the email addresses in the images shared in your original thread.

    Best regards,
    Yuki Sun 


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, September 1, 2017 7:46 AM
    Moderator
  • Hi Yuki,

    We talked about this a few months back but the situation continues to persist. 

    Let me update you on my status now. 

    I have reformatted my machine with Windows 10 1709. I now have a "fresh" installation of Windows. 

    I have installed only the Click 2 Run Version of Office 2016 from my Office 365 Account. Before I had two versions that both got updated by click to run. 

    I tried to create a document tonight and save to draft but it will not save. Here are my current settings and version of click to run. Can you verify this on your end please?



    • Edited by ResidentX10 Friday, February 2, 2018 2:12 AM
    Friday, February 2, 2018 2:03 AM
  • I see the problem now. The "drafts" ARE being saved but not into the rich client only the web client. 

    Notice the screenshots:

    Outlook Rich Client(OWA saved draft at 9:27 came down to rich client):

    Outlook Web Client(This showed my original 8:23 draft and the ones I saved at 9:26):


    • Edited by ResidentX10 Friday, February 2, 2018 2:37 AM
    • Marked as answer by ResidentX10 Friday, February 2, 2018 2:37 AM
    Friday, February 2, 2018 2:36 AM
  • Hi ResidentX10,

    Great to see that you have found the problem and many thanks for your sharing! :)

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, February 2, 2018 2:48 AM
    Moderator
  •  I need you to confirm this and report this as a bug issue so it can be fixed...can you do that?
    Friday, February 2, 2018 3:56 AM
  • Hi Everyone,

    I had the same problem that new emails are not autom. saved as draft in OL2016 rich client, but in O365 online version it will be saved as draft.

    In my case in

    File - Options - Trust Center - Trust Center Settings - Email Security - Encrypted Email 

    the checkbox "Add digital signature to outgoing message" was checked because I send outgoing Messages with digital signature.

    Solution:
    After the checkbox was disabled my new emails are saved autom. in draft folder again.

    Dont know if this is by design or a bug, maybe this tip can help someone with same configuration.

    Tuesday, February 20, 2018 11:55 AM
  • Hiltls,

    I got on the phone with Microsoft support and they looked at this closely after I talked to the Product Manager. A fix is on the way for this. The problem is because of "Cached" mode in the Rich client.

    Tuesday, February 20, 2018 5:15 PM
  • Hi,

    Any fix for this? I got the same problem for my client.

    Thanks!

    Wednesday, March 28, 2018 1:00 AM
  • Close this. I opened a ticket in the office365 portal and they logged the bug and acknowledged it. It may have been patched now but the problem was the cached mail. It has to be turned off. 
    Wednesday, March 28, 2018 5:27 AM
  • I'm having the same problem as described above - drafts save online but not pc client. Can you describe what you mean by "the cached mail"? Did you find a solution?
    Friday, April 27, 2018 6:47 PM
  • I opened a ticket and they turned off "cached" mail in the settings. They said they were going to fix it but they didn't I guess now.


    Friday, April 27, 2018 8:08 PM
  • This still appears to be an issue, and very annoying.  I  wrote a long email while on an aircraft last night - no wifi was available.  I clicked save, assuming it'd go into drafts, but it did not.  <g class="gr_ gr_574 gr-alert gr_gramm gr_inline_cards gr_run_anim Punctuation only-ins replaceWithoutSep" data-gr-id="574" id="574">Obviously</g> it could not get into OWA either, so I lost the message completely.  An hour of effort that'll have to be redone...

    Frustrating.  Why does it behave like this<g class="gr_ gr_740 gr-alert gr_gramm gr_inline_cards gr_run_anim Punctuation multiReplace" data-gr-id="740" id="740">..</g>

    Thursday, May 10, 2018 11:36 PM
  • Ok, so I had this problem today, and as noted by @ResidentX10, the issue is that Drafts are being saved, but only appearing on the OWA Web Client and not in Outlook. Some further testing on my end revealed that the problem is actually Outlook on my PC. Further, it's my specific copy of my Outlook profile. New profiles synced to my Exchange account have no issue.

    The problem appears to be corruption in my local Outlook data, due to my account being set for "Cached" mode.

    The solution: I turned Cached mode off and restarted Outlook, and now my missing Drafts have reappeared. I've since re-enabled Cached mode, and new drafts still properly save to the Drafts folder. Hopefully it is fixed for good! But I'm sure I'll have to repeat the procedure eventually :-/


    • Edited by apraetor Monday, September 24, 2018 11:27 PM solution
    Monday, September 24, 2018 11:26 PM
  • To turn off Cached mode with the C2R client (Office 365):

    1. In Outlook, select “File” > “Account Settings” > “Account Settings“.
    2. Select (or double click) the Exchange account name in the list.
    3. Uncheck or check the “Use Cached Exchange Mode” box to disable or enable it. 

    Tuesday, September 17, 2019 1:17 PM
  • The big problem in the "missing" emails is that the default sorting in Drafts-folder does not show the newest drafts on top of the list, if the draft has not a certain kind of date-stamp in it.

    Only those drafts will appear on top of the Draft folder, which will have Date-info. And it is a mystery which drafts will get/will be generated with that date info,

    So at the moment, my newest drafts will appear weirdly after the oldest drafts, because the new drafts do not have a date stamp.

    If you sort the Draft-folder by Start date and not by Date (Please note i'm not sure what those are exactly in English UI), the "missing" drafts will be listed as they naturally should.

    For some reason the new drafts are naturally visible in top of the list in the Advanced find, even it has the same default sorting option (Date) chosen, as by default view in Drafts folder.

    So this is definitely a big annoying (UX) bug - this has been haunting me in my previous job as well (as i haven't tracked the root cause before). And how many people in the world have started to write a "new" emails from "scratch", not knowing that the (long) missing draft was actually saved.


    Tuesday, September 24, 2019 11:25 AM