none
Windows could not start the Server service on local computer Error 193:0xc1

    Question

  • Hello,

    Not able to start Server (lanmanServer) Service in Windows Server 2008 R2 

    Its a VM and on logging into the Server it sometimes shows as started and then will stop by itself,

    If we try to start manually it always gives the error --Windows could not start the Server service on local computer Error 193:0xc1

    All dependent services are fine and running ,did sfc,did copy svchost and svcsrv.dll files from a working Server of same.but no help,no shares of this server are accessible since this service is not running

    on checking the event log its shows an error "Server is not a valid win32 application"

    Please help

    Thanks and Regards

    Jose

    Tuesday, January 21, 2014 3:43 PM

Answers

  • Dear All,

    The Issue is Fixed Now....
    what we did is we mounted the DVD iso and  tried doing an Upgrade to the OS Windows 2008 R2 Std
    It continued and on the step Gathering user files ,settings... it gave an error . Windows installation encountered an unexpected error.Verify that the installation sources are accessible,and restart the installation Error Code:0xC0000005
    Then we copied the Windows 2008 R2 Std SP1 DVD content to the Server and tried doing an Upgrade to the OS Windows 2008 R2 Std the same above error came up

    Now we did a clean boot ,disabling all other services apart from microsoft's

    So the Upgrade did the Repair!! without removing the configurations!!

    Hurray!! the installation went throiugh and after login we found that the server service was started with all dependent service functional and no error , fixed without lossing any data!!! or configuration!! ( Server was part of Domain as well)

    On reboot all services enabled which were disabled before the upgrade!

    NB:
    We made a backup of the VMDK.Flat and other contents of this server before performing this upgrade just in case if anything goes wrong..
    Ensure backup is taken

    Should Thank..

    http://www.networksteve.com/forum/topic.php/Repair_Server_2008_R2_system_files_with_DVD_/?TopicId=15477&Posts=0

    ((Hi, You can repair the Windows Server 2008 R2 system but there are some differences. In previous systems, you can boot from the disk and then repair the system. In Windows Server 2008 and Windows Server 2008 R2, you should run the disk from the current system to perform an In-place Upgrade. For example, if you are running Windows Server 2008 R2 Enterprise, you can insert the installation disk, double-click setup.exe and install Windows Server 2008 R2 Enterprise again over the current system. Normally your personal data will not be destroyed after that. But it is still recommended to back up your important files first. Tim Quan ))

    for giving this hint of repairing!

    Thanks and Regards
    Jose





    • Marked as answer by JosephBoban Tuesday, January 28, 2014 2:03 PM
    • Edited by JosephBoban Tuesday, January 28, 2014 2:12 PM updated
    Tuesday, January 28, 2014 2:03 PM

All replies

  • What Event ID# and Source Name is that event? Is it EventID 7000? If yes:

    Event ID 7000 and "%1 Is Not a Valid Win32 Application" Error Message When You Start a Service
    http://support.microsoft.com/kb/812486

    You receive a "Not a Valid Win32 Application" error message when you start SharePoint Portal Server
    http://support.microsoft.com/kb/325680

    *

    What's installed on this server? SQL, SharePoint, Exchange?

    Is it a DC?

    *

    Here's one where it was SQL causing it:
    Error 193: 0xc1 – Weird but solved!
    http://www.brainlitter.com/2008/10/09/error-193-0xc1-weird-but-solved/

    If there was a power outage or similar forcing the VM into a stopped state, maybe something got corrupted? Here's more info on that in this discussion:
    http://answers.microsoft.com/en-us/windows/forum/windows_xp-performance/error-193-0xc1-cannot-start-computer-browser-on/4a344bc7-fe5e-e011-8dfc-68b599b31bf5

    Thread: ".net Service gives wierd error when starting.  Error 193: 0xc1"
    http://social.msdn.microsoft.com/Forums/vstudio/en-US/41452aac-13f9-4e7a-97a7-9a116681c832/net-service-gives-wierd-error-when-starting-error-193-0xc1?forum=vbgeneral


    Ace Fekay
    MVP, MCT, MCITP/EA, MCTS Windows 2008/R2 & Exchange 2007, Exchange 2010 EA, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Technical Blogs & Videos: http://www.delawarecountycomputerconsulting.com/

    This post is provided AS-IS with no warranties or guarantees and confers no rights.

    FaceBook Twitter LinkedIn

    Tuesday, January 21, 2014 9:09 PM
  • Hello Ace,

    *EVENT ID 7023, Service Control Manager

    *This Server is having Veritas NetBackup

    *Checked and did find any file by the name program or common in C:

    Thanks and Regards

    Jose

    Wednesday, January 22, 2014 3:55 AM
  • Is the Computer Browser service running?

    Was anything added/installed, or removed lately?

    Any errors with Veritas?

    I can't find anything specific for EventID 7023, Service Control Manager, with error "Server is not a valid win32 application." Was there something left out of the Event? Can you use the copy function and paste the whole thing, please?

    If you can't due to security policies in your company, you can look here to see if it helps:
    http://www.eventid.net/display-eventid-7023-source-Service%20Control%20Manager-eventno-345-phase-1.htm

    *

    Or perhaps this may help:

    Event ID 7023 — Service Stop Operations
    http://technet.microsoft.com/en-us/library/cc756318(v=WS.10).aspx

    *

    Have you ran a virus scan and an anti-malware scan (www.malwarebytes.com) just in case?


    Ace Fekay
    MVP, MCT, MCITP/EA, MCTS Windows 2008/R2 & Exchange 2007, Exchange 2010 EA, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Technical Blogs & Videos: http://www.delawarecountycomputerconsulting.com/

    This post is provided AS-IS with no warranties or guarantees and confers no rights.

    FaceBook Twitter LinkedIn

    Wednesday, January 22, 2014 9:33 AM
  • Hello Ace,

    Error 22-01-2014 18:00:32 Service Control Manager 7023 None

    Friendly View

    -------------

    - System 


      - Provider 

       [ Name]  Service Control Manager 
       [ Guid]  {555908d1-a6d7-4695-8e1e-26931d2012f4} 
       [ EventSourceName]  Service Control Manager 
     
      - EventID 7023 

       [ Qualifiers]  49152 
     
       Version 0 
     
       Level 2 
     
       Task 0 
     
       Opcode 0 
     
       Keywords 0x8080000000000000 
     
      - TimeCreated 

       [ SystemTime]  2014-01-22T12:30:32.086098000Z 
     
       EventRecordID 26435 
     
       Correlation 
     
      - Execution 

       [ ProcessID]  568 
       [ ThreadID]  656 
     
       Channel System 
     
       Computer XXXXXXXX
     
       Security 
     

    - EventData 

      param1 Server 
      param2 %%193 

    -------------------------------------------------

    Computer Browser is started

    Thanks and Regards

    Jose

     
    Wednesday, January 22, 2014 1:02 PM
  • Note: The Server service is what "shares" data, such as allowing the ability to access across the network, share files, share printers, etc. This is determined usually if File & Print sharing is enabled. By default on a server OS, this is usually enabled and started.

    In contrast the "Workstation" service is on one computer will connect to the Server Service on another.

    -

    So something is misconfigured to not allowing it to start...

    Is File & Print Sharing enabled in the NIC? Is the executable or process allowed in the Windows firewall?

    Is there an antivirus on this server that may be blocking this service and an exception not configured? You would be surprised how many times we hear antivirus apps causing issues with their network and other additional protection features that are enabled.

    Is there a GPO applying to the server that is meant for workstations?

    How about Network Location the interface is set to. I assume it's set to Domain or Work, and not Public or Unknown, which may also stop it.


    Ace Fekay
    MVP, MCT, MCITP/EA, MCTS Windows 2008/R2 & Exchange 2007, Exchange 2010 EA, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Technical Blogs & Videos: http://www.delawarecountycomputerconsulting.com/

    This post is provided AS-IS with no warranties or guarantees and confers no rights.

    FaceBook Twitter LinkedIn

    Thursday, January 23, 2014 7:41 AM
  • Hello Ace,

    File & Print Sharing is enabled on NIC

    AV is removed from Server

    Windows Firewall is stopped and disabled

    Another Server of same config its working on Domain.

    One thing that we observed is we renamed the srv.sys and srv2.sys from drivers and then tried to start the Server Service and it failed with error dependency service not started, then we restarted the server and corrected the name to srv.sys and srv2.sys and tried starting the service and the service got started!! but on a refresh the service stopped and again the same error popped up (

    Windows could not start the Server service on local computer Error 193:0xc1)

    So on repeating this exercise we see that the service starts and stops immediately on refresh.. but not always this is not consistent..

    We even tried removing the lanmanserver from registry and imported from another server but same error

    We unchecked and Rechecked File & Print Sharing from NIC after removing lanmanserver from registry and a restart but found that the lanmanserver was not created automatically.. is there any way to get that created automatically?

    Thanks and Regards

    Jose



    • Edited by JosephBoban Thursday, January 23, 2014 12:47 PM update
    Thursday, January 23, 2014 10:26 AM
  • Interesting. I didn't realize you had removed LANMANSERVER from the machine. I wouldn't have suggested that, and now it adds a bit of complexity to resolve it. See if the fix for LANMANSERVER and the SERVER service the poster in the following thread helps you:

    Server service (lanmanserver) will not starthttp://social.technet.microsoft.com/Forums/windowsserver/en-US/3316a5e0-fc2f-4300-917d-66e1527b4aa7/server-service-lanmanserver-will-not-start?forum=winserverfiles

    *

    If that doesn't help, due to the complexities, my next suggestion is to contact Microsoft Support for assistance so they can logon to the machine and evaluate, run tests, etc, to determine the cause and resolve it.
    http://support.microsoft.com/contactus/


    Ace Fekay
    MVP, MCT, MCITP/EA, MCTS Windows 2008/R2 & Exchange 2007, Exchange 2010 EA, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Technical Blogs & Videos: http://www.delawarecountycomputerconsulting.com/

    This post is provided AS-IS with no warranties or guarantees and confers no rights.

    FaceBook Twitter LinkedIn

    Thursday, January 23, 2014 4:08 PM
  • Dear All,

    The Issue is Fixed Now....
    what we did is we mounted the DVD iso and  tried doing an Upgrade to the OS Windows 2008 R2 Std
    It continued and on the step Gathering user files ,settings... it gave an error . Windows installation encountered an unexpected error.Verify that the installation sources are accessible,and restart the installation Error Code:0xC0000005
    Then we copied the Windows 2008 R2 Std SP1 DVD content to the Server and tried doing an Upgrade to the OS Windows 2008 R2 Std the same above error came up

    Now we did a clean boot ,disabling all other services apart from microsoft's

    So the Upgrade did the Repair!! without removing the configurations!!

    Hurray!! the installation went throiugh and after login we found that the server service was started with all dependent service functional and no error , fixed without lossing any data!!! or configuration!! ( Server was part of Domain as well)

    On reboot all services enabled which were disabled before the upgrade!

    NB:
    We made a backup of the VMDK.Flat and other contents of this server before performing this upgrade just in case if anything goes wrong..
    Ensure backup is taken

    Should Thank..

    http://www.networksteve.com/forum/topic.php/Repair_Server_2008_R2_system_files_with_DVD_/?TopicId=15477&Posts=0

    ((Hi, You can repair the Windows Server 2008 R2 system but there are some differences. In previous systems, you can boot from the disk and then repair the system. In Windows Server 2008 and Windows Server 2008 R2, you should run the disk from the current system to perform an In-place Upgrade. For example, if you are running Windows Server 2008 R2 Enterprise, you can insert the installation disk, double-click setup.exe and install Windows Server 2008 R2 Enterprise again over the current system. Normally your personal data will not be destroyed after that. But it is still recommended to back up your important files first. Tim Quan ))

    for giving this hint of repairing!

    Thanks and Regards
    Jose





    • Marked as answer by JosephBoban Tuesday, January 28, 2014 2:03 PM
    • Edited by JosephBoban Tuesday, January 28, 2014 2:12 PM updated
    Tuesday, January 28, 2014 2:03 PM
  • Hi,

    Thanks for your share and it would be helpful to anyone who has similar issues.

    Have a good day!

    Best regards,

    Susie

    Friday, January 31, 2014 1:43 AM
    Moderator
  • Glad to hear you've resolved it. And also thanks for posting the resolution!

    :-)


    Ace Fekay
    MVP, MCT, MCITP/EA, MCTS Windows 2008/R2 & Exchange 2007, Exchange 2010 EA, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Technical Blogs & Videos: http://www.delawarecountycomputerconsulting.com/

    This post is provided AS-IS with no warranties or guarantees and confers no rights.

    FaceBook Twitter LinkedIn

    Friday, January 31, 2014 6:49 AM
  • I have the same issue with Windows 7 Ultimate.  I think svrsvc.dll is corrupt, but I can't replace it (access is denied).  Do I have to do a repair install from disk?

    Wednesday, April 30, 2014 9:25 PM