none
In order to make a VBA tool work,how to register MSCOMCTL.OCX in Windows 7 without admin rights? RRS feed

  • Question

  • I do have developed a VBA Macro using excel in MS office 2003.This macro was working fine in both MS office 2003 and 2007.Since i moved to Windows 7 with MS office 2010,my macro stopped working.After googling i came to know that MSCOMCTL.OCX was not registered.The tool\macro starts working once i register the above said ActiveX control.But my problem is this,tool is deployed to the sales executives whom doesnot have administrative priviledge to register this .OCX file.Now i want the solution to register the MSCOMCTL.OCX in Windows 7 without admin rights.

    P.S:Sales executives cant be given admin rights as per our company policy.Hence i want a work around to fix this issue without admin rights.

    Wednesday, June 20, 2012 7:10 AM

All replies

  • You cant. Regsrv32 to register dlls, works only with administrator rights.

    The same is when you use any instalator (can have that or other system controls)


    Oskar Shon, Office System MVP

    Press if Helpful; Answer when a problem solved

    Wednesday, June 20, 2012 7:58 AM
  • Thanks for your reply.

    But my concern is,this particular .OCX file was registered as part of MS office 2003 and 2007 installations but now it is not part of MS office 2010 installation.hence i need to register this .OCX file explicitly which is causing me the issue.

    Furthermore why does the MS office 2010 is not installing MSCOMCTL.OCX has part of its installation?

    is there any way to prommatically register .OCX file?

    Wednesday, June 20, 2012 10:03 AM
  • You can check it if really is?

    Make new project and find any control from MSCOMCTL.OCX assign as Control 6.0 (SP6)

    and show this form.


    Oskar Shon, Office System MVP

    Press if Helpful; Answer when a problem solved

    Wednesday, June 20, 2012 5:39 PM
  • Hi,

    Try to just click on all programs -> accessories -> then right click on command prompt and select run as administrator


    Jaynet Zhang

    TechNet Community Support

    Thursday, June 21, 2012 9:48 AM
    Moderator
  • Hi Zhang,

    Thanks for your reply.

    But this is not possible because am a standard user whom doesnt have admin priviledge.Can you suggest me any other alternative to register the .OCX without admin rights.

    regards,

    rajan

    Friday, June 22, 2012 10:48 AM
  • Rajan_D why you force install dll library that way.

    You cant do it without admin rights (dot)

    Why? Because that is change the way on system works.


    Oskar Shon, Office System MVP

    Press if Helpful; Answer when a problem solved

    Monday, July 2, 2012 8:12 AM
  • I'm unsure if this issue has been solved for you, but I just happened upon this so I thought I'd give some insight seeing as how I've run into this issue as well.

    Jaynet is correct.
    You need to right click on the Command Prompt and run the program "As Administrator".

    Once you do that it will ask you for credentials.

    Any windows machine has to have an administrator account on it - or you would theoretically be locking yourself out from ever making changes < and that is quite silly.

    So, depending on how your company works, you may have an IT staff with administrative rights on your computer or you have an intranet in which case anybody within the company that has administrative rights can log into the prompt that asks for credentials and then you're in.

    I hope this helps, just keep in mind that an administrative account always exists!

    -JM

    Thursday, August 16, 2012 1:41 PM
  • check this link this may help you out

    http://answers.microsoft.com/en-us/office/forum/office_2010-customize/how-to-register-mscomctlocx-in-windows-7-without/8a6d2793-a03a-4f00-b476-4521e39b2e64?msgId=0d8ec8ee-5e81-4f32-b0b5-4aff07ad3e8a

    Friday, August 17, 2012 10:15 AM