none
No Audio or Webcam (Drivers have Error 39 in Device Manager)

    Question

  • I am running Windows 8. Everything installed and was working fine, then after a reboot (for no particular reason) I see a red X against the speaker icon "No audio output device is installed".

    In Device Manager the Sound, video and game controllers IDT HD Audio Codec, Intel Display Audio, USB Audio Device devices have a Yellow exclamation mark and display Code 39 "Windows cannot load the device driver for this hardware (unable to load device driver) %hs device driver could not be loaded. Error status was 0x%x. Also displaying the same error message is the HP Truevision HD device (webcam) Driver v6.2.9200.16420. I also connected a LOgitech Quickcam Pro 9000 and this installed the drivers but then came up with the same Code 39 error.

    I have run dxdiag and the first time it stalled, second time said there was a problem with DirectShow last time so I skipped it, and third time it ran but both times it showed no audio drivers installed.

    I have run sfc /scannow and that saw some errors and "corrected them" and after reboot I ran this again, but still no audio although the driver for the IDT device was updated to v6.10.6425.0. 

    On searching CBS.log I can find no reference to 6.10.6425.0 although there are references to 6.2.9200.16420.

    There are also various lines saying "Cannot repair member file "cofire.exe mui" of MS-W-CorruptedFileRecovery.Resources, Version 6.2.9200.16384. I don't know if that is relevant. 

    I am searching for a program to compare two exported registry (.reg) files. I don't want anything to change the registry, just want to see what the differences are between the two. Anyone suggest anything?

    • Edited by Goandays Wednesday, June 26, 2013 9:36 PM
    Wednesday, June 26, 2013 1:43 PM

All replies

  • I did not google the exact information for this, but got one might be helpful.

    When trying to use a hardware device attached to your computer, such as a USB optical mouse, your computer displays the error message for error code 20. Windows is having problems loading a device driver and is unable to use the affected device.  

    Please see http://www.error.info/windows/driver-20.html for detail.

    Andy

    Thursday, June 27, 2013 1:50 AM
  • Andy

    I hardly think that is relevant. These are Code 39 errors "Windows cannot load the device driver for this hardware (unable to load device driver) %hs device driver could not be loaded. Error status was 0x%x."

    I have tried uninstalling, re-installing but it is as though something is hogging the audio memory or interrupt. I find that Windows simply saying that no audio drivers are loaded (when running dxdiag) is up to its usual level of unhelpfulness.

    I know there are not loaded (but not through lack of trying) and Windows must know that they are trying to load (that's why they show in Device Manager with errors), so why can't it direct me to why they can't load?

    Friday, June 28, 2013 1:22 PM
  • Hi Goandays,

    Did you try System Restore? Try to restore it on the date before the problem occurred. You might have installed the wrong driver for your Audio which caused your system to malfunction. Make sure to download the driver on the OEM sites (the manufacturer of your computer) the correct driver updates by searching the Exact Model ID of your computer.

    If you cannot find the driver downloads for your computer, you can try Driver Finder. This will scan your devices and recommend you latest and compatible driver updates which will fix PC Problems.

    http://www.driverfinderpro.com/lp/audio/audio-drivers.php

    Monday, July 1, 2013 3:36 AM
  • Audio was restored with a Windows Refresh. Seems like a sledgehammer to crack a peanut job to me. Now got to go through installing all my programs again, probably the 4th time.

    And I thought this OS was supposed to be simple to use---maybe I misread it and it's for simple people to use!

    All of my System Restore points (with Audio) had disappeared (superceded). There doesn't seem to be any way to manage Restore Points i.e Delete unwanted ones, save as protected any good ones, simply delete all. What kind of management is that?

    Now have a fully working system BUT.......... Screen saver now will not activate. I will start a new subject on this but if anyone wants to help then I will only be too pleased.........

    Sunday, July 7, 2013 11:33 PM