none
Mouse snap to default button no longer works in Office 2010

    Question

  • Using Windows 7 home edition premium.  Had office 2007 - the mouse pointer snapped to the default button in dialog boxes.  After upgrading to Office 2010, the mouse pointer no longer does this.  Mouse control panel settings have not changed and are set for snapping to the default button.

     

    Real PITA

    • Moved by Sally Tang Monday, September 06, 2010 7:17 AM (From:Office 2010 Setup and Deployment)
    Friday, September 03, 2010 3:28 AM

All replies

  • Hi,

     

    We can enable/Disable Snap to Default Button. This force the cursor to always jump to the default button of any dialog or alert that opens.

     

    1.       Click Start, in the Search box type regedit and press Enter to open the registry editor.

    2.       Locate the key: HKEY_CURRENT_USER\Control Panel\Mouse

    3.       Modify/Create the Value Data Type(s) and Value Name(s) as detailed below.

    Data Type: REG_SZ [String Value] // Value Name: SnapToDefaultButton

    Setting for Value Data: [0 = Snap To Disabled / 1 = Snap To Enabled]

    4.       Exit Registry and Reboot

     

    Best Regards,

     

    Sally Tang

     

    • Marked as answer by Sally Tang Friday, September 10, 2010 9:22 AM
    • Unmarked as answer by Sally Tang Friday, September 17, 2010 8:46 AM
    Monday, September 06, 2010 7:20 AM
  • Hello Sally,

    PITA is right, your recommendation doesn't apply, because I faced the same at Win 7 Ultimate, Office 2010, at Excel, Word, Powerpoint 2010. Also, there is no Windows Sound !  However, Outlook 2010 and Access 2010 work as usual.  So, it might be a programmer's issue.  I have asked MS Online Support in Germany weeks ago, but haven't gotten any response. I guess Seattle should look into this and fix it with the next SP.

    Best regards,

    Ben1888

    Sunday, September 12, 2010 10:41 AM
  • Sally,

    Your answer gets me absolutely nowhere!

    In my Control Panel the option was marked as 'snap to', and (frankly,unsurprisingly) the same was true in the Registry - why would it not be?

    Fact is, this option seems quite simply NOT TO WORK in Word 2010 with Windows 7 Home.

    Please can you confirm that you agree?

    Even better, please tell us if Microsoft is proposing to fix it!

    Remember, there is no shame in not having a perfect piece of software, and you get more Brownie points for admitting it than pretending a problem does not exist.......

    Thanks,

    Ed

    Monday, March 28, 2011 7:53 PM
  • This issue has nothing to do with the underlying operating system.

    I have Office 2010 on an XP sp3 system and get the same symptom.


    doug mcallister
    Friday, April 08, 2011 2:09 PM
  • Where is Sally Tang hiding?!

    Sally, you seem to have gone very quiet for the last six months or so. Do you or any of your colleagues monitor this site? Or do you just answer questions when they are easy?

    Please can you do one terribly simple thing - post here to say whether or not Microsoft currently accept that the snap-to-default mouse facility in Office 2010 (Word anyway), combined with Windows 7 (and it would seems also XPsp3) simply does not work.

    It is not much to ask!

    Please?

    Thanks,

    Ed

    Sunday, April 17, 2011 7:34 PM
  • I have office 2010 on Windows 7 Home on 4 pc's and they all have this problem even after Excel sp1. Please can this bug be fixed?

    It is silly for snap to not to be used on Excel as it saves so much time.

     

    Thanks

    Julian

    Wednesday, July 06, 2011 6:32 PM
  • Same problem for me.

     

    Would be great to have a solution.

    Friday, July 29, 2011 5:46 PM
  • I am having same problem. Using Win7-64bit. Worked fine in Win7 while I was using Office 2007. Since installing Office 2010 experiencing same problem as other users. Mouse setting in control panel correctly checked for snap to in dialog boxes. Registry correctly reflects that snap to is enabled.

    Is there a solution yet

    Friday, October 28, 2011 8:37 PM
  • It's one month since the last post, and the feature is still unavailable.  I'm getting desperate - is MSF really not going to fix this?

    • Edited by fhjlassie Monday, November 28, 2011 6:32 PM
    Monday, November 28, 2011 5:52 PM
  • Actually, it is well over a year since people first started writing about this.  With no useful replies.  It feels as if god is dead, or at least not listening/reading, in the forum world...
    Thursday, December 22, 2011 3:58 AM
  • The issue isn't the OS or a bug in MS Office 2010.  The issue is that MS did not specify a 'default' option in some dialog boxes, specifically the save dialog box. There really shouldnt be a default option since Word doesn't know if you want to save or not. Sure it's better to save than not save if you are unsure, but there is no necessary reason for it.

    What stinks is that they had the feature in 2007 and we all got used to it.  In 2010, its not really the case.  You'll notice some instances, especially in outlook 2010, snap-to still works.  In other cases, they must've not specified a default, so there is nothing to snap-to. 

    Will MS ever change this? I doubt it. Maybe in 2012?

    Regardless. the point is that it's not a bug, so there is nothing to 'fix' for them.  Just use the arrow keys or tab keys.

     

    • Proposed as answer by Brian2686 Monday, February 06, 2012 3:41 PM
    Monday, February 06, 2012 3:41 PM
  • Brian, 

    I agree entirely that it is not a bug. It is simply a feature that used to exist, was useful, and no longer exists.

    What is puzzling is that the two Microsoft 'experts' I have found on the Net who have sought to address this problem - Sally Tang here, and someone whose name I now don't recall on another Forum - have plainly not viewed it in that light.

    They plainly reckoned that the mouse SHOULD snap to the buttons in those areas of Office 2010 where it does not.

    What we surely seek is a statement from Redmond as to why they saw fit to change a feature that was so useful?

    COME ON REDMOND! Tell us why, there's good chaps.....

    Face it, if there was a good reason, we might like to know what it was. Of course if it was either a BAD reason, or an oversight, you might wish to reinstate the feature.

    Let's be hearing from you, please!

    Ed

    Saturday, February 18, 2012 8:46 PM
  • as a web developer we make it a point to NEVER  create any control buttons WITHOUT a default. it seems like such common sense. and as a power user i dont want to have to deal with tabs or arrows. MS needs to wake up and bring back common sense.

    doug mcallister

    Sunday, February 19, 2012 3:29 AM
  • Since I've not found any forum which even suggests this will ever be fixed, I'll post a "not-as-good" alternative.  This freeware moves the dialog box near the pointer.  Still not quite to the default button, but it you have a large monitor it's better than nothing.  It did work for me, though I unchecked the hot keys option. 

     

    http://www.thewindowsclub.com/make-confirmatory-dialog-windows-appear-near-mouse-cursor

    Sunday, March 11, 2012 10:55 PM
  • Brian said

    > The issue is that MS did not specify a 'default' option in some dialog boxes, specifically the save dialog box.

    This is incorrect.  On choosing to Save, Save (as opposed to Don't Save or Cancel) is highlighted in blue and is activated if you hit the Return key.  So it's a default.  It leaves me speechless that Microsift has released Office 2010 to the world and has mislaid snap-to along the way.  And has apparently not noticed, thru beta testing and the rest.

    Wednesday, April 18, 2012 10:13 PM
  • This has become a major nose bleed for me.  Well, beta 15 dot whatever shipped last week.  Any feedback?
    Sunday, April 22, 2012 9:40 PM
  • Personal for Sally Tang, please!

    Sally, browsing about the other day, I found some useful information on this site that was, as it happens, a couple of years' old. At the end, I noticed that it was you who had closed the thread - entirely sensibly, as the question was answered. 

    That reminded me that it was you who had gone to ground on this thread, so I am writing (over a year since I first did!) to ask:-

    ARE YOU DEAD OR ALIVE?

    Microsoft would do itself just so much good if it would communicate. There are now I think TWELVE people unhappy enough to have found this thread and posted to it.

    What is the point of a Forum like this if you simply ignore it

    COME ON! Show us you really WANT to help!

    Edward Martineau

    Wednesday, April 25, 2012 8:08 PM
  • Ditto all the above ...

    Perhaps a class action repetitive stress disorder lawsuit against the MS Office Team will get their attention! If the OS provides this setting in Control Panel, Mouse, Pointer Options ... who the heck does the MS Office Team think they are to let their product blatantly interfere with it?

    Thursday, April 26, 2012 3:10 PM
  • I have got the same issue even after sp1 is installed, what's wrong with office team ?  office 2010 is even worse than 2007 :O  very disappointed !
    Tuesday, August 07, 2012 3:47 AM
  • I can't believe that such a simple issue has 1) not been resolved and 2) not gotten more views.  This is a absurd thing for the MSFT team to disable, especially considering how much the marketing campaign touts increased efficiency.  Having to move the mouse to the dialog box EVERY SINGLE TIME is not efficient, far from it.

    Wednesday, October 10, 2012 12:26 AM
  • Hello there Redmond!

    Just dropping by this Forum for the first time in SEVEN MONTHS to see if anything has changed....

    It HAS!

    Even more people have expressed their frustration!

    WHEN will you say something to us?

    This side of eternity?

    Edward Martineau

    Saturday, November 10, 2012 8:36 PM
  • Hello Microsoft,

    it would be great if anyone could fix this "bug", but when I am looking to the history of this issue... I believe nothing will happen.

    Best regards,

    MaHa

    Tuesday, February 12, 2013 10:28 AM
  • hello all,

    with the same problem after migration from office 2003 to office 2010, i contact microsoft with a support call and they give it to their office developers.
    they confirmed this issue and now it´s documeted but no hotfix is planed, because for microsoft it is not a bug. Office 2007 and 2010 use ribbons, new own dialogs and a new code. No design considerations for this function was given from micrsoft.

    I think, this was a unlucky engeniering, because in Access and Outlook it works well, even in all my non microsoft applications.
    And it is not a Windows XP, Win 7 Problem.

    You can check this bei "alt+F4" to save a document. If "save" it is only blue framed or highlighted and the cursor is there.

    conclusion: no solution yet

    But if more people ask microsoft for this feature, maybe it will be a design requirement for after next office versions.

    best regards

    marc

    Wednesday, February 13, 2013 2:55 PM