none
Error 1920. Service 'Office Software Protection Platform' (osppsvc) failed to start. Verify that you have sufficient privileges to start system services.

    Question

  • I'm trying to install Microsoft Office 2010 Professional.  I am running on Windows 7 Home Edition 64-bit.  I have previously installed the Microsoft Office 2010 Professional trial version, but later uninstalled it when the trial ran out.  I have tried changing the permissions in Office software Protection Platform.  I've also tried running a bat file (it didn't run) and I also tried giving the system all network controls as MS has insisted.  Nothing has worked yet.  Please help.
    Monday, November 8, 2010 4:01 PM

Answers

  • Hi tronixmart, the problem is not a bad key. . .

    First of all, if you are using Win 7 Home Premium (as I am), Home Basic, or Starter, you will not have a Local Users and Groups option. It is only for Win 7 Ultimate, Professional, or Enterprise.

    Jennifer Zhan's second suggestion regarding the changing of 'This account' to 'Local system account' under the "Log on" tab in the properties window of Office Software Protection Platform is better, but still not adequate. If you try this, as I did, and then manually start Office Software Protection Platform before continuing the Office 2010 installation from the point of error, you will receive a new surprise. The Error 1920 message goes away, but then it is replaced with an oh-so-descriptive dialogue box telling you that "Microsoft Office 2010 installation encountered an error." Nice.

    Changing 'This account' to 'Local system account' is useless, because after the error described above, the system somehow reverts the log on selection for Office Software Protection Platform back to 'This account,' with 'Network service' selected by default.

    The better solution is to give the user account called 'Network service' full permissions for the appropriate folders and registry entries. Simply follow these instructions I found on another forum:

    In Windows Explorer:

    Right Click  on the folder OfficeSoftwareProtection Platform from C:\Program Files\Common Files\Microsoft Shared and Microsoft from C:Program data(hidden folder) Properties > Security > Edit > Add > Type Network Service > OK > Check the Full control box > Apply and OK.

    In Registry Editor (regedit.exe):

    Go to HKEY_CLASSES_ROOT\AppID registry >Right Click on the folder > Permissions > Add > TypeNETWORK SERVICE >  OK > Check Full Control > Apply > OK

    This worked for me and many others with the same problem, and took mere minutes to do.

    • Marked as answer by Jennifer Zhan Thursday, November 18, 2010 7:14 AM
    Friday, November 12, 2010 12:07 AM

All replies

  • I also cannot start the Office Software Protection Platform.  I get an error message 2:  The system cannot find the file specified.

     

     

    Monday, November 8, 2010 4:38 PM
  • Hi,

    See here for same issue:
    Aleksdj provides the steps used solving his problem as follows:
    Step 1:

    Go to Local Users and Groups: (http://www.sevenforums.com/tutorials/7539-local-users-groups-manager-open.html)

    Step 2:

    Go to Groups and double click Admistrators

    Step 3:

    Click Add, click Advanced and click Find Now 

    Step 4:

    Double Click in Network Service (in the bottom list) and click Ok

    Final Step:

    Click Ok and try to Install the Office Suite again.

    And Ruhul also gives another method, I think you may have a try.

    Open Run (Press Windows key + R) > type services.msc and click on OK

    On the services MMC window right-click on Office Software Protection Platform and select Properties

    Select the LOG ON tab > change the ‘Log on as’ information from ‘This Account’ (Network Service) to ‘Local System Account’

    Click on Apply and OK

    Hope that helps.

    • Proposed as answer by Martin Mora Wednesday, September 18, 2013 3:05 PM
    Tuesday, November 9, 2010 5:54 AM
  • Thanks for your help, but I'm already set up as the Administrator.  I only have one account on this computer and Windows 7 forces you to designate at least one user as an Administrator.  When I tried doing the first step, there wasn't a folder or icon for local users and groups.  I think I have a bad key.   '

     

    Tuesday, November 9, 2010 10:59 PM
  • Hi tronixmart, the problem is not a bad key. . .

    First of all, if you are using Win 7 Home Premium (as I am), Home Basic, or Starter, you will not have a Local Users and Groups option. It is only for Win 7 Ultimate, Professional, or Enterprise.

    Jennifer Zhan's second suggestion regarding the changing of 'This account' to 'Local system account' under the "Log on" tab in the properties window of Office Software Protection Platform is better, but still not adequate. If you try this, as I did, and then manually start Office Software Protection Platform before continuing the Office 2010 installation from the point of error, you will receive a new surprise. The Error 1920 message goes away, but then it is replaced with an oh-so-descriptive dialogue box telling you that "Microsoft Office 2010 installation encountered an error." Nice.

    Changing 'This account' to 'Local system account' is useless, because after the error described above, the system somehow reverts the log on selection for Office Software Protection Platform back to 'This account,' with 'Network service' selected by default.

    The better solution is to give the user account called 'Network service' full permissions for the appropriate folders and registry entries. Simply follow these instructions I found on another forum:

    In Windows Explorer:

    Right Click  on the folder OfficeSoftwareProtection Platform from C:\Program Files\Common Files\Microsoft Shared and Microsoft from C:Program data(hidden folder) Properties > Security > Edit > Add > Type Network Service > OK > Check the Full control box > Apply and OK.

    In Registry Editor (regedit.exe):

    Go to HKEY_CLASSES_ROOT\AppID registry >Right Click on the folder > Permissions > Add > TypeNETWORK SERVICE >  OK > Check Full Control > Apply > OK

    This worked for me and many others with the same problem, and took mere minutes to do.

    • Marked as answer by Jennifer Zhan Thursday, November 18, 2010 7:14 AM
    Friday, November 12, 2010 12:07 AM
  • Good job.  It fixed the problem.  No one else had the right fix.
    Monday, September 19, 2011 2:28 PM
  • I know this thread is old and probably isn't looked at but if it is I wanted to thank you Sir Chump.  I spent the better part of 2 hours trying to fix this error on my own. 

    Thank you for contributing. 

    Thursday, October 6, 2011 11:57 PM
  • Hey Sir Chump - I like philo_ wanted to say thank you for the help. I've spent over 5 hours trying to troubleshoot this issue trying various methods (including all the official MS support suggestions) only resulting in more work on my end. I was very close to giving up but thanks to your response my problems are finally fully resolved. Thanks again.

    (And for those of you out there who found this information useful as well - take one more minute out of your lives to show some appreciation for the person who helped you out.)

    Sunday, December 11, 2011 1:47 AM
  • I did the following and am still having issues...

    click on window, computer- in the search key type "OFFICESOFTWAREPROTECTION" from the list provided, I right clicked on the OFFICESOFTWAREPROTECTION PLATFORM folder.  I added Network Service and gve it full control

    I unhid files and found program data on the C:\.  Right click and add network service there too.  I have norton that would not allow changes.  but the other files were updated w/o issue.

    I followed the registry editor directions too.

    reboot

    tried running the program again and received the same 1920 error.  I did note that I had program file and program file (x86).  there was no office software protection under the program file (x86).

    Any suggestions?

    Saturday, June 9, 2012 8:47 PM
  • This worked for me. Thank you!
    Wednesday, March 20, 2013 2:41 PM
  • Hello Sir...!!
    I am really gratefull to you for typing this solution ...it was really helpful.....i was unable to install Office 2013 professional plus since a long time because i always encountered this error "Microsoft Office 2013 installation encountered an error." after i started the osppsvc manually......tried alot with deleting registries ...even the MSI logging....but the installation was always disastrous.....but your solution worked for me....
    thanks alot
    Friday, September 13, 2013 6:29 PM
  • Thank you sir! You have really saved my ass. I tried all means but it couldnt work. Until I tried your suggestion.
    Thursday, September 26, 2013 8:56 PM
  • After some hours of debug (..) I've found your post and it solves the problem!! Thank you very much!!
    Saturday, December 14, 2013 9:27 PM
  • Good Job.

    Also for me following resolution works (with proper permissions, as I am the administrator):

    1) For windows XP & server 2003

            a. Click Start and click Run.

            b. Type the following command line, and then press ENTER:

            cacls "C:\Program Files\Common Files\Microsoft Shared\OfficeSoftwareProtectionPlatform" /t /e /p "Network Service":F

            c. Try the install of Office 2010.

    2) For windows Vista and windows 7

            a. Click Start and click Run.

            b. Type the following command line, and then press ENTER:

            icacls "C:\Program Files\Common Files\Microsoft Shared\OfficeSoftwareProtectionPlatform" /grant "Network Service:F" /t

            c. Try the install of Office 2010.

    Thanks

    Tuesday, December 31, 2013 9:04 AM
  • Great Job Sir Chump,

    Worked for me after a big run around from you know who!

    Thanks A Mill !

    Herc.


    FJP

    Thursday, April 17, 2014 1:13 AM
  • Thank you so much. You resolved my problem!
    Thursday, September 25, 2014 11:20 PM
  • Thanks, its worked for me, i have spend two days to solve this issue, finally i have solved using this solution.
    Thursday, June 4, 2015 3:08 PM
  • +1 tyvm..:)
    Sunday, August 21, 2016 4:50 PM
  • buenas noches quien me puede dar solución al siguiente problema con error 1920 Error al iniciar el servicio office software protection platfom compruebe  que dispone de suficientes privilegios para iniciar servicios del sitema y

    Tuesday, October 4, 2016 12:41 AM
  • this worked like magic on my Windows 7. Thanks
    • Proposed as answer by buff4u2000 Saturday, February 4, 2017 11:41 AM
    Saturday, February 4, 2017 11:41 AM
  • It works! Thank you very much!
    Monday, January 22, 2018 9:24 AM
  • How about win10? What shall I do there?
    Wednesday, January 31, 2018 7:54 PM
  • I was having a very similar issue!

    I was trying to get rid of some odd remnants of a malware thing and wound up installing Malwarebytes.  After running it and subsequently installing the newer version, I found that my install of Office 2010 wasn't working!  I kept getting an error saying it couldn't be verified even though I've been using the software for over 7 years.  I was ready to do a full reinstall of Windows since I NEED my Outlook and Word until I found this post using a very complex and exact search parameter.

    Somehow or another, Malwarebytes had altered my registry thinking it was in error but it actually did more harm than good.  Now I just need to replace my data files (which I had backed up) and get back to work!

    Monday, February 5, 2018 4:26 AM
  • Its worked for me,great work.
    Saturday, March 24, 2018 8:03 AM
  • Very very thanks.
    Sunday, May 27, 2018 9:27 AM
  • Thanks a mill! It worked like magic!!!
    Saturday, June 23, 2018 2:44 PM
  • hi

    you should go to the below path(for win7):

    "C:\Program Files\Common Files\Microsoft Shared\OfficeSoftwareProtectionPlatform"

    and find this file : OPPSVC 

    and right click on the file > select rename and add the end of name ".EXE"

    like this: OPPSVC.exe

    and try it or repare it with setup

    Wednesday, October 10, 2018 5:34 AM
  • Thanks, it works  : ))) 
    Thursday, November 29, 2018 10:26 AM
  • A co z win10? Co mam tam zrobić?
    How did you solve your problem?
    Thursday, December 6, 2018 8:44 AM