none
MOUSE & KEYBOARD ISSUE IN HYPER-V MANAGER

    Question

  •  

    Hello IT guru’s

     

    Recently I installed Win2008 RC1 SP1 v.735 with Hyper-V (version 6.0.6001.17101) so after configuring the VHD when the system boots up and when the logon screen appears I cant use the mouse neither keyboard, but on the underneath tab I can see a message “To release your mouse press CTRL+ALT+LEFT ARROW – I tried to do this but I cant use the mouse and keyboard.

     

    Secondly the screen of the VM PC is quit big and it is not fitting into the screen,

     

    So guys could you please help me in this regards - is there any patch or hotfix to slove this issue...

     

    Note: I checked this URL http://download.microsoft.com/download/e/4/8/e48d5cff-53d2-4eed-85bf-4af50e25b78c/relnotes.htm it says check the Integrated Services" i checked but i coudnt find much intersting stuff.

     

    Waiting for your response

    Monday, March 31, 2008 1:58 PM

Answers

  •   Are you running this directly from the server? The behavior you describe is what happens if you are connecting to the server by remote desktop. Remote connections cannot handle the mouse until the integration components are installed.

     

       What OS is running in the vm? There are integration components for more OSs in the latest version. 

     

    Tuesday, April 1, 2008 6:53 AM

All replies

  • If you are using the same version of Windows 2008 as host and guest OS, the mouse and keyboard should work fine.

    However, if you have installed Hyper-V RC on the host OS, keyboard and mouse (and network) won't work in the guest OS until you've installed the Hyper-V patch there as well.

    Probably the easiest way to do this is to create a new virtual hard disk, copy the files onto that, add it to you guest OS and then run it from there. You should then find the integration components work as you would wish.

    _
    David
    Monday, March 31, 2008 3:31 PM
  • If your guest screen is way too big then your video is not being detected correctly by the guest OS.

    If you guest NIC is not working, then you need to fall back to the lagacy NIC until you get the Integration Components updated in the guest.

     

    Does not patching your guest prevent it from working - technically no.

     

    Oh, and if you maximize the Connect client window in RC0 it will resize the desktop of your VM (like RDP does) in your Host window than you can get to the guests GUI much easier.

     

    and sometimes with the release key sequence - you have to make sure that your mouse is actually over the Desktop of the VM and not pulled off to a side (outside of the window) for it to release properly.

     

     

    Monday, March 31, 2008 4:55 PM
    Moderator
  • Be careful here. You're running an RC of Windows 2008 instead of RTM? You should be running Windows 2008 RTM, patch it with the Hyper-V RC0, then create virtual machines and patch them with Hyper-V RC0.

    More details are available here: http://blogs.technet.com/jhoward/archive/2008/03/19/Hyper_2D00_V-RC0-release-is-available-for-download.aspx

    Monday, March 31, 2008 5:18 PM
    Moderator
  • As John Paul has pointed out, you'll want to run with the latest and greatest:

     

    Windows Server 2008 Enterprise Eval version: http://www.microsoft.com/downloads/details.aspx?FamilyID=13c7300e-935c-415a-a79c-538e933d5424&DisplayLang=en

     

    Hyper-V RC0 (latest publicly available): http://www.microsoft.com/downloads/details.aspx?FamilyId=DDD94DDA-9D31-4E6D-88A0-1939DE3E9898&displaylang=en

    Monday, March 31, 2008 6:02 PM
  • Thanks guys for all your responses – well I guess there is some misconception J – I will list down the below details I hope you will get the clear picture

     

    Issue: Mouse & Keyboard is not functioning in VM Host, but I can see the mouse cursor with “DOT” sing and its moving free but the keyboard doesn’t work , I have to send the command by clicking Action then “Ctrl-Alt-Delete” then I can login, but here surprisingly my Keyboard will function and once I am in if I click the mouse it gets freeze and the message appears in task stating “To release your mouse press Ctrl+Alt+Left Arrow” so here I can work with keyboard only INSIDE THE VIRTUAL PC” – but not with the mouse

     

    Query1: Could you please tell me how I can know whether my O/S type is RC1 or RC0 – secondly I noticed when I start the Virtual host PC from Hyper-V console I can see small screen “BETA” in blue color which appears when the system boots up its comes like this “Win2003 Enterprise Edition with windows logo” with BETA… so you think this is beta version.

     

    Query2: Below is the version of my Win2008 O/S and Hyper-V version I hope if you can tell me which version I am using.

     

    Win2008 Ent O/S Ver:         6.0  Build 6001: Service Pack1, V. 735     

    Hyper-V                  :        Hyper-V Manager Version 6.0.6001.17101     

     

    Has mention in the blogs I tried to install the following updates “Windows6.0-KB949219-x64” but I am getting this message “ The update does not apply to your system”

    Secondly I even tried to run the windows update to check any latest updates – but nope there is no latest updates.

    So guys I hope you understood my illustration, please help me out….

     

    Tuesday, April 1, 2008 6:23 AM
  •   Are you running this directly from the server? The behavior you describe is what happens if you are connecting to the server by remote desktop. Remote connections cannot handle the mouse until the integration components are installed.

     

       What OS is running in the vm? There are integration components for more OSs in the latest version. 

     

    Tuesday, April 1, 2008 6:53 AM
  • Thanks for your update.. well this is what i am doing ..

     

    1. I have highend server with 8GB RAM with OS Win2008 installed with Hyper-V

    2. All the VM host are Win2003 Ent Edition

    3. The administration is done through Hyper-V console, I have some Base O/S (VHD) and after running the new wizard "Virtual Machine" in Hyper-V console when i execute on the avabalibe VM windows screen appers with Ctrl+Del .. from here i cant use the mouse.

     

    Coming to your second question i checked the Integration components for the VM machine, the below are the avalabie componets.

     

    1. Operating System Shutdown

    2. Time synchrozine

    3. Data Exchange

    4. Heartbeat

    5. Backup (voulme snapshot)

     

     

    Please let me know for further any query required.

     

     

     

    Tuesday, April 1, 2008 7:20 AM
  • Are you using remote desktop / terminal services to connect to the server?

     

    Cheers,

    Ben

    Thursday, April 3, 2008 5:36 PM
    Owner
  •  

    Hi There,

     

    I had a similar problem, but with Windows Server 2008 RTM (64bit) as the host OS and Windows Server 2003 as the guest OS. In my scenario the guest OS was a VM which was built using Virtual Server 2005, and now I wanted to use it in Hyper-V.

     

    Mouse did not work, even after installing the Integration Services.

     

    In the end, I opened device manager in the guest OS (using keyboard strokes...), only to find a big yellow sign next to the mouse. I therefore told it to update the mouse driver (HID-Compatible Mouse), it asked for Windows 2003 CD, and after some installation time, the mouse now works.

     

    In other words, it was just a mouse driver issue, even though it worked fine in Virtual Server 2005.

     

    Michael

    Monday, May 26, 2008 1:32 PM
  • I am having the same problem with W2k8 as host and trying to get a W2k3VM server.  How didyou get the key strokes to work, it is not letting me bring up the device listing to even see the driver.
    Wednesday, June 4, 2008 5:22 PM
  •  I have tried and this is working fine:

    All credits going to mike_something

    The problem is that the old mousedriver is hooked to the mouse device class.
    To remove this dependency, go into the registry and navigate to the key


    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{4D36E96F-E325-11CE-BFC1-08002BE10318}

    Remove the value msvmmouf from the UpperFilters Regvalue.

    Reboot....

    tadaaa!!

    If you wish you can take out the drivers completely by deleting these registry hives completely :

    The driver:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\msvmmouf

    The Service:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\VPCMap

    The CopyHook Shell Extension: ( for folder access )
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{30C14BA C-122C-42ED-B319-1139DBF48EB8}\InProcServer32
    HKEY_CLASSES_ROOT\Directory\shellex\CopyHookHandle rs\VPCCopyHook

    After a reboot you can delete the "Virtual Machine Additions" folder from program files...

    Good Luck!

    Saturday, January 31, 2009 11:55 AM
  • thanks Vinnie U

    Simple fix...

    My base OS is W8_64B_Enterprise, with Hyper-V(W7).

    Monday, October 1, 2012 7:55 PM
  • Hi there 

    I am having the same issue I just made a recover form physical to virtual hyper V VM, i just get to the screen that is asking to log in, either the jkeyboard and mouse is working , I am not able to install the integration services on that particular VM because I have to login first, please some advice

    Tuesday, June 24, 2014 1:29 PM