none
Issue with File PPT in SharePoint RRS feed

  • Question

  • IE Brower and Chrome works fine, the issue is mainly with Firefox which is the main browser I use since the other apps/websites I use work best.

    Here is the screen shot of the error I get when I try to open the doc in office from Firefox.  When I go to troubleshoot, it says to make sure you have 32bit brower installed, which I do.

    Other people use Firefox and have not seen this error.


    Monday, July 15, 2019 5:44 AM

Answers

  • Hi SravanC,

    For Firefox,  NPAPI plugin support was disabled by default in version 52, and NPAPI plugin support will be removed in version 53 and later. If you are planning downgrade Firefox, you can install version 51.

    Note the risk when downgrade in the article below: Install an older version of Firefox

    https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no

    Per my knowledge, there is no method to fix this issue when we still use the current version of firefox.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by SravanC Wednesday, July 31, 2019 9:39 AM
    Tuesday, July 16, 2019 8:06 AM
    Moderator
  • Hi SravanC,

    For Firefox 52, there is a workaround to enable NPAPI plugins using an about:config setting, but in Firefox 53 and later, Mozilla remove this workaround.

    Reference: How To Re-Enable NPAPI Plugin Support (i.e. Java) in Firefox 52

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Friday, July 19, 2019 8:46 AM
    Moderator
  • Hi SravanC,

    I’m checking how the things are going on about this thread. Whether the post helps you?

    You can mark the post as answer if it helps.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by SravanC Friday, August 16, 2019 1:10 PM
    Wednesday, July 31, 2019 9:38 AM
    Moderator

All replies

  • Hi SravanC,

    What’s the version of Firefox you used to open SharePoint file?

    Since NPAPI add-on disabled on newer Firefox versions, the office web apps integration on SharePoint stopped working.

    Reference: Since firefox 53.0, the office web apps integration on sharepoint stopped working. What can I do to fix it?

    As a workaround, you can install an older version of Firefox.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, July 15, 2019 6:52 AM
    Moderator
  • Hi Wang,

    Thank you for the response.

    Below is the end user version

    so as a work around, shall i address the use to install version before 53.0? could you tell me the older version name which work out? 

    And apart from installing older version is there any way to fix this issue with current version(60) ? 


    • Edited by SravanC Tuesday, July 16, 2019 4:32 AM
    Tuesday, July 16, 2019 4:32 AM
  • Hi SravanC,

    For Firefox,  NPAPI plugin support was disabled by default in version 52, and NPAPI plugin support will be removed in version 53 and later. If you are planning downgrade Firefox, you can install version 51.

    Note the risk when downgrade in the article below: Install an older version of Firefox

    https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no

    Per my knowledge, there is no method to fix this issue when we still use the current version of firefox.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by SravanC Wednesday, July 31, 2019 9:39 AM
    Tuesday, July 16, 2019 8:06 AM
    Moderator
  • Hi Wang,

    is there any MS article saying that in 52, 53 & 60 versions NPAPI plugin support was disabled and removed. If you have please share it. 

    so if i enable NPAPI in 60 can not we resolve the issue? 

    and how to find out NPAPI plugin support is disabled? i verified from option in Firefox browser but could not find out.  

    Tuesday, July 16, 2019 9:38 AM
  • Hi SravanC,

    There is no Microsoft Official documentation mentions about this feature, however, there is roadmap from mozilla mentioned that starting with Firefox 52 in March 2017, plugins other than Adobe Flash are no longer supported in Firefox. Therefore we cannot enable NPAPI.

    https://developer.mozilla.org/en-US/docs/Plugins/Roadmap

    Thanks for your understanding.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Thursday, July 18, 2019 2:09 AM
    Moderator
  • Hi Wang,

    so in 51 NPAPI is already enabled? I am correct? 

    and one more thing I know it is not supported but how do we enable NPAPI in later versions of 52 to resolve the issue? i just want to cross check, Please show me the option where NPAPI setting is available

    Thank you 


    • Edited by SravanC Thursday, July 18, 2019 4:18 AM
    Thursday, July 18, 2019 4:18 AM
  • Hi SravanC,

    For Firefox 52, there is a workaround to enable NPAPI plugins using an about:config setting, but in Firefox 53 and later, Mozilla remove this workaround.

    Reference: How To Re-Enable NPAPI Plugin Support (i.e. Java) in Firefox 52

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Friday, July 19, 2019 8:46 AM
    Moderator
  • Hi SravanC,

    I’m checking how the things are going on about this thread. Whether the post helps you?

    You can mark the post as answer if it helps.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by SravanC Friday, August 16, 2019 1:10 PM
    Wednesday, July 31, 2019 9:38 AM
    Moderator