none
Viewing PDF documents RRS feed

  • Question

  • Is there a way to have sharepoint 2013 open PDF documents in the browser?  The behavior I am currently experiencing is that if I click on a PDF document in a document library, it wants to download it, and then I have to manually open the file.

    I prefer to click on the file in the document library and have it open in a new tab and rendered in browser.

    I appreciate any suggestions.

    Thursday, January 10, 2013 11:54 PM

Answers

  • The solution is:

    1) go to Central Administration

    2) Choose Manage Web Application

    3) Select Web Application that has the document library with the PDF files

    4) Click on General Settings -> General Settings in the top ribbon that appears when you selected the web application

    5) Scroll down until you see Browser File Handling and choose Permissive instead of Strict.  and click OK.

    Now the PDF files will open in the browser and will not require the user to download them first and manually open.

    • Marked as answer by tricolore Friday, January 11, 2013 4:54 AM
    Friday, January 11, 2013 4:54 AM

All replies

  • The solution is:

    1) go to Central Administration

    2) Choose Manage Web Application

    3) Select Web Application that has the document library with the PDF files

    4) Click on General Settings -> General Settings in the top ribbon that appears when you selected the web application

    5) Scroll down until you see Browser File Handling and choose Permissive instead of Strict.  and click OK.

    Now the PDF files will open in the browser and will not require the user to download them first and manually open.

    • Marked as answer by tricolore Friday, January 11, 2013 4:54 AM
    Friday, January 11, 2013 4:54 AM
  • The solution is:

    1) go to Central Administration

    2) Choose Manage Web Application

    3) Select Web Application that has the document library with the PDF files

    4) Click on General Settings -> General Settings in the top ribbon that appears when you selected the web application

    5) Scroll down until you see Browser File Handling and choose Permissive instead of Strict.  and click OK.

    Now the PDF files will open in the browser and will not require the user to download them first and manually open.


    What about for a SharePoint online environment that does not have Central Admin?
    Friday, March 15, 2013 8:36 PM
  • Hi tricolore,

    After applying solution in Central Administration for the particular site, the pdf files opens in browser with IE 8 but still asked to download from IE 9 & IE 10.

    Please give some suggestions.

    Monday, April 8, 2013 10:06 AM
  • Yeah, I see the same thing with IE 10.  I have no idea why this is happening, as it does not happen with Chrome or FireFox.  

    So my suggestion is to advise your users to use Google Chrome, as it has no issues.

    Tuesday, April 9, 2013 4:20 AM
  • Hi tricolore,

    Many users are still using IE. They prefer IE more than other browsers.

    Please anyone suggest for this. I don't want to enable users to download or save copy of my pdf files. So I want pdf files to view only from browser and not able to download.

    Tuesday, April 23, 2013 5:08 AM
  • Hey, I have checked for the users who have "View Only" Rights. They can view pdf files in IE also.

    But still the users are able to download or save the pdf files. What cab be done for this?? Please anyone give the solution for it.

    Tuesday, April 23, 2013 11:26 AM
  • Hi,

    I have added 'application/pdf' as a trusted MIME type to my SharePoint 2013 setup and I can open pdf files directly in Chrome but not in IE10. I have kept Browser File Handling as 'Strict'. Is there anything additional I need to do to enable direct opening in IE10?

    Wednesday, July 17, 2013 7:15 AM
  • I struggled with this issue too, but I have discovered a work-around. If you add your SP site to the list of sites to be viewed in Compatibility mode in IE10, it will work. Unfortunately, you then need to add the site to that list on all the PCs in your organization. I added a GPO to do that. Of course, after some testing, I determined that this only allows LINKS to pdf files to open in the browser though. Clicking directly on the item in a document library still opens Adobe Reader.


    Tuesday, April 1, 2014 3:58 PM