none
OOTB Publishing Workflow Error RRS feed

  • Question

  • Since Migration from SP10 to SP13 the OOTB-publishing-workflow is not working anymore.

    Workflow-Log:

    The workflow could not update the item, possibly because one or more columns for the item require a different type of information.

    List-Settings:

    Require content approval for submitted items? -> YES

    Workflow-Settings:

    Enable Content Approval -> Checked

    If i uncheck "Enable Content Approval" the workflow is working but, but the item is not approved.
    So it seems there is a problem for the workflow to access/update the "Approval Status"-column.

    Any suggestions to solve this problem ?

    Friday, May 22, 2015 10:58 AM

Answers

  • Solution:
    First of all, i had a problem showing the workflows in the SharePoint-Designer, caused by a missing list-template (no leading infos from SP-Designer at all !).

    I only had to republish the "Publishing Approval"-workflow and the problem was gone.

    • Marked as answer by Thomas Stessl Thursday, May 28, 2015 8:09 AM
    Thursday, May 28, 2015 8:08 AM

All replies

  • Hi Thomas,

    This issue may be due to the Approval workflow is corrupted.

    I recommend to re-publish the OOB Approval workflow to SharePoint with the following steps:

    1. Deactivate workflow feature from site collection.
    2. Use SharePoint Designer and delete the OOB Approval workflow from the site collection.
    3. Reactivate feature and verify Approval workflow is recreated.

    Best regards,

    Lisa Chen


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Sunday, May 24, 2015 3:51 AM
    Moderator
  • Hi Thomas,

    I had faced similar issue. We had email functionality in which there was an user added in Cc of email. When we checked specifically 'check errors' on that page, it errored there. As soon as CC field is removed, workflow started working fine.

    I would say, it might not be same issue but there must be some error in workflow. Try checking 'check errors' on each workflow activity page. Also, check for configuration mismatches if any on SP13 environment. 

    Thanks.

    Sunday, May 24, 2015 4:06 AM
  • Where do i delete the WF from the site collection. Cant find any entries.
    Tuesday, May 26, 2015 11:19 AM
  • I would start by just removing it from that library. Does it have that error everywhere, or just a specific library? If it is everywhere, then you can fix the workflow in SharePoint Designer, or just make a new one, and use that.
    Tuesday, May 26, 2015 1:14 PM
  • I created a new announcement-list with content approval turned on and a new publishing approval workflow  on a subsite. If the "Enable Content Approval"-setting of the workflow is turned on, I get a workflow error.

    So it looks like to be a bigger problem regarding workflows.
    SP2010 -> SP2013 Migration ?

    Tuesday, May 26, 2015 2:12 PM
  • I checked the list with the SharePoint-Mangager-Tool.

    There is no "DefaultContentApprovalWorkflowId" set. If i try to set this property, i get the exception:
    Microsoft.SharePoint.SPException: You can only add a default approval workflow to a list for which versioning and content approval have been enabled.

    But the "Moderation" is enabled.

    Tuesday, May 26, 2015 2:21 PM
  • I created a new Site-Collection and the workflow is working correctly.

    So the problem affects migrated SP2010-sites (Bug ?).

    Any solutions available ?

    Thursday, May 28, 2015 6:28 AM
  • Same happens on the test-system.

    Log:


    Thursday, May 28, 2015 6:54 AM
  • Solution:
    First of all, i had a problem showing the workflows in the SharePoint-Designer, caused by a missing list-template (no leading infos from SP-Designer at all !).

    I only had to republish the "Publishing Approval"-workflow and the problem was gone.

    • Marked as answer by Thomas Stessl Thursday, May 28, 2015 8:09 AM
    Thursday, May 28, 2015 8:08 AM