none
Rules in Error - "Cannot reply to message" error in outlook 2010

    Question

  • I have created a rule used previously in SP1 of 2007 that automatically replys with a template to recieved emails matching certain criteria. The rule is set to automatically run when the criteria exists.

    However when the rule is triggered I recieve the error: Rules in Error - "Cannot reply to message" and outlook turns off the rule.

    I have tried the KB article: KB2028839 and it has not helped as I am using the rule exactly as prescribed in the KB article.

    Has there since been a fix to this that I am not aware of yet?

    From reading other forums around I believe this bug has been around since 2007 SP2 was brought out. Surely there is a fix by now that I just can not find.

    Monday, August 30, 2010 3:05 AM

All replies

  • Hi,

     

    There is a bug in Outlook 2007 SP2 that prevents templates from working with rules.

     

    Outlook 2007 SP2 introduced a bug into the reply with template feature and it no longer works.

     

    I think it was related to a specific update (http://www.outlook-tips.net/archives/2009/20090721.htm ) but removing the update doesn't appear to fix it anymore.

     

    The problems fixed by the update are detailed in the following KB article.

     

    http://support.microsoft.com/kb/969907   

     

    Or you can do this:

     

    SP 2 broke Outlook 2007 on this. There's a workaround.

     

    1. Do everything MS tells you to do, including making sure it's in text.

     

    2. Move everything from you inbox to another temporary folder.

     

    3. Send yourself a message. You'll get the pop-up saying it sould not reply.

     

    4. Close outlook.

     

    5. Reopen outlook. You should still have the message you sent yourself there.

     

    6. Open rules again, recheck the box for your auto reply rule. Choose "run rule now" and on the dialog box, check your autoreply rule.

     

    7. It will work! And from now on (once it's run once) it will work, BUT ONLY AS LONG AS OUTLOOK STAYS ON. If you close outlook (or get an update that reboots your computer) the rule won't work any more. And you'll have to go through steps 2-6 again.

     

    8. The reason I had you transfer everything from your inbox in step 2 is because when you run rule now, it will send your autoreply to every message in the inbox. After you've run the rule manually, you can move the messages back from their temporary home into the Inbox.

     

     

    Regards,

     

    Harry Yuan

    • Marked as answer by Sally Tang Friday, September 03, 2010 8:27 AM
    • Unmarked as answer by Sally Tang Monday, February 14, 2011 7:52 AM
    Wednesday, September 01, 2010 9:34 AM
    Moderator
  • Have Microsoft released a fix for this yet, anybody? I would really like to know as it appears they don't seem to find it important at all, if it has been going on so long without them actually looking into it.

    Thank you.

    Willie

     

    Friday, January 07, 2011 11:45 AM
  • I am having the same problem with Outlook 2010... is there still no solution?!
    Wednesday, January 19, 2011 9:28 PM
  • Hello? Hello? Is this a Microsoft Support Site.... Hold on I will check..

     

    Oh yeah there it is in the address bar, social.technet.MICROSOFT.com.

    Sorry for the confusion but due to the complete LACK of response for months on a very wide spread, large impacting problem I am yet to see Microsoft actually help in anyway.

    Please this is driving me insane, it should be so simple, please help...

     

    hello? is anybody out there?

    Friday, January 28, 2011 1:26 AM
  • Harry,

    This does not work for 2010. It works once and breaks again.

    Please stop copy pasting this; it is useless, also please remove the green tick indicating it is the answer. It isn't.

    Friday, January 28, 2011 1:30 AM
  • I"m having the same issue here. Outlook 2010. I will buy another server and an exchange license for 3 users :-) . I guess this is the MS way.

    • Proposed as answer by Joe [OKC] Wednesday, August 03, 2011 9:27 PM
    • Unproposed as answer by Joe [OKC] Wednesday, August 03, 2011 9:27 PM
    Thursday, March 03, 2011 10:32 PM
  • Office 2010 SP1 seems to fix this.

    • Proposed as answer by Joe [OKC] Wednesday, August 03, 2011 9:28 PM
    Wednesday, August 03, 2011 9:28 PM
  • Not for me.

    I have a rule that runs on all incoming messages and I still see "rules in error" occasionally. Sometimes the rules in error window is hidden. I use Autohotkey to detect the existence of the window, make it un-hidden, dismiss it, and then re-enable the rule in Outlook. It is a hassle, but has been a suitable work-around.

    Monday, January 23, 2012 5:42 PM
  • Thank you thank you thank you

    This worked perfectly on Outlook 2010 which I have been fighting with for 3 days now. 

    So thank you to everyone that posts your problems and solutions.  They are really appreciated!

    Friday, June 22, 2012 3:43 PM
  • JennRC,

    What exactly worked for you?

    Wednesday, July 04, 2012 8:46 PM