none
Officed 2010 Install fails C\ProPlusWW.msi ErrorCode: 1603(0x643)

    Question

  • I've downloaded the Office 2010 ISO from Technet and with it I was able to make a DVD and then install Office 2010 onto a system, XP and Windows 7, with no problems.

    Now I'm trying to deploy it on to a Virtual Machine (VMware) , XP and Windows 7, and the installation fails, with the following error:

    Error: Failed to install product: C:\MSOCache\All Users\{90140000-0011-0000-0000-0000000FF1CE}-C\ProPlusWW.msi ErrorCode: 1603(0x643).

    This Virtual Machine dos not have a previous version of Office on it, nor does it have any Anti-Virus just to test it out. It does have windows installer 4.5 on it.

    The process fails in the same manner whether I try to install it from a Network Drive, or from a mounted ISO, or a mounted CD. It happens no matter if I use a Domain Administrator account, or a local administrator account. It fails even if I only select Word to install.

    I've tried to stuff mentioned in http://support.microsoft.com/kb/927153 and that does not help either.

    So any ideas why this error would happen on Virtual Machines but not physical systems, using the same installation media?

    Friday, May 28, 2010 7:51 PM

Answers

  • Hi, late but better late than never.

    I solved the Problem by Using the CD.
    On my Office CD is a Folder called ProPlus.ww that contains the ProPlusWW.msi
    I've changed the Path from C:\MSOCache\All Users\{90140000-0011-0000-0000-0000000FF1CE}-C\ProPlusWW.msi to
    the Installmedias folder and the Update was successful.

    Best Regards

    • Proposed as answer by borka Friday, April 27, 2012 1:29 PM
    • Marked as answer by GodOfLions Wednesday, March 26, 2014 2:48 PM
    Saturday, October 01, 2011 6:28 PM

All replies

  • Hi,

    The Windows error 1603 occurs when the user makes an attempt at installing the Microsoft Windows Installer package. The error message appears when the folder to which the user is attempting to install the said application is encrypted and when the drive containing the directory that the user is attempting to install the application to is used as the substitute drive. This issue also occurs when the SYSTEM account does not have the Full Control permissions for the directory where the Windows Installer package is being installed in. The error message is displayed because the service for the Windows Installer employs the SYSTEM account in the installation of software.

     

    To resolve this error, please first make sure that you install the application to a non-encrypted folder. You can right click C:\Program Files or other folder you want install the software, and choose Properties, click the Advanced button under the General tab, make sure the box is not checked: Encrypt contents to secure data.

                                                       

    Then, also try the steps to check the permission:

    ==================

     

    I suggest we check the related Registry permissions by performing the steps below:

    ----------------------

    1. Click "Start", in the Search box, type regedit" (without quotation marks) and click OK.

    Note: In Windows XP, click "Start", and click "Run". Type "regedit" (without quotation marks) and click OK.

     

    2. Right-click HKEY_LOCAL_MACHINE and choose Permission.

     

    3. Please check if "Administrators" is listed in the "Group and User" name list. If not, please click the "Add" button and type "Administrators" in the open window and click "OK" to add this group.

     

    4. Highlight "Administrators" and check on "Full Control" under "Accept".

    5. Click the "Advanced" button and choose the "Owner" tab.

     

    6. Highlight the current user account in the list and mark the check box before "Replace owner on subcontainers and objects".

    7. Click OK to save changes and wait for Windows XP to transfer the ownership of all the objects on the partition.

     

    Note: if there is the warning information "Error: The Registry Editor could not set security in the key currently selected, or some of its subkeys", it is normal. Please click "OK".

     

    8. Click OK again to save the changes and exit the Properties window.

     

    Then, please repeat the steps above to check permissions for this key:

    HKEY_CLASSES_ROOT

     

    Also check this:

    --------------------------------

    First, start your computer into Safe Mode.

     

    Then, use the following steps to take ownership of the Windows folder to ensure the permission is correct:

     

    1. Open My Computer and open the C drive.

    2. Right-click on the Windows folder and choose Properties.

     

    Note: I am assuming your Windows system is installed on the C:\Windows folder.

     

    3. Choose the "Security" tab and see if "Administrators" is listed in the "Group and User" name list. If not, please click the Add button and type "Administrators" in the open window and click "OK" to add this group.

     

    4. Highlight "Administrators" and check "Full Control" under "Accept".

    5. Click the "Advanced" button and choose the "Owner" tab.

     

    6. Highlight the "Administrators" user group in the list and mark the check box before "Replace owner on subcontainers and objects".

     

    7. Click "OK" to save changes and wait for Windows to transfer ownership of all the objects on the partition.

     

    8. Click OK again to save changes and exit the Properties window.

     

    After this, please try to install the software again.

     

    There is also a similar thread here for your information:

    http://social.technet.microsoft.com/Forums/en/outlook/thread/6e8731f7-1d6e-468f-966e-1351bf4a25a3

     

     

    • Marked as answer by Jennifer Zhan Tuesday, June 01, 2010 5:59 AM
    • Unmarked as answer by GodOfLions Wednesday, June 09, 2010 6:02 PM
    Monday, May 31, 2010 1:40 AM
  • The problem still persists even after doing the following:

    1. Verifying that Administrator has Full Control, and ownership of HKEY_LOCAL_MACHINE and HKEY_CLASSES_ROOT in the registry.

    2. Verifying that Administrator has Full Control, and ownership of C:\, and C:\Windows

    3. Deleting the HKEY_LOCAL_MACHINE\Software\Microsoft\Office key that was present before the installation

    This is all being done on a freshly loaded Windows XP system in a VMWare Virtual Machine. I've downloaded and installed all the updates and installed Windows Installer 4.5 and made sure it was upto date as well.

    The problem still persists. It happens even if I only select just Word to install, and none of the sub-options to word. It still comes back with the same error.

    Friday, June 04, 2010 12:13 PM
  • I'm having the same problem.  Did you find a solution to the error message?
    Wednesday, November 03, 2010 11:33 PM
  • I am receiving the same error when trying to install Project 2010 on an XP SP3 machine
    Tuesday, November 16, 2010 3:06 PM
  • I also am receiving this error , but one in VM computers

    Thursday, January 27, 2011 4:53 PM
  • I am also getting this error.
    Wednesday, April 27, 2011 8:14 PM
  • Hi, late but better late than never.

    I solved the Problem by Using the CD.
    On my Office CD is a Folder called ProPlus.ww that contains the ProPlusWW.msi
    I've changed the Path from C:\MSOCache\All Users\{90140000-0011-0000-0000-0000000FF1CE}-C\ProPlusWW.msi to
    the Installmedias folder and the Update was successful.

    Best Regards

    • Proposed as answer by borka Friday, April 27, 2012 1:29 PM
    • Marked as answer by GodOfLions Wednesday, March 26, 2014 2:48 PM
    Saturday, October 01, 2011 6:28 PM
  • How do you do that step by step please? I'm kind of a newbie at this kind of stuff
    Thursday, November 08, 2012 12:57 PM
  • I've encountered the same issue several times. Tried all thats advised here, also on a fresh admin account etc. None helped.

    What solved it in my case was related to the other language I wanted to get installed as well. I removed (renamed) the Office.[lang tag] directory and the installation went fine, at last. Including SP1 integration and custom setup admin file.

    Maybe this helps sb.

    Saturday, April 13, 2013 2:54 PM
  • Hi, late but better late than never.

    I solved the Problem by Using the CD.
    On my Office CD is a Folder called ProPlus.ww that contains the ProPlusWW.msi
    I've changed the Path from C:\MSOCache\All Users\{90140000-0011-0000-0000-0000000FF1CE}-C\ProPlusWW.msi to
    the Installmedias folder and the Update was successful.

    Best Regards

    I don't have ProPlusWW.msi in my instalation. Only  ProPlusrWW.msi... Crapy update :-(.
    Tuesday, August 27, 2013 10:17 AM
  • Had to uninstall and install again to solve this issue.

    1. Unistall your MS Office SP1.
    2. Restart system.
    3. Install SP1 version again.
    4. Install SP2 update.
    Tuesday, August 27, 2013 10:50 AM