none
PowerPoint becomes read only

    Question

  • I posted this question at the Microsoft Community, but did not get an answer, so I'm hoping someone can shed some light on this here.

    A user in our office has been having this issue since we upgraded to Windows 7 & Office 2010 a few months ago: 

    She'll be working in a PowerPoint presentation and saving changes without any error.  But then she tries to save her file again, and all of a sudden the file is read only and this message pops up: 

    "PowerPoint was unable to open or save this document. Please ensure that you have access privileges to read or write the document and that it is not encrypted."

    Read-only is not displayed in the Title Bar.  And if she tries to save it as a new document, the same message pops up.

    The only way to save the file is to copy all of the slides and paste them into a new presentation.  She has to do this several times a day!

    I researched the issue, and some suggestions were to:  disable add-ins, close the Preview Pane and Details pane in Windows Explorer, disable anti-virus software, change the auto-save location, save locally instead of on the network -- I have tried all of these suggestions, but the issue continues.

    After doing some additional research and testing, I finally narrowed it down to Microsoft Excel Worksheet objects that are causing the problem - at least this is the only way I've been able to re-create the issue on other computers. 

    So does anyone have any ideas as to what could be causing this problem?  Is Microsoft aware of this issue?   

    Monday, August 12, 2013 10:33 PM

Answers

  • Looks like I may have figured it out! 

    I have turned off (unchecked) Enable Data Execution Prevention Mode in Excel, and so far no read-only issues in PowerPoint that have Excel objects!  Yay! 

    To turn off this option:

    1. Open Excel.
    2. Go to File > Options > Trust Center > Trust Center Settings > Protected View > UNCHECK the box next to Enable Data Execution Prevention Mode.
    • Marked as answer by KrystyneW Tuesday, August 13, 2013 5:00 PM
    Tuesday, August 13, 2013 4:57 PM

All replies

  • Looks like I may have figured it out! 

    I have turned off (unchecked) Enable Data Execution Prevention Mode in Excel, and so far no read-only issues in PowerPoint that have Excel objects!  Yay! 

    To turn off this option:

    1. Open Excel.
    2. Go to File > Options > Trust Center > Trust Center Settings > Protected View > UNCHECK the box next to Enable Data Execution Prevention Mode.
    • Marked as answer by KrystyneW Tuesday, August 13, 2013 5:00 PM
    Tuesday, August 13, 2013 4:57 PM
  • Quick Question

    Using Office 2010, I go under the the above path, and see this instead:

    Protected View

    Enable Protected View for files originating from the Internet

    Enable Protected View for files located in potentially unsafe locations

    Enable Protected View for Outlook attachments.

    Am I doing something wrong?  I have a user having the same issue so looking for a fix but not seeing the same thing as what is located above in the post.  

    Wednesday, April 09, 2014 1:03 PM
  • Hello All,

    I had a similar situation with a little difference and is only that my pptx file was on a network location. Besides, doing some further research on the internet, all similar cases also makes reference to have excel graphs/content embedded so what i have done (and had to do it only once)  for both, Excel and PowerPoint (both part of Office 2013 suite is) is the following:

    1. Open Excel/Power Point
    2. Go to File > Options > Trust Center > Trust Center Settings > Trusted Locations > Add the full network path and also check the option "Include/Trust Subfolders on this location".
    3. Remove the slide where the table/graph from excel is included.
    4. Save your pptx (it should now save your document) with a different name (i.e. name_v1.0.pptx)
    5. Once saved, press ctrl+z (undo command) and the missing slide(s) should/will come back, now save your pptx again with a simple ctrl+s and your file should be good now.

    I hope that this small suggestion helps anyone out there with this odd issue that can drive you crazy especially if you have been working on this pptx a lot of time.

    With Best Regards

    AP

    Thursday, November 13, 2014 1:01 PM
  • We have had the same issue as the others in this thread, and our project was on a shared drive.

    We had success with AP's process; however, our project included several slides with embedded excel spreadsheets.  We found the easiest solution for us was to copy the slides and paste them into an empty powerpoint with formatting.  We were able to save the new powerpoint without any issues.

    B14


    Tuesday, December 09, 2014 4:50 PM
  • I can't thank you enough, this solved it for me in Office 2013 -- well it's a little different (there is no Enable Data Execution Prevention Mode, but some other options very similar)

    I have spent unbelievable hours trying to fix and lost a lot of hours of work -- in my case I couldn't even copy and paste charts I myself had created!

    Monday, January 05, 2015 4:46 PM