none
The URL '<Doc lib>/File name' is invalid. It may refer to a nonexistent file or folder, or refer to a valid file or folder that is not in the current Web. sharePoint 2010 rbs RRS feed

  • Question

  • Hi,

    I am working on configuring the RBS in the SharePoint 2010 with SQL server 2008 on Windows server 2008. I have followed all the steps which are mentioned in the Microsoft site (http://technet.microsoft.com/en-us/library/ee663474(office.14).aspx#proctrbs) . i could able to run all the steps successfully.

    When i am Trying the test the RBS implementation I am gettting the Above error
    like "The URL '<Doc lib>/File name' is invalid.  It may refer to a nonexistent file or folder, or refer to a valid file or folder that is not in the current Web. '

    Even i have created the new document library and tried to upload still i am getting the same error message

    Please suggest how to overcome with this issues.

    Thanks

    Kotresh
    Kots
    • Moved by Lily Wu Monday, January 25, 2010 3:18 AM SharePoint 2010 issue (From:SharePoint - General Question and Answers and Discussion)
    Thursday, January 21, 2010 8:20 AM

All replies

  • Hi Kotresh,

    I am also facing the same problem

    "The URL '<Doc lib>/File name' is invalid.  It may refer to a nonexistent file or folder, or refer to a valid file or folder that is not in the current Web. '

    Did you get answer to this? Itwould be great if you can share the solution with me.

    Thanks, Simant


    Corporate Branding & Collaboration Consultant simant@live.in
    Wednesday, May 5, 2010 9:06 PM
  • If you have AvePoint software installed, as a test, try removing it from all servers in the farm. If AvePoint seems to be the culprit, try installing the software consisitanlty on all servers (WFE's etc).
    Monday, May 10, 2010 10:34 PM
  • Hi I have Installed SharePOint 2010 and configure a RBS. after that I am getting same exception. and not able to add the document / picture in the list. Can you please help me to resolve this issue.
    Thanks, TusharG [There are only 10 types of people in the world: Those who understand binary, and those who don't]
    Monday, June 28, 2010 12:39 PM
  • Hi,

    I have also installed and configured RBS for SharePoint Server 2010 (Enterprise version) following the instructions found in Todd Klindt's blog . As many people pointed out, this is a really good post on how to have RBS up and running. Now troubles arise when you are trying to configure it in a farm of more than one server.

    In my case, I'm having the same problems as Kotresh, Simant and Tushar. After installation and configuration have been successfully completed and when trying to upload a file to a document library (located in a Site Collection that belongs to a Web Application that points to the blob content database) we get the same, by now feared, error message "The URL '<Doc lib>/File name' is invalid.  It may refer to a nonexistent file or folder, or refer to a valid file or folder that is not in the current Web. "

     

    Now, as far as we can tell, the configuration process was done correctly (in both SQL and SharePoint servers) and leaving the value of MinimumBlobStorageSize   untouched, we can see the following scenarios:

    1. Upload a file less than 100 KB: Success. (File is stored in the content database, like on any plain SharePoint document library)

    2. Upload a file greater than 100 KB and less than 1 MB: Success . (File is stored in the C:\BlobStore folder, with a particular folder structure and file naming convention, but saved in a Windows folder nevertheless!)

    3. Upload a file greater than 1 MB: Failure . (We get the "The URL '<Doc lib>/File name' is invalid" error message)

     

    I have check and discovered in this blog and in this comment (titled Filestream Impersonation ) from Todd Klindt's post, that in a multi-server SharePoint farm the only way to solve this problem is to have all the servers of said farm using the same version of the operating system. Sadly in our case that is not the solution that solves our headaches. We have a farm of 4 VMWare Virtual Machines, each running Windows Server 2008 R2 Standard and each built upon the same basic Windows Server 2008 R2 VM (meaning: no roles enabled, no features installed, etc.). So there is nothing we need to change or upgrade.

     

    I'm also sending the results of entering the following Powershell commands in the SharePoint 2010 Administration Shell:

    $cdb = Get-SPContentDatabase 'SharePoint_Content_Blob'
    $rbss = $cdb.RemoteBlobStorageSettings
    $rbss

     Enabled ActiveProviderName               MinimumBlobStorageSize UpgradedPersistedProperties
     ------- ------------------               ---------------------- ---------------------------
        True FilestreamProvider_1                                  0 {}

     

    Is there any else we can do in order to find an answer to this problem? Have you guys tried something else? Any help on this matter will be gratefully appreciated.

    Many thanks in advance

     

    Carlos Vigo

     

     

    Friday, August 13, 2010 10:45 AM
  • I had the same exact problem that Carlos posted.  It took three days of troubleshooting with Microsoft Tech Support to come up with a solution. 

    Background: I installed SharePoint 2010 Standard on a VM in vSphere 4.1. I had SharePoint 2010 use my SQL 2008 Standard Server that was on a physical box.  I setup RBS using FILESTREAM.

     

    Problem:

    1. Upload a file less than 100 KB: Success. (File is stored in the content database, like on any plain SharePoint document library)

    2. Upload a file greater than 100 KB and less than 1 MB: Success . (File is stored in the C:\BlobStore folder, with a particular folder structure and file naming convention, but saved in a Windows folder nevertheless!)

    3. Upload a file greater than 1 MB: Failure . (We get the "The URL '<Doc lib>/File name' is invalid" error message)

     

    Solution: A Microsoft SQL engineer remoted in and typed in the following command in SQL:

    SP_CONFIGURE 'filestream access level',2
    go
    reconfigure with override

    This is the message she sent me:

    "I found an issue with filestream setting, I ran the below mentioned T-SQL and took the SQL SERVER restart

    SP_CONFIGURE 'filestream access level',2
    go
    reconfigure with override

    After this we uploaded two files whose size was more than 2 MB and its uploaded successfully."

     

    Explantion: I did some research in to what that command does and found this:

    “FILESTREAM Access Level ‘0’ and ‘1’ are interpreted exactly as documented (0 for Disabled and 1 for TSQL Access). The documentation says that ‘2’ stands for ‘TSQL and Win32 Access’ which is also known as ‘Full Access’”.

    “The FULL Access may be of two flavors. TSQL + Win32 Access (Local) and TSQL + Win32 Access (Remote). It means that the configuration value ‘2’ means TSQL and Local Win32 API Access. Configuration value ‘3’ stands for TSQL and Remote Win32 API Access”

     

    You can find more info about it on this BLOG that I found:

    http://beyondrelational.com/blogs/jacob/archive/2010/03/02/what-is-the-filestream-access-level-on-your-server-instance-oh-i-have-got-a-3.aspx

    Friday, December 3, 2010 2:20 PM
  • Why did you mention this about AvePoint? 
    Tuesday, March 15, 2011 11:04 AM
  • I was wondering if you ever got this fixed.  I've just installed Sharepoint 2010 on SQL Server 2008 with RBS and am having the same problem.

     

    Thursday, April 14, 2011 9:55 PM
  • There has got to be some type of bug in 2010 causing this error.  I'm seeing it in different locations / circumstances.  I've seen it happen to random docs when migrating them to a new site.  I've also seen it when migrating docs from Notes to Sharepoint.  The security on random documents gets corrupted, and results in this error.  WHen you try to manage permissions on these docs, it throws up as well.
    Wednesday, May 25, 2011 1:19 PM
  • There has got to be some type of bug in 2010 causing this error.  I'm seeing it in different locations / circumstances.  I've seen it happen to random docs when migrating them to a new site.  I've also seen it when migrating docs from Notes to Sharepoint.  The security on random documents gets corrupted, and results in this error.  WHen you try to manage permissions on these docs, it throws up as well.


    Well to be honest there are a couple of scenarios here

    1) I am getting the same error after following dito step by step intructions from the microsoft site and still getting the same error.

    (Here no file Gets Uploaded, I even tried to un-install and re-install everything as per the given steps)

             a) Filestream access level set to 2

             b) Installed RBS on both SQL server and Sharepoint server as per instruction

    2) Where one the above steps is missed  a) step above then you cannot upload files greater than one MB, in this case you need to enable Filestream on the SQL server, and appropriate the level 2 permissions

     

    As for step 1) am still puzzled. I will try to remove everything again and give it another shot but I must say I have installed RBS on two other sites using the same microsoft site steps this time it was a bit wierd.

     

    Best Regards,

    Anwar

    P.S.

    Will let you know what the outcome is of re-installation in step 1

     


    MAAS
    Thursday, August 4, 2011 3:53 PM
  • I received the exact same error on my environment. I would like to try Jonathan Bentancourt's proposed solution but I'm not able to uncheck the "Allow remote clients to have streaming access to FILESTREAM data' option. If I'm not mistaken, this option is chekcked and greyed out by default in a SQL Failover cluster which what I have for my SharePoint 2010 environment.

    How do I uncheck this option? And if there is any other approach I should try?

    Thanks,

    Phu Huynh

     

    Monday, October 17, 2011 11:34 PM
  • Any updates on this? I have the exact configuration - SP2010, SQL2008 and using RBS. In my case, I'm not able to upload anything. I was able to Uncheck the FILESTREAM option on SQL Configuration Manager that says "Allow remote clients to have streaming access to FILESTREAM data".

    When I had this checked, the value returned by

    SELECT  SERVERPROPERTY ('FilestreamEffectiveLevel')

    ======================================

    3

     

    Unchecked, it returned 2.

    Not sure if this is relevant, but I've tried all I can think of and still no success.

    Thursday, October 27, 2011 6:39 PM
  • I am receiving the same error but I am using SharePoint 2013 and SQL Server 2012. I've followed the guide but I can't seem to get past this...
    Tuesday, January 15, 2013 7:38 PM
  • This is how I fixed it.

    1. Find the service account for the application pool that uses the database that you have configured RBS on.

    2. Make sure that service account has dbo_owner rights on the database with RBS


    Chris

    • Proposed as answer by Sergy11 Thursday, June 20, 2013 2:17 PM
    Thursday, June 20, 2013 12:02 AM
  • Chris, thank you so much, you saved my day
    Tuesday, May 26, 2015 8:33 AM