none
Using a Document Library Template with Column Default Settings RRS feed

  • Question

  • I am using a Document Library with a specific folder structure to store documents.  The library has Default Column Values set on each of the folders to set a variety of attributes to meet the needs of our file plan.  When I try to copy or template the library for replication the Default Column Value settings do not copy.  The folder structure and content will copy in several methods, but the values do not carry forward.  We had assumed in our planning that a direct copy of the library using ShareGate or Metalogix, or even a Library template OOTB would create a copy that had all settings.

    Thanks in advance for any help!  My deadline is rapidly approaching as this was unforeseen.


    Greg Bartlett

    Friday, April 28, 2017 6:57 PM

Answers

  • Hi Greg,

    This is a known issue in SharePoint. When you define Column Default Settings for a Library or folder, this information is included in any list template that you save on this basis. However, when instantiating a new library from your list template, the Defaults you have entered previously remain linked to the OLD (original) library. So, the reference isn't updated to match the newly created library.

    Please follow the steps below to fix this issue:

    1. Open the site where the new library is created in SharePoint Designer.
    2. Using "All Files", navigate to the "Forms" folder of the library you created based on your template.
    3. Open the file "client_LocationBasedDefaults.html".
    4. Find the relative reference to your original library and replace that path with the correct one.
    5. Save the file.

    Best Regards,

    Victoria

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, May 1, 2017 6:40 AM
    Moderator

All replies

  • You mean to say metadata properties would not being copied. If I am correct, Use Sharegate or metalogix tools for coping files.

    ----------------------------------------------------------------------------

    Thanks

    Lalith

    ----------------------------------------

    Please mark as Answer, if this post solves your issue.


    Friday, April 28, 2017 7:32 PM
  • Hi Greg,

    This is a known issue in SharePoint. When you define Column Default Settings for a Library or folder, this information is included in any list template that you save on this basis. However, when instantiating a new library from your list template, the Defaults you have entered previously remain linked to the OLD (original) library. So, the reference isn't updated to match the newly created library.

    Please follow the steps below to fix this issue:

    1. Open the site where the new library is created in SharePoint Designer.
    2. Using "All Files", navigate to the "Forms" folder of the library you created based on your template.
    3. Open the file "client_LocationBasedDefaults.html".
    4. Find the relative reference to your original library and replace that path with the correct one.
    5. Save the file.

    Best Regards,

    Victoria

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, May 1, 2017 6:40 AM
    Moderator
  • Thank you Victoria.

    Greg Bartlett

    Monday, May 1, 2017 11:34 AM