I just deployed the new Lync Client for Android


  • I just deployed the new Lync Client for Android. However when I try to connect from the Android, I recieve the error "Cant connect to the server. It may be unavailable. Also please check your network connection sign-in address and server addresses. "

    When I attempted to connect I left everything on the Android at default just like I did with the Lync client on a PC outside the network (which works). I know this is brand new but any suggestions? Does the Android need a certificate? I have made a DNS entry for my Reverse Proxy for

    Do settings on the Edge or RProxy need to be modified or if the client works on a PC it should work on a mobile device.

    Any help is appreciated

    Thank you

    Wednesday, December 14, 2011 1:41 PM


All replies

  • Did you do all the updates on the Lync server for mobility, or did you just install the Android client and try to connect? 
    Wednesday, December 14, 2011 1:53 PM
  • I am going though the steps listed at

    I think my answers are all there

    • Marked as answer by SteveHDI Wednesday, December 14, 2011 3:31 PM
    Wednesday, December 14, 2011 3:31 PM
  • I can verify that the Android client works nicely. I even was using non-trusted certificate to test before spending money on a "real" certificate and I got a notice that I could "x" out of but then everything worked well. One interesting bug, though, is that once you set Lync up and have it running in the background you can't get back to it by doing a click-hold on the "Home" button to get recent apps as if you go that way and select the Lync App it tries to start a new session (at least that is what I think is happening) and then just disappears when you click Connect. I thought something was screwy until I finally just put the app on the home screen to click on (to save time while testing) and found that it works just fine that way. Anyway, definitely follow the steps above thoroughly and you should be good to go (as you mentioned).


    Wednesday, December 14, 2011 5:49 PM
  • I've just tried to get back to Lync as you said, and then it's successful for me to get into Lync view by clicking the Lync icon on the recent apps list.


    • Edited by Joezhao Thursday, December 15, 2011 7:42 AM
    Thursday, December 15, 2011 7:30 AM
  • yeah, it is funny, the recent apps thing works for me now just fine too. The App must not have been fully "setup" until I used the link within the apps folder (or from the home area).
    Thursday, December 15, 2011 12:08 PM
  • The only real issue I found was running the bootstrapper from the Lync Power Shell. I would hit return and nothing happened. Tried this on two lync servers. Finally I wondered what would happen if I dragged the bootstrapper and dropped it on the power shell. It ran!!!! All is well
    Thursday, December 15, 2011 1:57 PM
  • I followed the guide to the's resolving my server just fine via the autodiscover records because i get prompted about the untrusted certificate, but it allows me to accept it...but eventually it comes back and says that "an unknown error has occurred."


    Nothing shows up in the event logs on the server itself...any ideas of something i can try?

    Thursday, December 15, 2011 7:56 PM
  • can you run the Lync Logging Tool with the SIP stuff checked during the attempt to see if you see anything show up when you analyze the logs? I get the untrusted cert error too (since for now I'm using in in house CA) but once I "x" out of that notice everything runs smoothly. So, hopefully the logging trace turns up something


    Thursday, December 15, 2011 8:08 PM
  • nothing meaningful in the traces with SIP logging there any way i can refine it further, any particular components i should have enabled for logging?
    Thursday, December 15, 2011 8:50 PM
  • Well, I should have known.

    Resolved...remember the first rule of working in technology--

    --when all else fails, reboot.

    I restarted all of the Lync services and IIS after the install, but i didn't want to take down a production server in the middle of the day to reboot.  Late in the day, I decided it was worth a shot...and voila, the client connects properly!

    Thursday, December 15, 2011 10:31 PM