Configure Alerts in Sharepoint 2007


  • I am having trouble setting up alerts in Sharepoint 2007.  When I setup an alert from a document library to alert me of any new editions, I do not recieve an email notification.  Is there something I am missing?  I installed the SMTP service on my Sharepoint virtual server and confiured the outgoing email settings through central administration.

    Monday, August 27, 2007 11:37 AM

All replies

  • Is your Sharepoint server trusted by your mail server for sending e-mail. Usually security settings on you mail server will prevent the outgoing e-mail.


    (BTW, for setting up Outgoing e-mail you usually don't have to set up SMTP, unless you don't have another e-mail server on your network.)



    Thursday, August 30, 2007 12:40 PM
  • Do you know what security settings I would need to change?  The Security Settings on the server itself or in the Exchange 2007 management console?  They are both on the same domain, shouldn't they already trust each other?

    Thursday, August 30, 2007 3:52 PM
  • Not off the top of my head (not an Exchange Guy). In my organization we control the trusted senders to prevent malicious e-mail senders. (I think this becae standard about 3-4 years ago.)


    Anyway, talk to your e-mail admin and ask about trusted referers (I think that is the term, or Relay)


    Sorry I cannot be more precise.


    Friday, August 31, 2007 11:57 AM
  • BTW, do you get the Alert Confirmation e-mail?

    Friday, October 19, 2007 1:21 PM
  • Yes.  After we completed our migration to exchange, the alerts started generating.


    Friday, October 19, 2007 1:23 PM

    I'm having a similar issue. I get the email informing me that the alert was created but don't get any emails when documents are added. However this seems to be an issue with the "new item added" type alerts only, the "All changes" alert works fine. Therefore i don't think this is an exchange issue. have any of you experienced this before? There's nothign about it on the net.
    Thursday, April 17, 2008 6:26 AM