Runtime Error Occurred During the Loading of the COM Add-in RRS feed

  • Question

  • For starters this is not an add-in I created nor am I doing any development/programming work.  This is why I didn't post in the VS forums; perhaps that was a mistake?

    We're a Windows 7 (32-bit) + Office 2007 SP2 shop & one of our users recently reported that a specific third party add-in is no longer loading in Word.  They couldn't specifically pinpoint when this began or what recent events may have taken place that could have contributed to or otherwise caused this problem.  (Addition/Removal of application, application updates, etc.)

    When we check the add-ins under Word > Options > Add-Ins > COM Add-ins both have the same error

    Not loaded.  A runtime error occurred during the loading of the COM Add-in.

    Steps taken so far:

    • Uninstalled & reinstalled this add-in - no change  
    • Logged on as myself (for the first time) & was able to reproduce the issue suggesting its not a user/profile specific problem but something with their machine as a whole.
    • Performed repair install of Office 2007 - no change
    • Performed repair install of VSTO 8.0.50727.940 - no change
    • Verified health of .NET via the .NET verification tool - no errors but performed whatever it 'recommended'
    • Performed repair of .NET 3.5 SP1 (the one built into Win 7) by removing it, rebooting & re-adding - no change
    • Performed repair of .NET 4.0 Full - no change
    • Removed all add-ins except for those related to that add-in - no change
    • Removed all templates (office12\startup) except for the ones related to that add-in - no change
    • Attempted to debugging VSTO using log files & alerts by creating environment variables (VSTO_SUPPRESSDISPLAYALERTS=0 & VSTO_LOGALERTS=1) but I'm not seeing alerts and no log files are created.
    • Ran sfc /scannow, errors found rebooted; re-ran sfc, no errors - no change
    • Ensured loadbehavior was set to 3 at every step
    • Ensured not disabled in GUI or via registry (resiliency) at every step

    Not sure what else to try at this point beyond reimaging or replacing.

    • Edited by JuliusPIV Friday, March 1, 2013 4:40 PM
    Thursday, February 28, 2013 7:15 PM

All replies

  • Hi,

    The reason you didn't see the alert mgiht because you haven't set the LoadBehavior value to 3.

    Try follow the troubleshooting steps in the following blog articles:

    My Office Addin does not Load!

    Troubleshooting COM Add-In load failures

    Max Meng
    TechNet Community Support

    Friday, March 1, 2013 5:58 AM
  • Thanks for the prompt response Max Meng!

    After every failed attempt, I jump back into the registry & set the LoadBehavior for both back to 3 from 2.  I also verified they're not disabled via the GUI or 'hard' disabled via the registry (the resiliency key doesn't even exist).  I neglected to mention these two things in my post & for that I apologize.  Knowing this, I'm sure you can understand why I'm perplexed that I'm not seeing alerts!

    As for the other steps in the second link

    • I'm not sure how to handle step 2 in the first section - Do you have some guidance here?
    • I'm not clear on what vbscript suggestion in step 3: how do I determine/confirm the class?  - Do you have some guidance here?
    • AV is up to date & there are no alerts that AV is blocking execution.  There are 1600+ other users with the same AV setup and its been this way for some time - still, I could temporarily disable even though I don't think that's going to help.
    • I haven't tried repair installs or just reinstalling PIA in step 2 of the second section - Will try!
    • Fusion logs look promising

    I'll do this as soon as the user is available & post back results.  Thanks

    Friday, March 1, 2013 4:38 PM
  • Hello Julius,

    I am also facing the same issue. with my excel addin. I tried with all the possibilities like setting load behavior to 3.

    When I am open the excel addin I checked the registry value its loadbehavior  is 3 only.

    Even though its showing "Not Loaded. A runtime error occurred during the loading of the com add-in in excel 2016".

    I developed the addin using c#.net and Visual studio 2017 I used the .net framework version 4.5.2.

    Please help me out this problem.

    Thanks in advance.

    Monday, July 23, 2018 8:03 AM