locked
The Managed Metadata Service or Connection is currently not available RRS feed

  • Question

  • Hello Everyone,

    I thought I would add another "Managed Metadata Service or Connection is currently not available" thread to this forum. 

    It appears after following several articles I still cannot get manage my Managed Metadata Service from Central Admin.  I get the below error message.

    I also see this in my ULS logs:

    Failed to get term store for proxy 'Managed Metadata Service Application'. Exception: System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.   

    at Microsoft.SharePoint.Taxonomy.Internal.XmlDataReader.GetDateTime(String name)   

    at Microsoft.SharePoint.Taxonomy.Internal.SharedTermStore.Initialize(IDataReader dataReader, Guid termStoreIdValue, Boolean fromPersistedData)   

    at Microsoft.SharePoint.Taxonomy.Internal.SharedTermStore..ctor(IDataReader dataReader, Guid termStoreId, Boolean fromPersistedData)   

    at Microsoft.SharePoint.Taxonomy.Internal.DataAccessManager.GetTermStoreData(MetadataWebServiceApplicationProxy sharedServiceProxy, Boolean& partitionCreated)

    One of the articles I found had several steps, however non worked for me.

    http://blogs.msdn.com/b/allenwang/archive/2011/03/22/the-managed-metadata-or-connection-is-currently-not-available.aspx

    Finially I simply deleted my Metadata Services Application and App Pool from IIS, re-created it and restarted IIS but still getting the same error message.

    Only thing I didn't do is delete the database which I don't think I want to do.

    Anything else I can try?

    Thanks,

    Ian...

    Monday, February 3, 2014 5:14 PM

Answers

  • Did you already check the permissions on the following registry key:

    HKLM\Software\Microsoft\office Server\15.0

    As stated in a TechNet article (Account permissions and security settings in SharePoint 2013), the both users "WSS_Admin_WPG" and "WSS_WPG" need the respective permissions on this key. In my case, the permissions were completly missing, causing this issue. The permissions could be successfully added using the following PowerShell command:

    Initialize-SPResourceSecurity

    However, the error message in my log file was something different, as follows:

    Failed to get term store for proxy ‘Managed Metadata Service Application Proxy’. Exception: System.Security.SecurityException: Requested registry access is not allowed.

    • Marked as answer by JasonGuo Sunday, February 16, 2014 1:22 PM
    Thursday, February 6, 2014 8:11 AM
  • I solved the same problem simply going to 'Manage services on server' and changing 'Database Name' in 'Managed Metadata Service' (without having database permission, so no effective changes was made) and then return to old 'Database Name' (so mantaing all old data)

    • Marked as answer by igibason Friday, September 5, 2014 2:08 PM
    Wednesday, September 3, 2014 3:31 PM

All replies

  • Is this a database that came from 2010?  Or is it new to 2013 (provisioned in 2013)?

    Monday, February 3, 2014 5:19 PM
  • Try to add Managed Metadata Service application to default proxy group (if not added). Also check if Managed Metadata Service Web Service is Running on page http://central_admin/_admin/Server.aspx - if not started, start and do iisreset.

    Best regards, Andrii

    Monday, February 3, 2014 5:47 PM
  • How did you go about recreating the Managed Metadata Service Application? Did you point the service application at the existing database when recreating it or did you create it with a 'dummy' database and use the following PowerShell to point it at the old database?

    $app = Get-SPServiceApplication -Name "<ServiceApplicationName>"
    Set-SPMetadataServiceApplication -Identity $app -DatabaseName "<DbName>"

    Also, I have seen scenarios where the MMD service application db is completely corrupt and the only way to retain data is through the commands specified here: http://social.technet.microsoft.com/wiki/contents/articles/5233.sharepoint-2010-import-export-termset.aspx


    Regards,

    Andrew J Billings

    Portal Systems Engineer//MCSA,MCSE

    Blog: http://www.andrewjbillings.com  Twitter:   LinkedIn:   

    Monday, February 3, 2014 6:18 PM
  • Is this issue only in Central Administration? Can you access the Term Store from the Site Settings page in one of your site collections?

    Monday, February 3, 2014 7:32 PM
  • Hi Andrii,

    Thanks for the reply...this is a new SP2013 database

    Monday, February 3, 2014 7:34 PM
  • Hi Andrii,

    It is part of the default proxy group and the service is started...I have even stopped and restarted and restart IIS

    Monday, February 3, 2014 7:35 PM
  • Hi re-created it first deleting the metadata service application, then I deleted the app pool.  Created new Metadata service application and typed in the same database name on the same sql server.

    Monday, February 3, 2014 7:37 PM
  • Hey Jason,

    Thanks for the input.  This issue is in Central Administration as well as the Term Store from my Site Settings

    Thanks...

    Monday, February 3, 2014 7:43 PM
  • Did you already check the permissions on the following registry key:

    HKLM\Software\Microsoft\office Server\15.0

    As stated in a TechNet article (Account permissions and security settings in SharePoint 2013), the both users "WSS_Admin_WPG" and "WSS_WPG" need the respective permissions on this key. In my case, the permissions were completly missing, causing this issue. The permissions could be successfully added using the following PowerShell command:

    Initialize-SPResourceSecurity

    However, the error message in my log file was something different, as follows:

    Failed to get term store for proxy ‘Managed Metadata Service Application Proxy’. Exception: System.Security.SecurityException: Requested registry access is not allowed.

    • Marked as answer by JasonGuo Sunday, February 16, 2014 1:22 PM
    Thursday, February 6, 2014 8:11 AM
  • Hello Igibason,

    In our case we had the same issue. We ended up looking at the error and found out that the cause was that ECMChangeLog table was empty. One of the properties is ChangeTime.

    This is why the MMS couldn't get a date time value. It is based on the last ChangeTime value, which it didn't have.

    Just to be curious. Was the creation of the Managed Metadata Service Application a clean installation, or did you restore the database from another SharePoint farm.

    Hope this helps a bit


    - Dennis | Netherlands | Blog | Twitter

    Friday, April 25, 2014 2:02 PM
  • Hi Dennis,

    Thanks for the update.  I wonder if that would have worked for my environment.  I will have to try that (if) next time it happens to me.

    Since this was a new install and we didn't really have much data in our MMS it was safe to simple delete and re-create.  This was from a clean install with a new database.

    Hope this helps.

    Regards,

    Ian...

    Wednesday, April 30, 2014 3:45 PM
  • I solved the same problem simply going to 'Manage services on server' and changing 'Database Name' in 'Managed Metadata Service' (without having database permission, so no effective changes was made) and then return to old 'Database Name' (so mantaing all old data)

    • Marked as answer by igibason Friday, September 5, 2014 2:08 PM
    Wednesday, September 3, 2014 3:31 PM
  • Hi Gurca,

    Thanks for the reply.  I actually started having this issue again today.  The first time I had this issue I was simply attempting to open the Managed Metadata Service Application from the Service Applications page.  Again, since it was a test server I simply deleted it and re-created it.

    However, this time I was attempting to configure People Search.  Searching worked however when I clicked on the persons name it would come up with "Sorry, something went wrong. User not found".

    The correlation ID led me to "Failed to get term store for proxy 'Managed Metadata Service Application'. Exception: System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary."

    After following your direction this seemed to help get my Managed Metadata Service back up and running.  However I still cannot get the user site to load with clicking on the People Search results.  But that another issue ;)

    Thanks again

    Ian...

    Friday, September 5, 2014 2:08 PM
  • Both of those accounts were missing for me and once they were added to Read, everything started working.
    Tuesday, April 7, 2015 11:06 PM