none
Returning more than 250 search result hits in Outlook 2013 RRS feed

  • Question

  • Hi,

    I need to search over a very large amount of emails. My searches each have more than 250 hits, and I need to see all results. Currently, Outlook is limiting the number of results to 250.

    I have gone to File > Options > Search, and unticked 'Improve search speed by limiting the number of results shown'.

    I have also amended my registry, per this article: http://www.msoutlook.info/question/669.

    I have restarted my machine, but I am still getting only 250 results.

    Does anybody have further suggestions that I can try?

    Many thanks in advance,

    Keith


    R K Howard

    Friday, February 21, 2014 2:19 PM

Answers

  • Hi,

    Which type of email account are you using? POP, IMAP or Exchange?

    If you are using Exchange or IMAP account, please go to File > Account Settings > Account Settings > highlight your email account and click Change, and then check how you set the 'Mail to keep offline' range. Please adjust the slider bar and set it to All to check the result. You need to restart Outlook to make the change.

    Please let me know the result.

    Best Regards,

    Steve Fan

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here

    Monday, February 24, 2014 3:26 AM
    Moderator
  • Hello Steve,

    We have now switched to off-line mode, enabled ‘Cached Exchange Mode’, and moved the slider to ‘All’.

    This seems to have done it for us.

    Thanks for all your help.

    Kind regards,

    Keith


    R K Howard

    Wednesday, February 26, 2014 4:29 PM

All replies

  • Hi,

    Which type of email account are you using? POP, IMAP or Exchange?

    If you are using Exchange or IMAP account, please go to File > Account Settings > Account Settings > highlight your email account and click Change, and then check how you set the 'Mail to keep offline' range. Please adjust the slider bar and set it to All to check the result. You need to restart Outlook to make the change.

    Please let me know the result.

    Best Regards,

    Steve Fan

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here

    Monday, February 24, 2014 3:26 AM
    Moderator
  • Hi Steve,

    We are not using cached mode; we are using on-line mode, which only seems to let us see 250 search hits.

    Thanks.

    Keith


    R K Howard

    Monday, February 24, 2014 4:45 PM
  • Hi,

    I tested the registry setting, but it didn't work in my environment.

    By default, when we do an instant research in Outlook 2013, it shows the first 30 matches. If we click More below the results, we will get up to 250 results. However, if we clear the 'Improve search speed by limiting the number of results shown' option, Outlook will bypass the limit and show all results matched. See:

    http://office.microsoft.com/en-in/outlook-help/find-a-message-with-instant-search-HA102840067.aspx

    Please try to delete the registry and untick the 'Improve search speed by limiting the number of results shown' option, restart your Outlook and then check if the option will be ticked again.

    We can also try to run a repair of your Office installation to check if it helps. See:

    http://office.microsoft.com/en-in/outlook-help/repair-office-programs-HA010357402.aspx

    Please let me know the result.

    Best Regards,

    Steve Fan

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here

    Wednesday, February 26, 2014 2:41 AM
    Moderator
  • Hello Steve,

    We have now switched to off-line mode, enabled ‘Cached Exchange Mode’, and moved the slider to ‘All’.

    This seems to have done it for us.

    Thanks for all your help.

    Kind regards,

    Keith


    R K Howard

    Wednesday, February 26, 2014 4:29 PM
  • Hi, 

    this is not a solution for our environment. 

    We need to override this 250 object limit BUT also have offline cache limited to 12 Months. We have O365.

    Neither the reg key thing nor the uncheck 'Improve search speed by limiting...' worked.

    So anyway I don't understand why increasing the offline cache is affecting the search results limit of 250. That doesn't make any sense to me.

    So please we need a solution to set the search limit individually. Any Ideas?

    Thanks in advance!

    Thursday, January 11, 2018 3:57 PM