[Troubleshooting] New-MailboxExportRequest Stuck in Queued status RRS feed

  • General discussion

  • Administrators sometimes need to import .pst files into a mailbox using the New-MailboxImportRequest cmdlet. But the process might get stuck in “Queued” status. Here is a typical case for your reference.

    Environment: Exchange 2013 CU12
    Issue: The user ran the New-MailboxImportRequest command through the EMS to try importing the .pst file to the target mailbox. The import status always showed as “Queued”:

    Analysis: Firstly, we suggested running the following command to view detailed information about all import requests and exported the results to reports.txt:

    Get-MailboxImportRequest | Get-MailboxImportRequestStatistics -IncludeReport | fl > c:\reports.txt

    The error message below was returned in the exported report: 
     “Job pickup failure. Invalid Job - Orphaned Couldn't find a valid index entry for request.”

    According to the error, the index for the target mailbox database was abnormal, we recommended the user to try rebuilding the search index using the steps as follows:

    1. Stop the “Microsoft Exchange Search service” as well as the “Microsoft Exchange Host Controller.” on Exchange server.
    2. Delete the GUID folder that ended with .single or move it to another location. This folder is used to store the index. (In Exchange 2013, the default path is C:\Program Files\Microsoft\Exchange Server\V15\Mailbox\<Database Name>)
    3. Restart the “Microsoft Exchange Search service” as well as the “Microsoft Exchange Host Controller”. 
    4. Run the following command to see if the mailbox database index status is "healthy". Note: rebuilding the index may take a while.

    Get-MailboxDatabaseCopyStatus | ft -AutoSize

    In our case, the user executed the import command New-MailboxImportRequest again after successfully rebuilding the index. But it still didn’t work, and the import status was displayed as “Failed”.

    Then the user ran the commands mentioned above to check the status of the import and got the error below. 

    “Error: Cannot save changes made to an item to store. --> MapiExceptionShutoffQuotaExceeded: Unable to save changes. (hr=0x80004005, ec=12 45)”

    Considering that this error usually happens when the size of the imported file exceeds the quota of the target mailbox, we suggested check the relevant settings using the following command line:

    Get-Mailbox “username” | fl –Property MaxReceiveSize, MaxSendSize, ProhibitSendQuota, ProhibitSendReceiveQuota, IssueWarningQuota 

    From the result sent back by the user, obviously, the maximum receive quota set on the target mailbox was less than the actual size of the .pst file to be imported (85 MB).  

    Since root cause was found, we recommended taking the steps below:

    1. Run the following command to change the quota limit for the mailbox: 

    Get-MailBox “username” | Set-MailBox –IssueWarningQuota unlimited -ProhibitSendQuota unlimited -ProhibitSendReceiveQuota unlimited –MaxReceiveSize unlimited –MaxSendSize unlimited 

    2.After changing, waiting a while to take effect, or restarting the Microsoft Exchange Information Store service to take effect immediately. 
    Note: Restarting the Information Store service will dismount and remount all Exchange databases on the server which will interrupt mail flow and accessing to mailbox temporarily.
    After finishing these steps, the user ran the New-MailboxExportRequest command again and successfully imported the .pst files into the mailbox.

    If you are experiencing a similar issue, try the above steps. If the issue persists after all these steps, feel free to post a question with all details to our forum (via clicking “Ask a question” at the top left of this page), we’ll look further into the issue and try our best to help you.

    Rebuild an Index on Exchange 2013 for Specific Databases

    Please click to vote if the post helps you. This can be beneficial to other community members reading the thread.

    • Edited by ForumFAQ Tuesday, January 15, 2019 1:59 AM
    Tuesday, January 15, 2019 1:39 AM