none
The Language of this installation package is not supported by your system

    Question

  • Greetings!

    We are doing "network installation" for Office 2010. We have already done this for English & Slovenian Language pack. We wanted to add another proofing tool (Serbian).

    I have downloaded: sr_office_language_pack_2010_x86_dvd_575374.iso.

    -First I have opened ISO with magicdisc and copy all the content over already prepeared network installation office 2010.

    -I have changed the config.xml in ProPlus.WW folder. I have added the bold text: <AddLanguage Id="en-us" ShellTransform="yes"/> <AddLanguage Id="sl-si" /> <AddLanguage Id="latn-cs" /> <AddLanguage Id="match" />

    After I run the setup.bat:

    "c:\Office 2010-test\install\setup.exe" /config "C:\Office 2010-test\install\ProPlus.WW\config.xml"


    I receive an error: The Language of this installation package is not supported by your system.

    Ok, I googled some pages and saw, that maybe this can be related due to extracting the proofing tool, sth with directory/structure not being extracted the way tha MS wants it.

    I have opened ISO with magicdisc and copy the folder content (no luck, error the same). Then I have used WINRAR for extracting ISO, but the error still remains the same.

     

    Let me mention that for test purpouse I'm doing Upgrade of Office 2007 to Office 2010, cause this is the most real scenario in our company. I have also googled a page where it says I must Uncomment this: <LIS CACHEACTION="CacheOnly" /> but that also did not do any good.

     

    Any sugestions please?

    I think my question is very similiar what Christopher Woods CustomMade is asking as the last post on this thread: http://social.technet.microsoft.com/Forums/en-US/officesetupdeploy/thread/97580ded-379a-4a31-83e6-05604d76053f. What would be the right procedure to extract ISO...etc


    bostjanc

    Wednesday, June 22, 2011 8:20 AM

All replies

  • Hi Bostjanc,

    the language code for serbian is "sr-sp-latn". From my point of view you should change the line

    <AddLanguage Id="latn-cs" />

    to

    <AddLanguage Id="sr-sp-latn" />

    Then it should work. Please test and give feedback.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, June 23, 2011 8:43 PM
  • Greetings!

     

    Unfortunatelly changing config file with your suggestion did not solve the problem. I doubt it must be sr-sp-latn because folder names are:

    Access.sr-latn-cs

    Excel.sr-latn-cs

    Groove.sr-latn-cs

    InfoPath.sr-latn-cs

    etc...


    bostjanc
    Friday, June 24, 2011 8:16 AM
  • Hi,

     

    thank you for your feedback. The langague code I provided is from the list of "Language identifiers and OptionState Id values in Office 2010" at http://technet.microsoft.com/en-us/library/cc179219.aspx and should be the correct one. Maybe you could add the following line to enable logging:

    <Logging Type="Verbose" Path=""c:\Office 2010-test\" Template="Office_2010_ProfessionalPlus_Install(*).txt" />

    After starting the setup you will find the logfile in "c:\Office 2010-test\. At the top of the log (among the first thirty lines) setup will document what it parsed and which languages were identified. If you are not familiar with the logging of office 2010 you can also post the logfile here.

     

    But I have another question: In your first post you stated "we want to add proffing tools (serbian)". The <addlanguage>-statement will add a whole lanugage pack including a localized display language. If you want to add proofing tools only (without display language), you should refer to http://technet.microsoft.com/en-us/library/ee942200.aspx and add an Optionstate-statement to you config.xml like the following one:

    <OptionState Id="ProofingTools_2074" State="Local" Children="force"/>

    and remove the addlanguage-statement.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, June 24, 2011 12:44 PM
  • Greetings!

     

    I will try this tomorrow at work and let you know. Thank you for your answers.

     


    bostjanc
    Monday, June 27, 2011 7:53 PM
  • I have added the recommended command (look the bold text). The installation went thru... but in the end there is no proofing tool instaled.

    Only Slovenian <default>  and English US if I look under options - language on client.

    https://skydrive.live.com/redir.aspx?cid=f2036d479ec1756d&page=play&resid=F2036D479EC1756D!138

     

     

     

    <Configuration Product="ProPlus">

     <!-- <Display Level="full" CompletionNotice="yes" SuppressModal="no" AcceptEula="no" /> -->
     
     <!-- <Logging Type="standard" Path="%temp%" Template="Microsoft Office Professional Plus Setup(*).txt" /> -->

     <!-- <USERNAME Value="Customer" /> -->
     
     <!-- <COMPANYNAME Value="MyCompany" /> -->
     
     <!-- <INSTALLLOCATION Value="%programfiles%\Microsoft Office" /> -->
     
     <!-- <LIS CACHEACTION="CacheOnly" /> -->
     
     <!-- <LIS SOURCELIST="\\server1\share\Office;\\server2\share\Office" /> -->
     
     <!-- <DistributionPoint Location="\\server\share\Office" /> -->
     
     <!-- <OptionState Id="OptionID" State="absent" Children="force" /> -->
     
     <!-- <Setting Id="SETUP_REBOOT" Value="IfNeeded" /> -->
     
     <!-- <Command Path="%windir%\system32\msiexec.exe" Args="/i \\server\share\my.msi" QuietArg="/q" ChainPosition="after" Execute="install" /> -->

     <AddLanguage Id="en-us" ShellTransform="yes"/> <AddLanguage Id="sl-si" />

     <OptionState Id="ProofingTools_2074" State="Local" Children="force"/>

    </Configuration>

     


    bostjanc
    Tuesday, June 28, 2011 11:57 AM
  • anyone ?
    bostjanc
    Thursday, June 30, 2011 1:24 PM
  • ... :(
    bostjanc
    Monday, July 04, 2011 10:51 AM