none
Update from Exchange 2013 SP1 to CU8 error RRS feed

  • Question

  • hi,

    i've got problem when update to cu8.

    the file 'c:\program files\microsoft\exchange server\v15\transportroles\agents\hygiene\asdat.msi' is not a valid installation package for the product microsoft exchange 2007 standard anti-spam filter updates. try to find the installation package 'asdat.msi' in a folder from which you can install microsoft exchange 2007 standard anti-spam filter updates.

    please help me..

    Friday, April 10, 2015 3:25 PM

Answers

  • After many hours of searching it worked by running the commands

    msiexec /i "C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\agents\Hygiene\ASDat.MSI" REINSTALLMODE=vomus

    msiexec /i "C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\agents\Hygiene\ASEntIRS.MSI" REINSTALLMODE=vomus

    msiexec /i "C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\agents\Hygiene\ASEntSig.MSI" REINSTALLMODE=vomus

    (The other 2 subsequently failed)

    Tuesday, April 28, 2015 1:09 AM

All replies

  • hi,

    i've got problem when update to cu8.

    the file 'c:\program files\microsoft\exchange server\v15\transportroles\agents\hygiene\asdat.msi' is not a valid installation package for the product microsoft exchange 2007 standard anti-spam filter updates. try to find the installation package 'asdat.msi' in a folder from which you can install microsoft exchange 2007 standard anti-spam filter updates.

    please help me..

         The following error was generated when "$error.Clear();
              uninstall-MsiPackage -ProductCode '{C3F10D8C-BD70-4516-B2B4-BF69019807
    41}' -LogFile ($RoleSetupLoggingPath + "\UninstallASDat.msilog")
            " was run: "Microsoft.Exchange.Configuration.Tasks.TaskException: Couldn
    't remove product with code c3f10d8c-bd70-4516-b2b4-bf6901980741. The installati
    on source for this product is not available. Verify that the source exists and t
    hat you can access it. Error code is 1612. ---> System.ComponentModel.Win32Excep
    tion: The installation source for this product is not available. Verify that the
     source exists and that you can access it
       --- End of inner exception stack trace ---
       at Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception exception
    , ErrorCategory category, Object target, Boolean reThrow, String helpUrl)
       at Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception exception
    , ErrorCategory category, Object target)
       at Microsoft.Exchange.Management.Deployment.UninstallMsi.RemoveProductCode(Gu
    id productCode)
       at Microsoft.Exchange.Management.Deployment.UninstallMsi.InternalProcessRecor
    d()
       at Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b()
       at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String fun
    cName, Action func, Boolean terminatePipelineIfFailed)".


    The Exchange Server setup operation didn't complete. More details can be found
    in ExchangeSetup.log located in the <SystemDrive>:\ExchangeSetupLogs folder.
    Friday, April 10, 2015 3:27 PM
  • After many hours of searching it worked by running the commands

    msiexec /i "C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\agents\Hygiene\ASDat.MSI" REINSTALLMODE=vomus

    msiexec /i "C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\agents\Hygiene\ASEntIRS.MSI" REINSTALLMODE=vomus

    msiexec /i "C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\agents\Hygiene\ASEntSig.MSI" REINSTALLMODE=vomus

    (The other 2 subsequently failed)

    Tuesday, April 28, 2015 1:09 AM
  • Just wanted to say thank you for this.  Saved me.

    Rich

    Friday, March 11, 2016 2:57 AM
  • Hello

    Thank you for the fix.  It also works with the same error when installing Exchange 2016.

    Lee

    Friday, April 1, 2016 10:03 AM
  • Thank you very much, perikles. Difficult to find this solution but essential to recover and uninstall an Exchange 2016/CU1 server. The recover process always hangs at Mailbox Role: Transport Service 75 %. It is obviously necessary to re-cache the local Exchange 2007 anti-spam filter updates with the v parameter of Msiexec.exe reinstallmode.

    Marcel

    Wednesday, June 29, 2016 6:16 PM
  • Thanks very much perikles

    Saved my arse too

    Thursday, September 29, 2016 1:02 PM
  • After many hours of searching it worked by running the commands

    msiexec /i "C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\agents\Hygiene\ASDat.MSI" REINSTALLMODE=vomus

    msiexec /i "C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\agents\Hygiene\ASEntIRS.MSI" REINSTALLMODE=vomus

    msiexec /i "C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\agents\Hygiene\ASEntSig.MSI" REINSTALLMODE=vomus

    (The other 2 subsequently failed)

    Thank you, it worked perfect for us! It is fixed now! Thank you once again! It took me hours.
    Monday, March 20, 2017 6:57 PM
  • Thank you very much! Worked for me.. It was an Exchange2013CU21 Install
    Wednesday, August 8, 2018 9:27 PM
  • thank you.. worked perfectly. this was exch2013 CU22


    NS

    Sunday, June 2, 2019 1:07 AM
  • I got the error while upgrading from Exchange 2016 CU1 to CU13. I ran same command and it fixed the issue. Thanks a lot.
    Friday, July 19, 2019 5:32 AM