none
Outlook 2010 asks for me username password credentials every time I restart the computer

    Question

  • I run Windows 7/Outlook 2010 on a Boot Camp MacBook.  My company recently switched email hosting and since the switch, Outlook will ask me for credentials every time I restart, and sometimes every time I open the program.  

    I've tried a number of fixes, including navigating to Control Panel > Mail (32-bit) > E-mail Accounts > Change selected account > More Settings > Security tab, and then toggling the "Always prompt for logon credentials" on and off, as well as trying different Logon network security options.

    No luck so far.  Any suggestions are appreciated.

    Friday, December 31, 2010 6:19 PM

Answers

  • I modified Jennifer Zhan's registry edit suggestion above about a week ago, and so far the problem (Outlook constantly causing a box to pop up asking me about my Username and Password) is gone.  I will repaste her suggestion below for my own reference.

    I have Office 2010 running on a computer with Windows 7 Professional, 64 bit version. I tried just about every other fix I could find online without success.

    I also found that the folder Jennifer listed does not exist.  What I finally ended up doing was following the procedure she outlined exactly except for making the edit in a folder that I found did exist on my machine:  HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Security  (note that there is no "Policies" in this pathway, unlike in the path Jennifer lists).

    I hope this works for others.  Given all the really useful answers I have Googled over the past few years regarding all kinds of esoteric problems with household appliances, computers, cars, etc, I have quite a debt to repay.

     

     

    1.       Click Start, click Run, type regedit, and then click OK.

    2.       Locate and then right-click the following registry subkey:  (the subkey originally listed here was not present on my computer; this one worked for me: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Security)



    3.       Point to New, and then click DWORD Value.

    4.       Type PromptForCredentials as the name of the new registry entry, and then press ENTER.

    5.       Double-click the PromptForCredentials registry entry, and then type one of the following values in the Value data dialog box:

    00000000

    Note In this case, cached credentials will be used.

    00000001

    Note In this case, users cannot use cached credentials. Users are always prompt to provide a user name and password.

    6.       Click OK.

     

     

     


     

    • Proposed as answer by TPHS Saturday, January 08, 2011 7:57 AM
    • Marked as answer by Jennifer ZhanModerator Thursday, January 13, 2011 2:56 AM
    Saturday, January 08, 2011 7:55 AM

All replies

  • Hi,

    Since you are using Windows 7, please try following method:

    Open up windows explorer and then paste the following text into the address bar, which should bring you to a folder with a single folder inside with a really long name.

    %userprofile%\AppData\Roaming\Microsoft\Protect

    What you’ll need to do is just rename that folder to something else then re-open Outlook and type in your password.

     

    If it not works, you can try to add this registry entry.

    1.       Click Start, click Run, type regedit, and then click OK.

    2.       Locate and then right-click the following registry subkey:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\Security

    3.       Point to New, and then click DWORD Value.

    4.       Type PromptForCredentials as the name of the new registry entry, and then press ENTER.

    5.       Double-click the PromptForCredentials registry entry, and then type one of the following values in the Value data dialog box:

    00000000

    Note In this case, cached credentials will be used.

    00000001

    Note In this case, users cannot use cached credentials. Users are always prompt to provide a user name and password.

    6.       Click OK.

     

    In addition, you can try suggestions provided here: http://support.microsoft.com/kb/956531

     

    Hope that helps.

     

    Monday, January 03, 2011 6:10 AM
    Moderator
  • Jennifer, thank you for your reply.  I attempted to complete the fix via both methods you suggested.  I still encounter the error in Outlook after logging out and logging back in.  I noticed that the file path: %userprofile%\AppData\Roaming\Microsoft\Protect shows a new folder with a long file name after I rename the folder.

     

    I.E. I changed the folder from S13-5768...etc to "outlookpassword".  After logging out and logging back in, the file path showed two folders: "outlookpassword" and a new folder with a long alphanumeric name.

     

    I'm hesitant to use the hotfix suggestion, but if there is not further patch here then I will try that next.


    Tuesday, January 04, 2011 3:35 PM
  • there's no folder named Office under this subkey. 

    HKEY_CURRENT_USER\Software\Policies\Microsoft

    Am I supposed to create one for office\14.0\outlook\security?

     

    Thursday, January 06, 2011 2:26 PM
  • I noticed that as well...doesn't seem like this is a very helpful answer.  Probably should be noted as a bug.
    Friday, January 07, 2011 3:37 PM
  • I modified Jennifer Zhan's registry edit suggestion above about a week ago, and so far the problem (Outlook constantly causing a box to pop up asking me about my Username and Password) is gone.  I will repaste her suggestion below for my own reference.

    I have Office 2010 running on a computer with Windows 7 Professional, 64 bit version. I tried just about every other fix I could find online without success.

    I also found that the folder Jennifer listed does not exist.  What I finally ended up doing was following the procedure she outlined exactly except for making the edit in a folder that I found did exist on my machine:  HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Security  (note that there is no "Policies" in this pathway, unlike in the path Jennifer lists).

    I hope this works for others.  Given all the really useful answers I have Googled over the past few years regarding all kinds of esoteric problems with household appliances, computers, cars, etc, I have quite a debt to repay.

     

     

    1.       Click Start, click Run, type regedit, and then click OK.

    2.       Locate and then right-click the following registry subkey:  (the subkey originally listed here was not present on my computer; this one worked for me: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Security)



    3.       Point to New, and then click DWORD Value.

    4.       Type PromptForCredentials as the name of the new registry entry, and then press ENTER.

    5.       Double-click the PromptForCredentials registry entry, and then type one of the following values in the Value data dialog box:

    00000000

    Note In this case, cached credentials will be used.

    00000001

    Note In this case, users cannot use cached credentials. Users are always prompt to provide a user name and password.

    6.       Click OK.

     

     

     


     

    • Proposed as answer by TPHS Saturday, January 08, 2011 7:57 AM
    • Marked as answer by Jennifer ZhanModerator Thursday, January 13, 2011 2:56 AM
    Saturday, January 08, 2011 7:55 AM
  • I had this same issues, the user was getting a prompt for his credentials everytime he started Outlook. I fixed it by giving the user administrator rights, started Outlook (no prompt) and removed the administrator rights. Now it's fixed.
    Tuesday, March 15, 2011 12:23 PM
  • thanks, this helped. it still gives me a yes/no authorization, but no longer asks for the login and password.

    we're having some AD issues as well - 2 servers claim to have all 5 FSMO roles, and one of them refuses to gracefully depromote itself from being a domain controller. so we may be facing some other issues related to AD and DNS that I haven't fully sussed out yet.

    Monday, March 28, 2011 8:37 PM
  • Dear,

    I tried all things to solve this issue, but I cant.. can you please tell me where to give user administrator rights. please send me the steps

    Regards

    Ashfak

    Wednesday, October 02, 2013 8:08 AM
  • One other fix that can sometimes solve this problem is starting Outlook with the /ResetNavPane switch.

    -Peter

    Wednesday, October 02, 2013 6:22 PM