locked
Outlook 2007 SP1 + Exchange Server 2007 SP1 = Free/Busy status Error + OOF message Error RRS feed

  • Question

  •  

    Hi All,

     

    I'm just wonderingif any of you have the workaround for those issue ?

     

    I'm now running Outlook 2007 SP1 + Exchange Server 2007 SP1 and then when i set my calendar like the following:

     

    Anonymous and Default -- > Free/Busy Subject, Location the calendar cannot be opened then i got the Error message:

     

     

    The Set of Folders cannot be opened

    This error usually occurs if the OST or PST file you are using is:
       1. Unavailable.
       2. Protected with file permissions.
       3. On a share on a server and the network is down.
       4. Corrupt.
    To correct this problem, store the OST or PST file on the local computer.
    You may also want to run the scanost.exe and scanpst.exe tools to verify file integrity.

     

    any idea of how could this be fixed ?

     

    the idea is to get the scheduling assistant to be working as in Outlook Web Access (all seems to be good from OWA).

    and also Out of office message also not working from Outlook 2007

    with the error message:

     

    Your Out of Office settings cannot be displayed, because the server is currently unavailable. Try again later.

     

    Thanks.

    Thursday, July 10, 2008 9:22 AM

Answers

All replies

  •  

     

     

     

    If a person or distribution list has been granted at least the "Free/Busy time, subject, location" privelege (a different set of permissions is available when sharing a calendar from an Outlook 2003 client versus an Outlook 2007 client) for another user's calendar, the user would expect to see details for the shared calendar when viewing the calendar in a group view or while using the Scheduling Assistant.

     

    However, if the user is logged into a PC with a child domain account and is using Outlook 2007, occupied time slots are blocked out but details do not appear.

     

    but that is not the case in OWA, everything work fine in OWA.

     

    any suggestion please ?

    Friday, July 11, 2008 6:29 AM
  • Clarify: In OL, calendar can’t open with error after free/busy set to “Free/Busy Subject, Location”; OOF can’t also open with error

    Collect info:

    1.       Is there any error info in the server and client’s application log?

    2.       Whether it is a product or testing environment?

    3.       Do you set proxy server on client PC’s IE?

    4.       Is there any other abnormality on the OL?

    5.       Is the user in the domain?

    Troubleshooting for OOF:

    1.       Please exclude OL’s OST from anti-virus software’s scan. It will cause same symptom

    2.       Run “Test E-mail AutoConfiguration” and post the screenshot of Result, Log and XML tab

    a.       Right-click the outlook icon in the tray

    b.      Choose “Test E-mail AutoConfiguration” and fill in the username and password

    c.       Only check “Use AutoDiscover” and test

    d.      See if you get any error, check the links

    3.       If you see error 80072f0c in “Test E-mail AutoConfiguration”

    a.       Go to CAS role’s IIS, expand to “AutoDiscover” VD and right-click it, choose “Properties”

    b.      In “Directory Security”->click “Edit” button in “Secure Communications” zone-> set client certificates as "ignore client certificates" and reset the IIS

    c.       Run “Test E-mail AutoConfiguration” and check the error again

    4.       Try to browse autodiscovery virtual directory, see if you can get expected error 600 in the xml page

    https://servername/Autodiscover/Autodiscover.xml

    5.       Go to EMS, check AutodiscoverServiceInternal URL

    a.       Run EMS

    b.      Get-ClientAccessServer -Identity CAS_Server_Name

    c.       See if it’s https://FQDN/Autodiscover/Autodiscover.xml

    6.       If Autodiscover service works well, please try to check and change the following configuration

    a.       Go to CAS role’s IIS, expand to “Default Web Site” and right-click it, choose “Properties”

    b.      In the “Web Site” tab, check "Enable HTTP Keep-Alives"

    c.       Stop and start the “Default Web Site” or enter IISRESET /NOFORCE in a command prompt

    d.      Try to set OOF message again. If it still cannot set, go to step 7

    7.       Collect Outlook troubleshooting log

    a.       “Tools” menu->click “Options”->click “Other” tab->click “Advanced Options”

    b.      Select Enable logging (troubleshooting), and then click OK

    c.       Restart OL, and try to set OOF message

    d.      Then go to C:\Documents and Settings\username\Local Settings\Temp\Opmlog.log

    e.      Check if has any error info

    Important: It is very important that you turn off logging after you complete your troubleshooting. If you do not turn off logging, the log files continue to increase in size

    Monday, July 14, 2008 9:54 AM
  • Well, thanks for your reply James,

     

    I haven't tried it yet, but I've applied these HOTFIXes below:

     

    office-kb954574-fullfile-x86-glb.exe

    office-kb951701-fullfile-x86-glb.exe

     

    but still the Error remains.

     

     

    I'm pretty sure this has got to do with Autodiscover problem.

     

    do you know how to add or edit Autodiscover entry inside AD database please ?

     

     

    Thanks.

     

     

    Tuesday, July 15, 2008 8:00 AM
  • These hotfixs you tried repair the issues which related to “Out Of Office” (OOF) is:

    1.       User account that you use to log on to the computer differs from the user account that you use to log on to OL2K7

    2.       OL2K7 cannot connect to the Autodiscover service in E2k7 until approximately 27 hours after the upgrade process is complete

    None of descriptions above happened in your environment, right?

    =================

    So you ensure the problem was caused by “AutoDiscover” malfunction, right?

    In that way, let’s confirm it by using step 2, 4 in my last post, if there’s any problem with “AutoDiscover”, we shall find error codes which can give us further info for analysis.

    Meanwhile, you can use command below which also test your “AutoDiscover” service to determine whether the user's free/busy information is being returned correctly from Client Access (CAS) server role to client:

    a.       On the Exchange CAS server role, go to EMS

    b.      Enter cmdlet: test-OutlookWebServices -identity:AffectedUser’sSMTPaddress | fl

    c.       Please post it if you get any error info

    Notes: all of these testing methods would let us better understanding the root cause and closer to the resolution

    QUOTE: “add or edit Autodiscover entry inside AD database

    You can check “AutodiscoverServiceInternal URL” in AD database by using ADSI Editor, that’s also the key point you shall check [ADSI Editor includes in Windows support tool, it will installed in C:\Program Files\Support Tools]

    a.       Run ADSI Editor [Start->Run->adsiedit.msc]

    b.      Expand “Configuration”->”CN=Configuration,DC=domain,DC=com”->”CN=Services”->”CN=Microsoft Exchange”->”CN=Orgname”->”CN=Administrative Groups”->”CN=Exchange Administrative Group”->”CN=Servers”->”CN=CASRoleName”->”CN=Protocols”->”CN=Autodiscover”->right-click ”CN=CASRoleName” and choose “Properties”->select “servicebindinginformation” attribute and click “Edit” button

    c.       The attribute’s content shall be like: “https://FQDN/Autodiscover/Autodiscover.xml”

     

    Tuesday, July 15, 2008 11:03 AM
  •  

    Thanks for your response James,

     

    here's the test result of

    Test-OutlookWebServices | fl

    ------------------------------------------------------------------------------------------------------------------------------------------------------------

    Id      : 1003
    Type    : Information
    Message : About to test AutoDiscover with the e-mail address user@<FQDN>.

     

    Id      : 1007
    Type    : Information
    Message : Testing server MCLAREN.itree.com.au with the published name https://<FQDN>/EWS/Exchange.asmx & .

     

    Id      : 1019
    Type    : Information
    Message : Found a valid AutoDiscover service connection point. The AutoDiscover URL on this object is https://<FQDN>/autodiscover/autodiscover.xml.

     

    Id      : 1013
    Type    : Error
    Message : When contacting https://<FQDN>/autodiscover/autodiscover.xml received the error The server committed a protocol violation. Section=ResponseHeader Detail=CR must be followed by LF

     

    Id      : 1006
    Type    : Error
    Message : The Autodiscover service could not be contacted.

    ------------------------------------------------------------------------------------------------------------------------------------------------------------

    actually i didn't specifically stated the mailbox username because it is affecting ALL of the user in my domain.

     

    anyway, I'm trying to follow your suggestion in your last few lines of your email because it does make sense and hopefully i can get it to work ASAP.

     

    Cheers,

    Wednesday, July 16, 2008 3:02 AM
  •  James Luo - MSFT wrote:

    QUOTE: “add or edit Autodiscover entry inside AD database

    You can check “AutodiscoverServiceInternal URL” in AD database by using ADSI Editor, that’s also the key point you shall check [ADSI Editor includes in Windows support tool, it will installed in C:\Program Files\Support Tools]

    a.       Run ADSI Editor [Start->Run->adsiedit.msc]

    b.      Expand “Configuration”->”CN=Configuration,DC=domain,DC=com”->”CN=Services”->”CN=Microsoft Exchange”->”CN=Orgname”->”CN=Administrative Groups”->”CN=Exchange Administrative Group”->”CN=Servers”->”CN=CASRoleName”->”CN=Protocols”->”CN=Autodiscover”->right-click ”CN=CASRoleName” and choose “Properties”->select “servicebindinginformation” attribute and click “Edit” button

    c.       The attribute’s content shall be like: “https://FQDN/Autodiscover/Autodiscover.xml”

     

    here's the result of that steps above:

     

    https://<CASservername.domain.com.au>/autodiscover/autodiscover.xml

     

    and then when i open it up from Internet Explorer, it goes like this:

     

      <?xml version="1.0" encoding="utf-8" ?>
    - <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
    - <Response>
    - <Error Time="13:01:34.1250000" Id="1433479874">
      <ErrorCode>600</ErrorCode>
      <Message>Invalid Request</Message>
      <DebugData />
      </Error>
      </Response>
      </Autodiscover>
     
    is that what I'm supposed to be getting ?
     
    thanks for your help in this matter James.
    Wednesday, July 16, 2008 3:08 AM
  • Hi, Albert, for this AutoDiscover issue, I saw you had tried many different methods for troubleshooting in these links:

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3310929&SiteID=17

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3526457&SiteID=17&mode=1

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3383032&SiteID=17

     

    We need more diagnosing logs and performance files to locate the root cause. Unfortunately, it is beyond what we can do in the forum as the nature of forum support. I'd like to recommend you to contact Microsoft Customer Support Service (CSS) for assistance so that this problem can be resolved efficiently. To obtain the phone numbers for specific technology request please take a look at the web site listed below:

     

    <http://support.microsoft.com/default.aspx?scid=fh;EN-US;PHONENUMBERS>

     

    If you are outside the US please see <http://support.microsoft.com> for regional support phone numbers.

    Your understanding is greatly appreciated and I hope the issue can be fixed soon!

     

    Friday, July 18, 2008 7:48 AM
  •  

    James,

     

    i read somewhere in this forum, mentioning that the root cause of this problem was the

     

    .NET Fx 3.5 updates ?

     

    well,

     

    I'll try to uninstall that .NET 3.5 on my Exchange Server 2007 sometimes during the weekend and perform a restart and see how it goes.

     

    Wednesday, August 27, 2008 7:34 AM
  • Yes, I saw the thread. Thanks for update it, waiting for results

    Wednesday, August 27, 2008 7:48 AM
  • Well,

     

    after I reinstall the .NET framework 3.5 from my Exchange Server 2007, the error is still there,

     

    do you have any idea like re-creating the Autodiscovery virtual dir. in IIS? if yes then could you share the cmdlets here please ?

     

    thanks.

     

     

     

    here's the detailed output from Outlook log files.

     

    Thread Tick Count Date/Time Description
    5012 29124375 07/11/08 16:59:19 Attempting URL https://servername.domain.com/autodiscover/autodiscover.xml found through SCP
    5012 29124375 07/11/08 16:59:19 Autodiscover to https://servername.domain.com/autodiscover/autodiscover.xml starting
    5012 29124390 07/11/08 16:59:19 Autodiscover to https://servername.domain.com/autodiscover/autodiscover.xml FAILED (0x80072F0C)
    5012 29124390 07/11/08 16:59:19 Autodiscover to https://domain.com/autodiscover/autodiscover.xml starting
    5012 29124421 07/11/08 16:59:19 Autodiscover request completed with http status code 500
    5012 29124453 07/11/08 16:59:19 Autodiscover request completed with http status code 500
    5012 29124453 07/11/08 16:59:19 Autodiscover to https://domain.com/autodiscover/autodiscover.xml FAILED (0x80004005)
    5012 29124468 07/11/08 16:59:19 Autodiscover to https://autodiscover.domain.com/autodiscover/autodiscover.xml starting
    5012 29124468 07/11/08 16:59:19 Autodiscover to https://autodiscover.domain.com/autodiscover/autodiscover.xml FAILED (0x800C8203)
    5012 29124468 07/11/08 16:59:19 Local autodiscover for domain.com starting
    5012 29124468 07/11/08 16:59:19 Local autodiscover for domain.com FAILED (0x8004010F)
    5012 29124468 07/11/08 16:59:19 Redirect check to http://autodiscover.domain.com/autodiscover/autodiscover.xml starting
    5012 29124468 07/11/08 16:59:19 Redirect check to http://autodiscover.domain.com/autodiscover/autodiscover.xml FAILED (0x80072EE7)
    5012 29124468 07/11/08 16:59:19 Srv Record lookup for domain.com starting
    5012 29124468 07/11/08 16:59:19 Autodiscover URL redirection to https://servername.domain.com/autodiscover/autodiscover.xml
    5012 29124468 07/11/08 16:59:19 Autodiscover to https://servername.domain.com/autodiscover/autodiscover.xml starting
    5012 29124484 07/11/08 16:59:19 Autodiscover to https://servername.domain.com/autodiscover/autodiscover.xml FAILED (0x80072F0C)
    5012 29124500 07/11/08 16:59:19 Srv Record lookup for domain.com FAILED (0x80072F0C)
    Saturday, August 30, 2008 6:26 AM
  • How to recreate Autodiscover VirtualDirectory

    1.       Remove-AutodiscoverVirtualDirectory "cas-servername\Autodiscover (default web site)"

    2.       New-AutodiscoverVirtualDirectory -WebsiteName "Default Web Site" -WindowsAuthentication $true -BasicAuthentication $true

    3.       Restart IISAdmin service

     

    Monday, September 1, 2008 1:36 AM
  • Hi Albert,

    did you mange to solve the problem  - I have an indentical situation

     

    Thanks

    Saturday, September 13, 2008 11:27 AM
  • Dear James

    I have a similar problem to this.

    OOF not working

    Test Emal Autoconfiguration fails (SCP is found but then returns status code 500)

    test-outlookwebservices fails

     

    I am trying to browse the autodiscover.xml but I get the following error:

    Could not load file or assembly 'Microsoft.Exchange.Diagnostics, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified

     

    I also notice that everytime I do test-outlookwebservices I get logged the following error in the appliucation log:

     

    Event Type: Warning
    Event Source: ASP.NET 2.0.50727.0
    Event Category: Web Event
    Event ID: 1309
    Date:  9/13/2008
    Time:  7:27:59 PM
    User:  N/A
    Computer: MAILSERVER
    Description:
    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 9/13/2008 7:27:59 PM
    Event time (UTC): 9/13/2008 5:27:59 PM
    Event ID: 6cefc12169bc45378c28f17a723f314b
    Event sequence: 22
    Event occurrence: 21
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/1/ROOT/Autodiscover-1-128657911333079644
        Trust level: Full
        Application Virtual Path: /Autodiscover
        Application Path: C:\Program Files\Microsoft\Exchange Server\ClientAccess\Autodiscover\
        Machine name: MAILSERVER
     
    Process information:
        Process ID: 5116
        Process name: w3wp.exe
        Account name: NT AUTHORITY\SYSTEM
     
    Exception information:
        Exception type: FileNotFoundException
        Exception message: Could not load file or assembly 'Microsoft.Exchange.Diagnostics, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
     
    Request information:
        Request URL: https://mail.bdomalta.com.mt:443/autodiscover/autodiscover.xml
        Request path: /autodiscover/autodiscover.xml
        User host address: 192.168.2.252
        User: 
        Is authenticated: False
        Authentication Type: 
        Thread account name: NT AUTHORITY\SYSTEM
     
    Thread information:
        Thread ID: 7
        Thread account name: NT AUTHORITY\SYSTEM
        Is impersonating: False
        Stack trace:    at Microsoft.Exchange.Autodiscover.Global.Application_BeginRequest(Object sender, EventArgs e)
       at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
     
     
    Custom event details:

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Saturday, September 13, 2008 6:07 PM
  • I manage 80 Clients and only 1 Client running Outlook 2007 is getting the SSL pop-up for autodiscover.domain.com.

     

    I have set the Internal and External URLs for Autodiscover in Exchange to point to https://mail.domain.com/Autodiscover/Autodiscover.xml I have ran the ADSI Editior as decribed above and it is infact pointing to https://mail.domain.com/Autodiscover/Autodiscover.xml

     

    Is their someway to change the Outlook 2007 Client to not look for Autodiscover?

     

    I'm trying to avoid re-doing the SSL Certificate to allow for multiple hosts.

     

    When I deleted that users profile in outlook and re-created it the problem went away for about a week, but now it has returned.

     

    Thx

    Friday, September 19, 2008 6:21 PM

  • To All,

    you're not alone here :-|

    I've executed the script to set all of the virtual dir. URI to no avail.


    see the script result below:

    Get-AutodiscoverVirtualDirectory | fl Identity, InternalUrl, ExternalUrl
    Identity    : ExServerName\Autodiscover (Default Web Site)
    InternalUrl : https://ExServerName.domain.com/autodiscover/autodiscover.xml
    ExternalUrl : https://ExServerName.domain.com/autodiscover/autodiscover.xml

    Get-WebServicesVirtualDirectory | fl Identity, InternalNLBBypassUrl, InternalUrl, ExternalUrl
    Identity             : ExServerName\EWS (Default Web Site)
    InternalNLBBypassUrl : https://ExServerName.domain.com/ews/exchange.asmx
    InternalUrl          : https://ExServerName.domain.com/EWS/Exchange.asmx
    ExternalUrl          : https://ExServerName.domain.com/EWS/Exchange.asmx

    Get-OabVirtualDirectory | fl Identity, InternalUrl, ExternalUrl
    Identity    : ExServerName\OAB (Default Web Site)
    InternalUrl : http://ExServerName.domain.com/OAB
    ExternalUrl : http://ExServerName.domain.com/OAB

    Get-ActiveSyncVirtualDirectory | fl Identity, InternalUrl, ExternalUrl
    Identity    : ExServerName\Microsoft-Server-ActiveSync (Default Web Site)
    InternalUrl : https://ExServerName.domain.com/Microsoft-Server-ActiveSync
    ExternalUrl : https://ExServerName.domain.com/Microsoft-Server-ActiveSync

    Get-UMVirtualDirectory | fl Identity, InternalUrl, ExternalUrl
    Identity    : ExServerName\UnifiedMessaging (Default Web Site)
    InternalUrl : https://ExServerName.domain.com/UnifiedMessaging/Service.asmx
    ExternalUrl : https://ExServerName.domain.com/UnifiedMessaging/Service.asmx


    hope that anyone could solve this problem one day, it'd be much much appreciated.
    Friday, September 26, 2008 2:16 AM


  • updated Thread that i created:

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=4025905&SiteID=17

    and also the workaround in registry in case you need to use the Free/Busy feature:

    --"under this registry folder a value called: Read URL : this value is empty put this URL and restart your PC."
    [HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Options\Calendar\Internet Free/Busy]

    Value Type: String
    Value Name: Read URL
    Value: https://servername.domain.com/ews/services.wsdl

    "--------------------------------------------------------------------"
    HKEY_CURRENT_USER
    \Software\Microsoft\Office\12.0\Outlook\Options\Calendar
    Value Type: DWORD
    Value Name: UseLegacyFB
    Value: 1
    any other idea and input is greatly appreciated.
    Tuesday, October 21, 2008 6:58 AM
  •  Johnapul_nye wrote:

    I manage 80 Clients and only 1 Client running Outlook 2007 is getting the SSL pop-up for autodiscover.domain.com.

     

    I have set the Internal and External URLs for Autodiscover in Exchange to point to https://mail.domain.com/Autodiscover/Autodiscover.xml I have ran the ADSI Editior as decribed above and it is infact pointing to https://mail.domain.com/Autodiscover/Autodiscover.xml

     

    Is their someway to change the Outlook 2007 Client to not look for Autodiscover?

     

    I'm trying to avoid re-doing the SSL Certificate to allow for multiple hosts.

     

    When I deleted that users profile in outlook and re-created it the problem went away for about a week, but now it has returned.

     

    Thx

     

    Do a Test Email Auto Configuraton on Outlook client and posts the results here. Outlook

    2007 with sp1 will always look for Autodiscover as it has been hard coded.

     

    Also look at http://support.microsoft.com/kb/940726; if it helps your situation.

     

    Regards

    Jedi_0007

    Tuesday, December 2, 2008 2:26 AM
  • Wow this fourm worked out great I was receiving the following error when Testing the autodiscover in outlook 2007,

    Autodiscover to https://mail.mydomain.com/autodiscover/autodiscover.xml FAILED (0x80072F0C)

    I followed the troubleshooting guid provided by James to "ignore client certificates" and it fixed my autodiscover :)
    Tuesday, June 23, 2009 1:25 PM
  • Same Issue.


    I've installed Hotfix on KB 952883 (some ASMX issue)

     as told on KB 958934 article http://support.microsoft.com/kb/958934

    The problem was NOT solved


    Thak's all
    Tuesday, October 6, 2009 7:50 PM
  • I had the same issue oof outlook 2007 doesn'twork.

    after i uninstall .net 3.5sp1

    kb948609 and kb948610

    I reboot mine exchange server 2007.

    outlook 2007 clients works well with OOF.

    kind regards.

    Robert Jhinkoerai

    Monday, July 5, 2010 4:12 PM
  • For me this works!

    Cause:
    Client certificate option selected in IIS for all virtual directory

    Resolution
    Although client certificates and SSL server certificates both use certificates, they are not directly related to each other.
    SSL server certificates provide encryption and security functionality.
    Client certificates provide user authentication functionality.
    In Native mode, we need to use server/SSL certificates and to ignore client certificates.

    WINHTTP, which our client uses for web connections, does not have any mechanism for client certificate handling so we attempt to try to use the client certificate instead of the server SSL certificate which fails the certificate requirement to access the site via SSL.

    To check this setting within IIS 7:
    1) Open IIS Manager
    2) Expand the Web Site
    3) Select each of the virtual directories
    4) In the middle pane, Select "SSL Settings" per virtual directory
    5) Under "Client Certificates", make sure the option "Ignore" is selected instead of "Accept" or "Require"

    After making this change on Exchange server, the clients began connecting, Able to connect to Exchange Server using AutoDiscover.

     

    From here: http://www.exchange-help.com/index.php?option=com_content&view=article&id=75:autodiscover0x80072f0c&catid=36:exchange2007&Itemid=53 


    Augusto - Brasil
    Friday, December 23, 2011 11:52 AM