locked
HTTP to HTTPS OWA redirection

Answers

  • Replace everything in the redirect.html file with the following code:

    <html>
      <head>
        <title>Hello World</title>
      </head>
      <body>
        <h1>Hello World</h1>
      </body>
    </html>
    

    Try it again.  I think it will give you the same 404 not found.

    It means that your site is located in another location, not in c:\inetpub\wwwroot\. 

    Go to IIS Manager, go to Site and click on your website (not sure how many of them there).  On the right side you will see Basic Settings.  Click on it and check your Physical Path.  This is the place where you have to place that redirect file with the redirect code that I provided.

    Thank you.



    Please “Vote As Helpful” and/or “Mark As Answer” if this post helped you.

    Tuesday, October 23, 2012 12:15 AM

All replies

  • IIS Manager > Default Web Site > SSL Settings > Uncheck Require SSL
    Tuesday, October 16, 2012 3:45 PM
  • Thanks but that was already unchecked.
    Tuesday, October 16, 2012 9:32 PM
    • Select the default Web site, and then make sure that you are in Features View.
    • Double-click HTTP Redirect. Or, right-click HTTP Redirect, and then click Open Feature.

    Refer to:

    How to redirect requests from http to  https:

    http://support.microsoft.com/kb/975341


    Fiona Liao

    TechNet Community Support


    Wednesday, October 17, 2012 9:17 AM
    Moderator
  • I followed the steps in that article but it still does not work. Specifically I applied:

    To   configure automatic redirection to an   OWA directory under the default Web site in IIS 7,   follow these steps:    

        • Start IIS 7 Manager.
        • Select the default Web site, and then make sure that you are in Features View.
        • Double-click HTTP Redirect. Or, right-click HTTP Redirect, and then click Open Feature.

          Note If you do not find the HTTP Redirection feature, make sure that it was installed in IIS. To install the HTTP Redirection feature, follow the steps:
          1. Open Server Manager, and then expand Roles.
          2. Right-click Web Server (IIS), and then click Add Role Services.
          3. Under Web Server, click to select the HTTP Redirection check box.
          4. Click Next to complete the installation.
  • Click to select the Redirect requests to this destination check box, and then type /OWA.
  • In the Redirect Behavior section, click to select the Only redirect requests to content in this directory (not subdirectories) check box.
  • In the Status code list, select Found (302).
  • Click Apply to save the settings.
  • Run the IISRESET command to make the settings take effect.

    Test the application to   determine whether you are   automatically redirected to the   /OWA directory   when   you   enter the http://localhost   URL location on the browser's Address Bar.

    When I test, it does not work internally, and it does not work externally.


Wednesday, October 17, 2012 3:32 PM
  • Any other ideas?
    Friday, October 19, 2012 10:05 PM
  • Here is another way to do this.  It is tested multiple times:

    In the IIS set the first default document as redirect.html. To to your Drive:\inetpub\wwwroot directory and create file redirect.html.  The file should be empty at this time.  Open it with notepad and paste the following:

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <html>
    <head>
    <title>Your Page Title</title>
    <meta http-equiv="REFRESH" content="0;url=https://webmail.domain.com/owa">
    </head>
    <body>
    Redirecting........
    </body>
    </html>

    Tested and works.

    Thank you.



    Please “Vote As Helpful” and/or “Mark As Answer” if this post helped you.



    Sunday, October 21, 2012 6:18 PM
  • Not working for me. Here is what I did:

    Open IIS7 > Select SBS Web Applications > Select Default Document

    Click Add > type Redirect.html > move to top of list

    Navigate to c:\inetpub\wwwroot\ and create Redirect.html and pasted code above modifying the URL to be my OWA url

    Did an IISRESET

    Tested by going to http://domain.com and received a HTTP 404 Not Found web page.

    Monday, October 22, 2012 11:01 PM
  • Replace everything in the redirect.html file with the following code:

    <html>
      <head>
        <title>Hello World</title>
      </head>
      <body>
        <h1>Hello World</h1>
      </body>
    </html>
    

    Try it again.  I think it will give you the same 404 not found.

    It means that your site is located in another location, not in c:\inetpub\wwwroot\. 

    Go to IIS Manager, go to Site and click on your website (not sure how many of them there).  On the right side you will see Basic Settings.  Click on it and check your Physical Path.  This is the place where you have to place that redirect file with the redirect code that I provided.

    Thank you.



    Please “Vote As Helpful” and/or “Mark As Answer” if this post helped you.

    Tuesday, October 23, 2012 12:15 AM
  • You are correct Igor, when I check the Physical path it is set to: C:\Program Files\Windows Small Business Server\Bin\WebApp\SBS Web Applications

    I created the redirect.html file in that location using the code above. I did an iisreset and tried the path but I still get a HTTP Error 404 not found.

    Monday, November 5, 2012 5:35 PM
  • Can you try that Hello World code that I gave you?  This would be a good test for the path.

    Thank you.



    Please “Vote As Helpful” and/or “Mark As Answer” if this post helped you.

    Monday, November 5, 2012 5:36 PM
  • I copied the Hello World code above and pasted it in to the redirect.html file at the new path. When I go to the URL I still see:

    Not Found


    HTTP Error 404. The requested resource is not found.

    Monday, November 5, 2012 5:39 PM
  • This means that you either using the wrong place for the redirect.html file, or it is not setup in default document.

    Do you use IIS7?  Go to your website, click on Default Document.  Is redirect.html there?

    Right click on your website and select Explore.  Is redirect.html file there?

    Thank you.



    Please “Vote As Helpful” and/or “Mark As Answer” if this post helped you.

    Monday, November 5, 2012 7:04 PM
  • I'm probably doing something wrong, but here are screenshots of what I'm seeing. I can't tell what I'm missing. Please note that in the screenshots the Redirect file is named "Redirect.old". When I name it "Redirect.html" it breaks OWA, however when it breaks OWA, I do not see "Hello World" on the site.

    Tuesday, November 6, 2012 5:01 PM
  • And the third screen shot

    Tuesday, November 6, 2012 5:01 PM
  • You have this script in Redirect.old file, not in Redirect.html.

    Thank you.



    Please “Vote As Helpful” and/or “Mark As Answer” if this post helped you.

    Tuesday, November 6, 2012 6:23 PM
  • My comment from above "Please note that in the screenshots the Redirect file is named "Redirect.old". When I name it "Redirect.html" it breaks OWA, however when it breaks OWA, I do not see "Hello World" on the site."
    Tuesday, November 6, 2012 6:30 PM
  • In our case, We have used below code in index.html

    <html>

    <head>

    <title>HTML Redirection to https:</title>

    <META HTTP-EQUIV=”Refresh”

    CONTENT=”1; URL=https://exchange/owa“>

    </head>

    <body>

    </body></html>

    http://msexchange.me/2010/05/22/redirect-http-to-https-owa/


    Sukhija Vikas http://msexchange.me

    Monday, May 5, 2014 3:32 AM