none
Excel - Unable to delete a row RRS feed

  • Question

  • Hi - I have an Excel 2007 spreadsheet - with no formulas - there are around 400 rows and 50 columns however when I try and delete a row I get the error message unable to complete with available resources, it takes forever to load and I have also tried to copy and paste the values into a new spreadsheet but get the same error
    Tuesday, March 15, 2011 11:08 AM

All replies

  • Hi,

    Maybe Excel settings are corrupted, but you need to know if it happens to any Excel files or to specific ones.

    If it happens only to specific files, try saving them with other name and try to delete the rows.

    Anyway, f you fix the settings for Excel in the registry it may solve the problem, see the steps bellow:

    1) Press "Windows" and "R" keys and type "Regedit" and press Enter

    2) Open the following hives in this sequency:

    HKEY_CURRENT_USER  >> SOFTWARE  >>  MICROSOFT  >>  OFFICE  >>  12.0

    3) Inside 12.0 right click "Excel" and rename it "Excel.old"

    4) Exit Regedit and try with a new file to see if the problem is fixed, should be enough.

    Renatoabc

    Tuesday, March 15, 2011 12:27 PM
  • Thanks so much for your response unfortunaly this is a work PC and I dont have the admin rights to do this - I will see about getting Excel re-configured
    Tuesday, March 15, 2011 12:31 PM