none
Outlook 2010 doesn't always reply using the correct email account - bug? RRS feed

  • Question

  • I've observed this behaviour on a number of Outlook 2010 installations:

    Outlook 2010 set up on multiple computers with multiple email accounts (1 Exchange 2007, several POP). When replying to an email that was sent to one of the POP accounts, Outlook will sometimes reply using Exchange instead of the original POP account. The "sometimes" is not random - for any given message it will reply either always via POP or always via Exchange.

    My theory is that the behaviour is dependent on which PC the POP download occurred. I haven't yet tested this theory (I will shortly) but I wonder if anyone else has come across this. To try this: set up an identical Outlook 2010 setup on 2 PCs, with the same Exchange account and the same POP account.

    Send email from any 3rd address to the POP account. If PC1 does a Send/Receive first and you reply to that message from PC1 the reply will go out via POP (as expected / desired). If PC2 does a Send/Receive first and downloads the POP email &  you then reply to that message from PC1 then the message will go out via Exchange (not desired).

    Anyone else seen this? 

    Friday, June 18, 2010 3:47 PM

Answers

  • Hi,

     

    I will provide you the notes I have on this topic along with how I was set up for the testing, but I think you'll be best served if you call in and open an Outlook support incident on this behavior. That will afford us the opportunity to go into a much deeper investigation of this issue.

     

    <><><><><><

     

    **** I wasn’t able to repro some of what you are seeing. Other stuff might be explained by a known issue(s).

     

         1)      In replying or forwarding email, as long as the account is in the profile, it’ll use that account to      reply/forward with. For example, if you had an Exchange account and a POP account, mail to the POP account that you replied/forwarded used that POP account as the sending account. Even if you dragged mail to another store (POP + POP both in different stores, drag mail from one to the other), it would reply/forward with the correct account. If you replied/forwarded to a mail to an account that’s not in the profile, it uses either the store context (if you drag/drop it into the store) or the default sending account if you just open it up in an inspector from Windows and hit reply/forward.

     

    2)      When generating a new email, it uses the context of the store, and in cases where multiple accounts are delivering to the same store, it’ll use the context of who had the store first. So Exchange + POP means Exchange comes up as the sending account. If in a PST with no context (this includes delivery to PST as it turns out), the default sending account is used. If you set up a POP + POP account delivering to the same store, the first account to create/couple to the store is the account that would show up in the new email context.

    3)      When creating a new meeting request, Outlook will use the account tied to the calendar the meeting request is created on. Example: Exchange + POP, new meeting request, the meeting request is created on the Exchange calendar so the Exchange account is used. If using multiple Exchange accounts, the new meeting request will depend on the context of where the meeting request is created. Similarly for OLC, if creating a new meeting request from inside the OLC store, it’ll make it on the OLC calendar. If trying to create a meeting request from an IMAP or POP account that don’t have their own calendars and use the default store’s calendar, it’ll use whatever account the default store’s calendar is. Example: Exchange + POP + IMAP, Exchange is the default store, all new meeting requests are on the Exchange calendar and use the Exchange account.

    4)      When replying or forwarding meeting requests things get tricky. If an unrelated account (an account not in the profile) sends a meeting request, all replies and forwards should behave just like email. If the originating account (exchange + POP + OLC, Exchange sends the meeting request to the POP account), replying will use the POP account but forwarding will use the Exchange account, because the forward is an on behalf of, however the Exchange account is already in the profile so it skips the on behalf of step.

    5)      There is a known issue around Simple MAPI and mailto where it’ll use the default store’s sending account instead of the default sending account. Example: Exchange + POP, POP is set to the default sending account but Exchange is the default store, both Simple MAPI (mail merge, sending things from Windows Explorer, etc.) and mailto will use the Exchange account.

    6)      There’s a regkey to force the user to pick a sending account every time which they can set: HKCU\Software\Policies\Microsoft\Office\14.0\Outlook\Options\ForceAccountSelect, a DWORD, 1 turns it on, 0 or absence of the key turns it off.

     

     

    Here are the configs I tested with:

    Setup #1:

    -          Outlook 2010 RTM

    -          1 Exchange account, 3 POP accounts, all delivering to a PST

    -          Two POP accounts delivering into their own folders as sub folders of the inbox, one POP account delivering to the inbox, Exchange account obviously delivering to the inbox.

     

    Setup #2:

    -          Outlook 2010 RTM

    -          1 Exchange, 4 POP, one IMAP, one OLC account

    -          Exchange + POP are in one store, two POP accounts are in one store, the rest are in their own store (pop, IMAP and OLC)

    -          PST with no account associated with it

     

    And I’ve done extensive tests with Multiple Exchange accounts on this as well.

     

     

    <><><><><><><><><><><>

     

    I hope that helps. If not, please call in and open a support incident on the issue(s) you are experiencing.

     

     

    Thanks and take care,

     

    Jahawk MSFT

    Friday, September 17, 2010 6:09 PM
    Moderator

All replies

  • Hi,

     

    I have tested this issue on my side many times, but could not reproduce the issue. We can also to test this issue by starting Outlook in safe mode and creating a new Outlook profile to see if the problem can be resolved.

     

    For the detailed steps, you can refer to the following:

     

    Step 1: Start the Outlook program in safe mode

    ==============

    1.       Click Start, point to All Programs, and then point to Microsoft Office.

    2.        Press and hold the CTRL key, and then click the Office program you want to start.

     

    If the problem does not occur in the safe mode, this issue might be related to some third-party add-ins in the Outlook program, we can try to disable them. Normally, you could do the following to disable the conflict add-ins in your Outlook program:

     

    Disable add-ins

    ***************************

    1.                   Click File menu, click OptionsAdd-in, click Go button in the Manage: Com-in Add.

    2.                   Check if there are any add-ins, clear the checkbox to disable them.

    3.                   Close the Office program and restart it.

    4.                   Add one check back each time to the list of Add-In, restart the Office program, and repeat the above procedure. Once the issue reappears again, we can determine which add-in causes this problem and then disable it.

     

    However, if the problem persists in the safe mode, let’s continue.

     

    Step 2: Test with a new Outlook profile

    ==============

    1.    Exit Outlook.

    2.    Go to Start > Control Panel, click or double-click Mail.

     

    Mail appears in different Control Panel locations depending upon the version of the Microsoft Windows operating system, Control Panel view selected, and whether a 32- or 64-bit operating system or version of Outlook is installed.

     

    The easiest way to locate Mail is to open Control Panel in Windows, and then in the Search box at the top of window, type Mail. In Control Panel for Windows XP, type Mail in the Address box.

     

    Note    The Mail icon appears after Outlook starts for the first time.

     

    The title bar of the Mail Setup dialog box contains the name of the current profile. To select a different existing profile, click Show Profiles, select the profile name, and then click Properties.

     

    3.    Click Show Profiles. Choose Prompt for a profile to be used.

    4.    Click Add.

    5.    Type a name for the profile, and then click OK.

    6.    Start Outlook, and choose this new profile.

     

    If this problem does not occur in the new Outlook profile, the old Outlook is corrupted. We can delete that and use a new Outlook profile.

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

     

    • Edited by Sally Tang Monday, July 26, 2010 4:39 AM not manged case
    Monday, June 21, 2010 3:56 AM
  • Hi,

     

    I am writing to see how everything is going with this issue. Is the problem resolved? If there is anything I can do for you, please feel free to let me know.

     

    Sally Tang

     

    • Edited by Sally Tang Monday, July 26, 2010 4:40 AM not manged case
    Wednesday, June 23, 2010 2:51 AM
  • Hi Sally,

    Thanks for your reply - I didn't get the notification about your first post, just got one today about your last one - I will try what you've suggested and get back to you.

     

    Thursday, June 24, 2010 10:56 AM
  • Hi,

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    • Edited by Sally Tang Wednesday, July 28, 2010 9:16 AM
    Friday, June 25, 2010 2:56 AM
  • Hi, Sally, Buchawla, I have exactly the same problem with Outlook 2010. I have configured four accounts (one Exchange as a default, three POP) and when I try to reply an email sent to my Exchange account, randomly, it choses a POP account instead (the same POP account every single time). This happens too when I answer a meeting request (Calendar). However, I never had an issue like this with Outlook 2007 and I used to have the same account configuration (one Exchange as a default, three POP).

    I've tried Sally's suggestion, but it didn't solved the problem. Now, I have additional information that can be useful. Some of our users (including me) have Blackberry devices in sync with the Exchange Server. I have noticed the following: the emails sent to my Exchange account and that are randomly replied from a POP account instead, were sent by Blackberry users. I don't recall this happening with emails from other users, but I wouldn't discard it.

    Maybe there is an existing issue with Blackberry synchronization, could it be possible?

    Best Regards,

    Igor Sakuma

    Wednesday, June 30, 2010 9:34 PM
  • Hi Igor,

     

    I would like to confirm whether you are using 64-bit version of Office 2010 or 32-bit versions of Office 2010. To check whether it is the Blackberry synchronization problem, we can check if other users who do not use Blackberry have this problem.

     

    Best Regards,

     

    Sally Tang

    • Edited by Sally Tang Monday, July 26, 2010 4:41 AM not manged case
    Thursday, July 1, 2010 9:22 AM
  • Hi Igor,

    We're not using BES or any BlackBerry devices / software on our network so I doubt our problem is BB related.

     

    Thursday, July 1, 2010 10:15 AM
  • Hi Sally, I'm using a 32-bit version of Office 2010, running on Windows 7 (32-bit as well). As I mentioned before, I have configured four accounts: one Exchange (default) and three POP. They're listed in this order: Exchange, POP1, POP2 and POP3. POP1 is always the account used by Outlook to reply some (it's random) emails sent to the Exchange account.

    Today, I realized that this happens not only with emails sent by Blackberry users (we use BES/BIS). For example, I received an email sent by a generic account (it is used to send daily news company-wide) to my Exchange account that, when I tried to forward it, Outlook used POP1 instead to do so. This time, Outlook changed accounts also for forwarding emails, not only for replying.

    What it surprises me is that this problem didn't occur with Office 2007. I had the exact same configuration and it worked fine everytime.

    Best Regards,

    Igor

    Thursday, July 1, 2010 2:48 PM
  • Hi Budchawla, you might be right, today I noticed that this problem also happens when forwarding emails, and the email wasn't from a BB user. This could be a bug, but if so, I guess we should have been getting a whole ton of post about it.

    Best Regards,

    Igor

    Thursday, July 1, 2010 2:52 PM
  • Hi Sally,

    I tried the steps you suggested. I see the same issue in Safe mode, so it doesn't seem to be related to an add-in. 

    I also set up a new profile and I saw the same behaviour. The only refinement to my original post is that the issue is not consistently reproducible; if Outlook on PC1 receives the email via POP and Outlook on PC2 receives it via Exchange sync it will sometimes reply using POP and sometimes using Exchange - depending on the message. There is consistency in that Outlook will always reply with the same account - if it's Exchange once, it will be Exchange every time.

     

    Monday, July 5, 2010 9:18 AM
  • I am seeing a similar issue to that as well. I have just upgraded from Office 2003 to Office 2010. I have one Exchange account and 5 POP accounts setup. All my Exchange mail and the 5 pop accounts are delivered to a single PST file on my PC.

    I want the exchange account to be the one which is used for all replies regardless of how they were delivered and with emails that is the case, the Exchange account is set as default and it all works okay when replying to an email.

    However, if I reply to a meeting request or I use 'send as attachment' from within Word 2010, it is the first POP account that is used as the 'From' account, not the default Eachange account. As you can imagine that causes confusion with those that are being sent the attachment or the meeting request as the address used for the reply isn't what they are expecting.

    I have tried changing the default account away from the Exchange to one of the other POP accounts and then it works consistently, the same default POP account is used everytime. It just appears to be when an Exchange account is the default that Outlook chooses the wrong 'from' account for certain things.

    We don't have any blackberries, but we do have iphones other other smartphones that sync with Exchange Server though the Send as attachment problem has nothing to do with mobile devices.

    Any ideas ?

    Monday, July 5, 2010 3:11 PM
  • Hello

    We work with Exchange 2003 and Windows 7 (32-bit) and Office 2010. One Exchange-account and one POP account.

    Outlook always takes the correct account except if we do this:

    send a POP-mail (correct sender)

    open this mail and click forward: it takes the exchange-account as sender (which we can change of course).

    Regards

    Ray

     

    Monday, July 5, 2010 3:21 PM
  • Hi all, should we consider this as a bug? If so, how can we report it to Microsoft?

    Regards,

    Igor

    Tuesday, July 13, 2010 7:29 PM
  • I have several IMAP\SMTP account a hotmail account and an Exchange account, and I have been having the same issue. When I reply to emails that come into one of the non-exchange accounts it randomly will send through the exchange account, it is always the exchange and never through a different account.
    Tuesday, July 13, 2010 8:10 PM
  • Yes, this  is another bug, which is very annoying:

    The way it works is the following: if in outlook you set up several (pop3) mail accounts, and you assign one as the “default account”, by default Outlook should send new emails from that account. (It says: “Send from this account by default”). But it doesn’t! It sends at random from any account!

    And that bug is carried over from Outlook 98, to Outlook 2000, to Outlook 2003, and now the same bug in Outlook 2010!!! (I have case numbers with Microsoft for all of them!)

    And until Microsoft recognise that they have a problem here, they won't fix it!

    Tuesday, July 27, 2010 4:07 PM
  • Same problem here. Any time someone on my corporate Exchange server sends me a meeting request, if I just hit Accept|Send The Response Now, the response will be sent using the first of my POP accounts, instead of the Exchange account, as it should be. Same happens with random non-meeting-request emails, as well.

    How do I make a bug report? And how do we get some action on this now-well-documented bug?!

    Thursday, August 5, 2010 11:36 PM
  • Since this is a Microsoft-managed web site, shouldn't someone from Microsoft tell us what to expect or how to proceed? Until July, I though this was not very common, but in one month there has been five new complaints, so I guess someone might be checking out this issue. I haven't heard lately from Sally Tang, she was helping with this at first, I believe she's a moderator in this site, so it would be nice to know if this has been scaleted.

    Best Regards,

    Igor

    Monday, August 16, 2010 2:29 AM
  • Sally,

    By definition, a software bug is an unexpected result which can be achieved on any PC given a specific set of steps are taken on a specific set of hardware which is otherwise normally configured.

    I have been using multiple accounts on Outlook since the very first edition and have never once, not one single time, experienced the performance described in this thread.

    That is NOT to say these customers are not experiencing this performance, but it is to say, at this time, the performance is not reproducible given the information provided thus far.

    Internally, we of course use Exchange servers and naturally, I also have an exchange account.  Into this profile, I have several personal POP3 and IMAP accounts and this has NEVER happened for me.

    HOWEVER, it should be clearly pointed out, the environment is controlled by EXCHANGE and in fact, none of the non-exchange accounts function at all unless the correct Proxy server is set up and active.

    Reviewing the above posts in this thread, I only see one poster that has NOT specified that an exchange account is also present in these multi account profiles.  All other posters mention at leaset one of the accounts is an Exchange account.

    This is potentially key to identification of the cause of this unexpected/undesired result.  There are many possibilities which could explain this performance, among them, them could be:

    1. when the new mail is opened (either new or by reply or forward), if Outlook can't  "see" the exchange server, it is possible Outlook is selection a different account to use.  I do not believe this would be the correct action by outlook, but this action is potentially directed by the group policies in the exchange server.

    2. corruption in the PST file.  Steps to isolate corruption in the PST file as the cause of this performance are specific and clear.  A new Windows user account must be set up, and a new outlook profile created from scratch with accounts added manually (not imported).  This includes the EXCHANGE account and may not always be conclusively support by the group policies on the exchange server.  Part of this is dependent on the cached exchange mode being used or not.

    The problem here is, that Exchange accounts are NOT supported through consumer support. Any time an Exchange account is in play, it is entirely possible the performance is directed by, or complicated by, or directly caused by the Exchange environment and consumer support does not have access to these settings.

    Therefore, I suggest two things:

    1. for all users who are experiencing this unexpected/undesired performance who also have an EXCHANGE ACCOUNT in the effected profile

    A. create a new profile (without importing messages from the original PST store) absent the exchange account and test performance again.  If this is possible WITHOUT the usage of a corporate proxy server, and the undesired/unexpected performance continues, please reply back with the specific steps taken or contact Microsoft consumer support.

    B. If you are not able to create a new profile absent the Exchange account, contact your corporate IT support staff, the technet forums, or Microsoft Professional services

    2. For all users who are experiencing this unexpected/undesired performance where there is NO EXCHANGE ACCOUNT being used, please follow 1-A above.

     

    In closing, and to be perfectly clear, this is not, or does not at this time, appear to be a reproducible scenario in a "clean environment". I have tried multiple times.  Furthermore, I have searched the existing databases and find ZERO record of any previous bug having been logged to describe this performance as far back as Office9.

    This does NOT mean we do not believe you all are experiencing this unexpected/undesired performance.  Clearly you are and we get that.  It just means we need more information to either create a specific set of clean reproduction steps, or isolate and identify the specific technical cause of the unexpected/undesired performance.  Good advice would be though, to keep an open mind when it comes to diagnosing/troubleshooting/documenting the performance as there are many potential causes, especially when an exchange account is in play.

    Thursday, August 19, 2010 1:04 PM
  • If this can be helpful, I'm having same problems with Outlook 2007 on a brand new PC with WINDOWS 7 home edition 64 bit.

    On my older PC with XPSP3 32 bit worked just fine.

    I installed outlook 2007 the other day and I noticed that when I hit REPLY or REPLY to ALL, not always the reply is sent from the expected sender (my default rule is to reply from the same account you received your email).

    Also (and this is very annoying) I noticed that all my inbox emails have no more the "replied mail" icons, I mean the one with the purple arrow indicating that you actually replied to that email, so now I don't see which email has been replied and which not.

    The accounts are all imap and there's just one computer without exchange server or other.

    In the meantime I installed Thunderbird and it works just fine, it kept the original tag (read, unread, replied, forwarded). Any help would be highly appreciated.

    Thank you,  Gianni,  Tours Around Tuscany
    Friday, August 20, 2010 10:24 AM
  • I am experiencing the same problem you describe here. I think you have described it best. The issue can be reproduced in in an environment where:

    -          there are multiple accounts; Exchange and POP3 mix

    -          all mail is delivered to the same PST file

    -          when replying to meeting requests, forwarding meeting requests, or sending from other apps, “send as”

    The email is not sent from the default account, but rather from the first account in the list below the default account, a POP3 account in this scenario. It is not a random account; it is always the first account below the default account (If there is only a single account of course there is no issue and the email/meeting response is sent from that account). I hope this issue is resolved.

     

    The problem does not affect replying to a message, creating new emails or new meeting requests. These cases are all correctly send from the primary account.  

    If the POP3 accounts have their mail delivered to a different PST file then the exchange account the problem does not occur. So bullet point #2 from above is important.

    I have also noticed that after you select the "File" tab, the default account is not active and instead the next account in the list AFTER the default account (the 2ed item) is active.

     More Info:

    I have noticed that the account that is identified as the active default account on the file tab behaves different depending on what PST/Account is active when you click on the file tab.

    Scenario:
    - Two accounts are setup in outlook: Exchange & POP3
    - There are two data files: PST and OST
    - The default account is the Exchange account. The POP3 account is the second account in the list.
    - All mail is delivered to a folder in the PST file. Mail for both POP3 account and Exchange go to the PST file

    In outlook if I select the account that is associated with the PST file and select the file tab I see that the POP3 account is identified as the default account. This is observed as the POP3 account is visible as the selected item in the account list.

    In outlook if I select the account that is associated with the OST file, the exchange account, and then select the file tab I see that the Exchange account (the true default account) is identified as the default account. This is observed as the Exchange account is visible as the selected item in the account list.

     

    Outlook 2010 x86 on Win7 x64

     
    Saturday, September 11, 2010 12:24 AM
  • Hi,

     

    I will provide you the notes I have on this topic along with how I was set up for the testing, but I think you'll be best served if you call in and open an Outlook support incident on this behavior. That will afford us the opportunity to go into a much deeper investigation of this issue.

     

    <><><><><><

     

    **** I wasn’t able to repro some of what you are seeing. Other stuff might be explained by a known issue(s).

     

         1)      In replying or forwarding email, as long as the account is in the profile, it’ll use that account to      reply/forward with. For example, if you had an Exchange account and a POP account, mail to the POP account that you replied/forwarded used that POP account as the sending account. Even if you dragged mail to another store (POP + POP both in different stores, drag mail from one to the other), it would reply/forward with the correct account. If you replied/forwarded to a mail to an account that’s not in the profile, it uses either the store context (if you drag/drop it into the store) or the default sending account if you just open it up in an inspector from Windows and hit reply/forward.

     

    2)      When generating a new email, it uses the context of the store, and in cases where multiple accounts are delivering to the same store, it’ll use the context of who had the store first. So Exchange + POP means Exchange comes up as the sending account. If in a PST with no context (this includes delivery to PST as it turns out), the default sending account is used. If you set up a POP + POP account delivering to the same store, the first account to create/couple to the store is the account that would show up in the new email context.

    3)      When creating a new meeting request, Outlook will use the account tied to the calendar the meeting request is created on. Example: Exchange + POP, new meeting request, the meeting request is created on the Exchange calendar so the Exchange account is used. If using multiple Exchange accounts, the new meeting request will depend on the context of where the meeting request is created. Similarly for OLC, if creating a new meeting request from inside the OLC store, it’ll make it on the OLC calendar. If trying to create a meeting request from an IMAP or POP account that don’t have their own calendars and use the default store’s calendar, it’ll use whatever account the default store’s calendar is. Example: Exchange + POP + IMAP, Exchange is the default store, all new meeting requests are on the Exchange calendar and use the Exchange account.

    4)      When replying or forwarding meeting requests things get tricky. If an unrelated account (an account not in the profile) sends a meeting request, all replies and forwards should behave just like email. If the originating account (exchange + POP + OLC, Exchange sends the meeting request to the POP account), replying will use the POP account but forwarding will use the Exchange account, because the forward is an on behalf of, however the Exchange account is already in the profile so it skips the on behalf of step.

    5)      There is a known issue around Simple MAPI and mailto where it’ll use the default store’s sending account instead of the default sending account. Example: Exchange + POP, POP is set to the default sending account but Exchange is the default store, both Simple MAPI (mail merge, sending things from Windows Explorer, etc.) and mailto will use the Exchange account.

    6)      There’s a regkey to force the user to pick a sending account every time which they can set: HKCU\Software\Policies\Microsoft\Office\14.0\Outlook\Options\ForceAccountSelect, a DWORD, 1 turns it on, 0 or absence of the key turns it off.

     

     

    Here are the configs I tested with:

    Setup #1:

    -          Outlook 2010 RTM

    -          1 Exchange account, 3 POP accounts, all delivering to a PST

    -          Two POP accounts delivering into their own folders as sub folders of the inbox, one POP account delivering to the inbox, Exchange account obviously delivering to the inbox.

     

    Setup #2:

    -          Outlook 2010 RTM

    -          1 Exchange, 4 POP, one IMAP, one OLC account

    -          Exchange + POP are in one store, two POP accounts are in one store, the rest are in their own store (pop, IMAP and OLC)

    -          PST with no account associated with it

     

    And I’ve done extensive tests with Multiple Exchange accounts on this as well.

     

     

    <><><><><><><><><><><>

     

    I hope that helps. If not, please call in and open a support incident on the issue(s) you are experiencing.

     

     

    Thanks and take care,

     

    Jahawk MSFT

    Friday, September 17, 2010 6:09 PM
    Moderator
  • Thanks very much  Jahawk for that detailed explanation of the logic Outlook employs. I didn't mention in my original post that all my POP accounts deliver to a folder in my Exchange mailbox - I don't use any PST files. With what you're saying above regarding context, perhaps that becomes relevant. Either way - the odd thing is that of late I have no longer noticed this issue on any of my computers. While earlier it was a regular annoyance I haven't really noticed it for several weeks / months so perhaps the issue is resolved - fingers crossed! 
    Tuesday, September 21, 2010 10:29 AM
  • I setup a laptop with Outlook 2010 using Exchange Online and POP account with two different inboxes. When doing a Reply in the POP account mailbox, the FROM defaulted to Exchange as the sending server. This is unexpected as obvioulsy there is no point in setting up an SMTP connection for the mailbox if you plan to send through another mailbox.

    There is no way, evidently to not have one of the boxes set as the "default" for sending mail, so since the user prefers the POP service due to a history of mail in that account, I set that box to the default for sending and reorganized the sequence so the pop box is at the top of the display in the list of accounts in Outlook.

    I was expecting mail from the pop account to go to the proper SMTP service when replying from that inbox, and that in fact is how it now works - so this workaround fixed the main problem. However, I was also expecting the Exchange mailbox to go through the SMTP service for the POP mailbox since the SMTP service is now "the default" - however, it works properly sending the mail through the Exchange service. This means, that the Outlook is inconsistent in it's selection of service in these two configrations. I certainly would classify this as a bug as it does not work as expected based on scenario.

    In summay:

    Outlook 2010 64 bit - Win7 home premium

    Inbox 1 - Exchange Online

    Inbox 2 - POP3/SMTP

    Scenario1: Inbox 1 set as default to send = Reply to mail in POP3 box results in mail being sent to the Exchange server by default. Exchnage box works correctly.

    Scenario2: Inbox 2 set to default to send = Reply to mail in both POP3 and Exchange inbox work correctly. Mail is sent to the server that is assigned to each account.

     


    Brett Hill | Office365Answers.com
    Monday, December 27, 2010 2:12 PM
  • I'm having this issue too.  Can't we just have an option in settings that allows us to pick the account mail is sent from in each scenario.  I have "use this account as the default" checked and am running into the same problem where, on reply emails, it is picking the non default email.
    Wednesday, January 19, 2011 9:33 PM
  • Sir, you said:

    "I have been using multiple accounts on Outlook since the very first edition and have never once, not one single time, experienced the performance described in this thread"

    What you are saying is that since you are not able to reproduce it, it therefore cannot be a bug.

    This is untrue. All that it means is that the bug is so elusive, we haven't been able to determine what combination of events causes it.

    Hence, you cannot reproduce it.

    I have a similar problem, today EVERYTHING I reply to uses a pop account. The only change is that I deleted a pop account, and created an imap account. For some reason, none of the mail is being stored in the imap store, it is all showing up in my personal folders.

    When I reply, it always uses a pop account, notably not random, but the same one every time.

    Not a bug you say?

    David

    Wednesday, March 21, 2012 5:23 AM
  • I have several POP3 accounts in Outlook 2003. Sometimes when replying to message sent to my default account, outlook replies using my other POP3 account. It is random. But once it happens, it will stick with it. Once I delete this account which I don't want to use to reply, it will reply with the right my default account. There is nothing I can do about it. Once Outlook thinks that this one message came to wrong account, it will keep trying to reply using this wrong account.
    Thursday, July 19, 2012 6:02 PM
  • Are you typing in the person's name and using the cached email that auto-fills?  It could be that you mistakenly sent a request to Exchange people from your personal account in the past and now that's what the auto-fill does automatically.  Try clearing your auto name cache (FILE>OPIONS>MAIL>Empty Auto Complete List) and actually enter the email address you want used to send the request or email from.  Then see if auto fill works properly after that.  Outlook 2010 keeps an autofill file on the server vs on your harddrive which may get corrupt and rebuilding it this way might solve your issues. Also, if you are highlighted on one email account while authoring and email, it will default to sending from that email account.  You can change that by clicking on the FROM button and changing to the preferred account..
    Tuesday, March 5, 2013 6:33 PM