none
Maximum attachment size for email-enabled lists RRS feed

  • Question

  • We have a number of lists set up to receive email in WSSv3. They are set up to save the original email and all original email attachments. The problem is with large attachments or multiple attachments whose total size is too large. The threshhold seems to be around 2MB. So, for example, if I forward an email that has a 3MB attachment to the SharePoint list, it is returned to my Inbox as Undeliverable with the following message in the email body:

     

    This message is larger than the current system limit or the recipient's mailbox is full.  Create a shorter message body or remove attachments and try sending it again.

                <mycompany.com #5.2.3 smtp;450 5.2.3 Msg Size greater than allowed by Remote Host>

     

    This also happens if I were to send the email with three attachments that were 1MB each (total attachment size of 3MB). As long as the total attachment size is less than 2MB, we can send attachments to the various lists all day long.

     

    I checked the Incoming Email Settings page for the email-enabled list itself, but it didn't have any settings for maximum attachment size there. Same for the Incoming Email Settings page in SharePoint Central Administration. I also checked the Web Application General Settings page in SharePoint Central Administration but the only thing that looked like it might apply was the Maximum Upload Size...but we already have that set to 50MB, so that couldn't be the problem. And I checked the Maximum Sending Message and Maximum Receiving Message sizes on our Exchange server and they were both set to 30MB.

     

    Does anyone know how to increase the email attachment size for email-enabled SharePoint lists?

     

    Thanks,

    Scott

    Friday, September 21, 2007 8:56 PM

Answers

  • Hi Scott,

     

    I'm guessing that the incoming email configuration you are using involves having a SMTP server running on one of your MOSS servers and that Exchange routes the emails to this SMTP server, and that it is this SMTP server that is rejecting the emails.

     

    If so just launch IIS Manager on the incoming email server and go to the properties of the SMTP server. On the Messages tab you will find some the size limit for attachments. On my box it was defaulted to 2MB. Change this and click Apply and you should find your problem solved.

     

    Chris.

     

    Friday, September 21, 2007 9:40 PM

All replies

  • Hi Scott,

     

    I'm guessing that the incoming email configuration you are using involves having a SMTP server running on one of your MOSS servers and that Exchange routes the emails to this SMTP server, and that it is this SMTP server that is rejecting the emails.

     

    If so just launch IIS Manager on the incoming email server and go to the properties of the SMTP server. On the Messages tab you will find some the size limit for attachments. On my box it was defaulted to 2MB. Change this and click Apply and you should find your problem solved.

     

    Chris.

     

    Friday, September 21, 2007 9:40 PM
  • Yes!! That was exactly it! This is going to make such a difference to us on a daily basis now.

     

    Thank you very much Chris for your helpful input.

     

    Scott

    Saturday, September 22, 2007 9:27 PM

  • Is there any service or API which when called will return the maximum attachment size to the end user ?

    i am trying to develop a plugin for outlook which will automatically split the attachment in case if the size exceeds
    maximum size

    also the program would like to know the allowed file types which can be sent via the mail service

    Regards
    amitjo
    Sunday, September 30, 2007 10:20 AM
  • Thanks, Chris!
    Your suggestion hit the nail on the head.
    Chris
    Wednesday, August 13, 2008 3:10 PM
  • I would strongly recommend not setting up your own SMTP server on a WFE (especially if its part of a load balanced set).  You are expected to make use of an existing SMTP server/gateway such as your Exchange server.  If SMTP is not set up in Exchange then ask your Exchange colleague to do so and reconfigure MOSS for that. 

    Regards,

    Garrath Earnshaw
    Garrath Earnshaw, IM Practice, Fujitsu
    Monday, February 2, 2009 4:14 PM