none
Having problems pasting Visio 2013 Drawings into Word 2013 RRS feed

  • Question

  • Hello I am having issues pasting Visio 2013 drawings into Word 2013. For some reason when I select and copy the visio drawing into Word 2013, a portion of the drawing is cut-off and I cannot resize it to fit the entire drawing. I can double-click the drawing but it only gets me back into Visio. I just want the entire drawing to show up correctly when I paste into Word. Never had this problem with previous versions! Please help!!!
    Friday, July 11, 2014 5:33 PM

Answers

  • Hi,

    Could you please tell us how do you past Visio 2013 drawings into Word 2013?

    Generally, we can select the entire drawing by pressing Ctrl + A, then copy the entire drawing.

    Or we can insert Visio 2013 drawings into Word by Insert > Object > Create from File.

    Note: Make sure tick the option of Link to file.

    Feel free to post back.

    Regards,

    Greta Ge CHN
    TechNet Community Support


    Monday, July 14, 2014 3:24 AM

All replies

  • Hi,

    Could you please tell us how do you past Visio 2013 drawings into Word 2013?

    Generally, we can select the entire drawing by pressing Ctrl + A, then copy the entire drawing.

    Or we can insert Visio 2013 drawings into Word by Insert > Object > Create from File.

    Note: Make sure tick the option of Link to file.

    Feel free to post back.

    Regards,

    Greta Ge CHN
    TechNet Community Support


    Monday, July 14, 2014 3:24 AM
  • I think to recreate the issue the OP has is,

    1. Do the process to insert the drawing as Mario suggested.
    2. Then edit the Visio document in Word.

    Note that the canvas is always the same size. Any operations which go outside the canvas are clipped by Word.

    The real question is, how can one resize the Visio canvas and subsequently resize the drawing in Word?


    William Wegerson (www.OmegaCoder.Com)



    • Edited by OmegaMan Friday, January 9, 2015 4:49 PM
    Friday, January 9, 2015 4:46 PM
  • I was running into the problem that after using the Word 2013 Insert, Object, From File, for my Visio 2013 diagram, word would show it clipped.

    It turns out that I missed the 'Crop' option that appears above the mouse when right-clicking on the visio diagram. After finding that, I was easily able to update the cropping boundaries of the visio diagram.

    Finally figured this out!!!

    Hoping this post can help others that might not also see that almost hidden 'Crop' option.

    • Proposed as answer by urgetosplurge Wednesday, June 1, 2016 2:55 PM
    Wednesday, June 10, 2015 7:24 PM
  • This is stupid ridiculous!  By default it should show the whole diagram, then allow the user to crop if desired.
    Thursday, August 6, 2015 8:01 PM
  • Wow, thanks for pointing that out.

    A few months back, I went from being able to copy and paste perfectly from Visio to Word to having this issue. Almost overnight. Did not realise it was auto-cropping.

    I'd like to think the auto crop is something we're able to turn off, but it doesn't look like it.


    Regards, Jason Dunbar

    Monday, November 23, 2015 11:45 AM
  • How is this in any way the answer?

    Regards, Jason Dunbar

    Monday, November 23, 2015 11:46 AM
  • Thanks so much for your answer: it's precisely what I was looking for.  Been struggling with this hair-tearingly annoying issue all day - never spotted the 'Crop' option above the context menu until you pointed it out.
    Wednesday, June 1, 2016 2:57 PM
  • Thanks for this.   This approach does not work when copying an item from Visio to Powerpoint. Any ideas?
    Wednesday, October 26, 2016 10:02 PM
  • Yes - I had this problem, nothing suggested so far solved it, but finally solved it today.  

    I used CTRL-A in visio 2013, then CTRL-C. ALT-TAB to Powerpoint, Paste Special -> Enhanced Metafile. It was always cropped. In fact it cropped even if I pasted it as a metafile into Visio... so it's lost in the copy, not the paste. Almost as if it's not copying the same pixels that are displayed...

    I was using a laptop, displaying out to a monitor over VGA, at a different resolution (1920x1200). I unplugged the laptop from the monitor, so it was displaying at native resolution on the laptop (in my case 1920 x 1080). I tried it again exactly as above, and it worked. Perfectly. No crop.

    So if you are displaying to a different monitor, try unplugging it. I tried changing the monitor to the same resolution as the laptop, that did not work. I had to unplug the monitor and use the laptop screen. It worked for me, good luck.

    p.s. yes this is terrible of visio etc. and just a work around, it does not excuse Visio 2013 from needing a bugfix!

    • Proposed as answer by Hemsey Tuesday, November 1, 2016 10:35 AM
    Tuesday, November 1, 2016 10:33 AM
  • This is the actual resolution to the issue.
    • Proposed as answer by PGMeadows Thursday, December 1, 2016 9:20 PM
    Thursday, December 1, 2016 9:20 PM
  • I had the same problem (though pasting from Visio 2010 to Word 2013), and to my surprise unplugging the large screen monitor worked. This sounds like an utterly ridiculous bug! Of course I would like to be able to use my large screen when working on Visio. Has a fix been released yet?
    Tuesday, December 13, 2016 1:53 PM
  • Greta's reply is an explanation of possible ways to paste, but does not address the failure.  Hemsey is correct in that the issue lies with the display.  When you have an embedded object from another application, it produces the Metadata of an image so that it can display on the screen and when printing without having to go to the original application. It is this process of generating that image that is at fault. I suspect that it uses the display driver to do this.  Somewhere the display is identifying the DPI to the application so that it can scale the image correctly when placing it into the document.  However I suspect that Anilij's driver is mis-reporting the information, presumably giving the DPI of the native display instead.  I have had this same issue for a very long time (years perhaps) and a search shows this to be the case for others.  My specific case is a DisplayLink driver. I would be curious for others which driver they are using to see if this is only related to a specific vendor/version etc.
    • Proposed as answer by gshipe Tuesday, August 8, 2017 2:32 AM
    Tuesday, February 28, 2017 12:22 AM
  • Same here - On DipslayLink Driver as well - I have had this issue on and off for years, but never used Visio often enough to realize it only happened on a particular screen setup. Mystery solved - thanks!
    Friday, March 3, 2017 8:12 PM
  • Hello,  I too have this issue and have tried everything that I can find on blog's etc. including this one.  Still get only a partial image of a flowchart that I want to place into a Word document.  This is now 03-22-2017 and I guess it is still a problem!  In the past it was as simple as lasso the image then copy and paste and it worked just fine.  This is really aggravating to say the least.  Long time user of the original Visio and MS office products.

    Regards, Peter at Panasonic Avionics Corp.

    Wednesday, March 22, 2017 9:44 PM
  • Made my day. I was almost getting crazy. I had the same issue when trying to export to a PDF. Parts on the right and bottom of the Visio drawing where permanently missing. After plugging off my external monitor and repeating the same steps on my notebooks primary display only - everything works like a charm.
    Monday, July 24, 2017 4:00 PM
  • Same issue but even worse solution, Windows 10 issue as no problems when I was on Windows 7.

    As I use Citrix Receiver the DPI on all monitors needs to be the same otherwise the mouse pointer offset is incorrect. So setup DPI to 100% on both laptop & external. So now Citrix works okay.

    Now try to copy & paste diagram from Visio to Word, fails top,side,bottom cut off.

    Okay so I unplug external monitor, same issue still not letting me paste without cropping most of the image.

    So now I set the DPI to 150% on laptop monitor the recommended. Now I can copy paste between Visio 2013 & Word 2013. 

    Welcome to the future, need to unplug external monitor and change DPI settings to copy & paste :-(

     


    Monday, August 14, 2017 2:31 PM
  • I have the same cropping problem when cutting and pasting from Visio 2016 to PowerPoint 2016 or to Word. This is a huge issue. I will lose all the graphics produced for my lectures over last 15 year. 

    After trying for hours, no solution found, apart from falling back to bitmap screen captures. Bitmaps are not acceptable in this age. Smooth, scalable vector graphics is the reason for using Visio in the first place.

    I have high display resolution, so increasing that won't help. Changing the font scaling to higher % from Windows 10 Display Properties reduces the cropping somewhat, but arbitrary parts of every Visio page are still lost.  In any case, display resolution should have nothing to do with vector graphics objects. PowerPoint and Word are able to crop more, but they cannot make the already cropped parts visible.

    This clearly is not a new bug. Is there any hope? 

    Wednesday, September 27, 2017 10:36 PM
  • me too. Word and Visio on Windows 10. New problem for me! unbelieveable. 

    PS no "auto crop" appears anywhere that I can see in Visio

    Monday, December 4, 2017 8:48 AM
  • You have got to be shitting me. This worked.

    Been trying for over an hour now.
    Thanks so much for posting this, that bug still exists in Visio 2016 to PowerPoint 2016.


    Monday, January 29, 2018 10:04 AM
  • This is pathetic.  I need to use my big monitor in order to do the detailed graphical work.

    Fix this!

    Saturday, March 17, 2018 6:52 PM
  • Totally agree. Creating additional steps to allow an image to be rendered in its original form is counter-intuitive. Cropping and other steps should only be needed if the user wants to select part of the diagram.

    I finally cried 'uncle' and used Snipping Tool to take a screen shot and pasted that.

    VERY poor development from Microsoft.


    Pamela

    Thursday, March 22, 2018 10:22 PM
  • Creating additional steps to allow an image to be rendered in its original form is counter-intuitive. Cropping and other steps should only be needed if the user wants to select part of the diagram.

    I finally cried 'uncle' and used Snipping Tool to take a screen shot and pasted that.

    VERY poor development from Microsoft - but not surprising given the development teams don't seem to talk to each other.


    Pamela

    Thursday, March 22, 2018 10:23 PM
  • me too. Word and Visio on Windows 10. New problem for me! unbelieveable. 

    PS no "auto crop" appears anywhere that I can see in Visio

    With Win 7: no problem, or only very long ago.

    With Win10: silly problem drives me crazy after each and every update the ridiculous implementation of cut&paste behaves differently or does not work due to this problem.  This week, it adds a border to the right and at the bottom.

    Hey, Microsoft: We are in the year of 2018! People dream of AI - but not even this feature works as expected!!

    Thursday, April 19, 2018 8:14 PM
  • me too. Word and Visio on Windows 10. New problem for me! unbelieveable. 

    PS no "auto crop" appears anywhere that I can see in Visio

    ===

    With Win 7: no problem, or only very long ago.

    With Win10: silly problem drives me crazy after each and every update the ridiculous implementation of cut&paste behaves differently or does not work due to this problem.  This week, it adds a border to the right and at the bottom.

    Hey, Microsoft: We are in the year of 2018! People dream of AI - but not even this feature works as expected!!

    The only way to get it work as expected on a Laptop with external monitors

    1) Edit the drawings with the best resolution possible.

    2) Display all screens only on local laptop monitor

    3) Do all the copy-and-paste work -- for me it worked as expected.

    Really, really poor implementation (Office 2016 Professional)

    Thursday, April 19, 2018 8:41 PM
  • Thank you, this works. Crop the pic first and then resize to fit the margins.
    • Edited by got.karthik Saturday, April 28, 2018 1:58 PM
    Saturday, April 28, 2018 1:57 PM
  • I had the same problem and narrowed it down to a situation where my laptop and external monitor Scale & Layout settings were mismatched; one was set to 150% and the other to 100%. Setting both to 100% worked around the problem. I suspect somewhere between Visio, Clipboard and Word the application took into account the display settings and somehow tried to be helpful. What benefit or problem does it solve and should it not always paste like-for-like at 100%. i.e. ignore the display scale settings! (dimensions fair enough).
    Thursday, October 11, 2018 8:30 AM
  • I had the same problem and narrowed it down to a situation where my laptop and external monitor Scale & Layout settings were mismatched; one was set to 150% and the other to 100%. Setting both to 100% worked around the problem. I suspect somewhere between Visio, Clipboard and Word the application took into account the display settings and somehow tried to be helpful. What benefit or problem does it solve and should it not always paste like-for-like at 100%. i.e. ignore the display scale settings! (dimensions fair enough).
    Thanks! I was dubious but yep, removed the extended monitors from the equation and totally fine to copy/paste it. What I don't get is a thread of complaints going back 4 years, 2 versions of Windows and no fix. It should not be this hard.
    Thursday, October 25, 2018 1:26 PM
  • I had the same problem when working with external 4K monitor and Intel(R) HD Graphics 520. When the "size of text" was set to 100%, cutting from Visio and pasting to Word works incorrectly cropping the fragment displayed in Word. Opening the document on any other computer shows the same cropping. The attempt to edit the embedded diagram opens Visio and displays the full picture correctly.

    Setting this factor to 125% immediately resolved the issue, and the copied fragment is displayed correctly in Word.

    Setting the text to 150% creates margins around the inserted fragment when pasted. Setting it to 200% creates even larger margins. 

    Interestingly, cutting with one scaling factor and pasting with another results in correct pasting at 125% regardless of the resolution used when copying. So it looks that there is some size parameter computed by the clipboard/insertion which is dependent on the scaling factor and it is computed incorrectly when pasting. It is certainly a bug!

    I repeated the experiment with Visio 2013 and Word 2016 with  Intel(R) HD Graphics 620 and the same monitor. In this case the optimum setting of the scaling factor is 100%, setting it to 125% creates margins to the right and bottom of the inserted image. 

    Note the different font size in this message(!) - it happened when I edited the text entered in 100% scaling in when display was set to 125% . The clipboard thinks that the text needs to be reduced to become as (small) as intended.

    Overall, it looks to me like a mess when computing the displayed size of the clipboard, hope that MSFT fixes this bug.

    • Proposed as answer by MLVJ- Friday, January 4, 2019 4:55 PM
    Thursday, December 20, 2018 1:32 AM
  • Really useful, thank you.

    On Intel(R) HD Graphics 530, in my own case, 175% is the required setting.

    I too hope that MSFT fixes this defect - which is new since I upgraded the laptop from Windows 7 to Windows 10 a couple of months ago.

    Friday, January 4, 2019 4:54 PM
  • I think I figured out a hack for this.

    - Insert the Visio object into word; it will be messed up/cropped

    -Right click on the Visio Object and hit edit. This will open in Visio

    -In the open Visio window, click the design tab and then under page setup click the size button.

    -Scroll to the bottom and click "More page sizes" and then "Custom size"

    - I increased the dimension by the same factor for both dimensions eg. (8.3X 1.3)X(11 X 1.3). I had to use 11.9 X 15.4

    As you increase the dimensions the visio drawing will shrink and probably move down. But when you click apply and ok and check your word doc, you'll notice that more of the object is showing although some of it may be off screen. I went back to the visio window and dragged the drawing towards the top and it moved object up in the word doc. This worked for me after an hour of playing around. 

    Wednesday, June 12, 2019 8:26 PM

  • I think I figured out a hack for this.

    - Insert the Visio object into word; it will be messed up/cropped

    -Right click on the Visio Object and hit edit. This will open in Visio

    -In the open Visio window, click the design tab and then under page setup click the size button.

    -Scroll to the bottom and click "More page sizes" and then "Custom size"

    - I increased the dimension by the same factor for both dimensions eg. (8.3X 1.3)X(11 X 1.3). I had to use 11.9 X 15.4

    As you increase the dimensions the visio drawing will shrink and probably move down. But when you click apply and ok and check your word doc, you'll notice that more of the object is showing although some of it may be off screen. I went back to the visio window and dragged the drawing towards the top and it moved object up in the word doc. This worked for me after an hour of playing around. 

    Wednesday, June 12, 2019 8:27 PM