none
IIS won't apply redirect on Lync Server RRS feed

  • Question

  • Hi,

    I have a problem with the redirect functionnality of IIS in my lync 2010 SE server.

    Actually, IIS should redirect https://admin.gaulle.lan to https://lync2010-fe.gaulle.lan/Cscp but it does not.

    "https://lync2010-fe.gaulle.lan/Cscp" is perfectly working. No problem with this page.

    But, when I try to access "https://admin.gaulle.lan", I've got a blank page. When I try to analyse, I don't receive a 302 from lync server.

    I searched in IIS parameters but I'm not a web/iis expert. When I look at the URL rewrite module, everything seems to be ok...

    Is there a way to be sure that redirect is working on my iis server ? Do I have to enable someting to make it work ?

    FYI, I meet the same problem with Dialin and Meet Simple URLs.

    Thanx for your help

    Regards,

    Bastien.

     


    Bastien
    Friday, February 18, 2011 9:21 AM

All replies

  • If you've changed the dialin, meet, or admin URLs since you installed the server you'll need to re-run the setup operation (Step 2) from the installation wizard. That step is what actually creates the redirect rules in IIS.
    Friday, February 18, 2011 5:55 PM
  • Hi, would you please try below PSS CMDLets:

    $urlEntry = New-CsSimpleUrlEntry -Url "https://admin.contoso.com"
    $simpleUrl = New-CsSimpleUrl -Component "cscp" -Domain "*" -SimpleUrl $urlEntry -ActiveUrl "https://admin.contoso.com"
    Set-CsSimpleUrlConfiguration -identify "site:CN" -SimpleUrl @{add=$simpleUrl}
    Enable-cscomputer


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, February 21, 2011 10:06 AM
  • Hi,

    Thanx for your help. I already tried to modify and reapply simple urls through the topology builder and it did not change anything.

    I tried to use commands you adviced me but it does not seem to work better.

    Here is my Get-CsSimpleUrlConfiguration

    Identity  : Global

    SimpleUrl : {Component=Dialin;Domain=*;ActiveUrl=https://dialin.gaulle.lan,        Component=Meet;Domain=gaulle.lan;ActiveUrl=https://meet.gaulle.lan,           Component=Cscp;Domain=*;ActiveUrl=https://admin.gaulle.lan...}


    Thanx,
    Regards
    Bastien.


    Bastien
    Tuesday, February 22, 2011 10:19 AM
  • Thanx for your answer !

    Unfortunatelly, I've already tried to modify simple urls and after to come back (and I reapplied setup operation) to my urls but without any success.

    Thanx,

    Bastien.


    Bastien
    Tuesday, February 22, 2011 10:21 AM
  • Hi, did you restart service or reboot server after modified that?
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, February 24, 2011 2:21 AM
  • Yes I did.

    I also tried to uninstall/reinstall lync web component server and the IIS role from my lync server but with no success.

    As I said, everything works fine except those redirect/rewrite URLs so I would think about a IIS configuration problem but I can't find where it is ...

     

     


    Bastien
    Thursday, February 24, 2011 10:42 AM
  • Bastien,

     

    did you find a solution to your problem ? I have similar issue.

     

    thanks

     

    Thursday, May 19, 2011 3:05 PM
  • Create a Host A record in DNS by name admin.gaulle.lan with same IP as the lync2010-fe.gaulle.lan
    ------Exchange, OCS------
    Thursday, May 19, 2011 8:40 PM
  • Sorry to bring up an old thread but i'm having a very similar problem and it didn't seem like this one was resolved.

    New Lync 2010 environment - no matter what I do, Simple URL's won't publish in the URL Rewrite module.

    I'm actually in training right now so I was able to check how it was supposed to look (multiple entries in the URL Rewrite options) and my environment only has 2 entries (client access and Meet rule #1, nothing else). 

    No matter how I many times I publish my topology or enable-cscomputer it doesn't work. This is on 2 front end servers. I even ran a clean install of a W2K8 R2 Server and did it again, still no luck. 

    What am I missing?

    Thursday, March 14, 2013 2:57 PM
  • Try this: Change URL for Administrative Access in Topology Builder (Lync Server 2010/2013 - Edit Properties). Next you must publish the new topology and then you must run Setup on the front end server and choose Install or Update Lync Server System - Setup or Remove Lync Server Components - Run. Worked in my case...

    Mike

    Tuesday, September 2, 2014 12:59 PM
  • Yes, this does work.

    Akos_DB

    Thursday, May 17, 2018 3:52 PM