none
Unable to mount database. Help! RRS feed

  • Question

  • Our server has 4 mailbox databases.

    We had tonnes of whitespace in the third database so I was performing migrations from this database into the 4th database and unknowingly the server ran out of space due to log files on the new database.

    The log files equated to 500GB then exchange unmounted all 4 of the databases.

    I've been able to remount 3 of the 4 databases but the one I was migrating away from won't mount.

    I need to get this mounted to finish off moving mailboxes away from it.

    Can anyone offer any advice?

    Sunday, July 21, 2019 11:29 AM

All replies

  • I am restoring the database which won't mount .edb file from a recent backup to a recovery database.

    If anyone could provide advice on how I can restore only the mailboxes which didn't migrate over to the 4th database into the 4th database from the recovery database?

    Hopefully that makes sense.

    Sunday, July 21, 2019 11:55 AM
  • Hi,

    Do you mean the you want to move mailboxes from the third database to the fourth database, and the third database cannot be mounted?

    Did you get any alerts when you tried to mount the third database?

    Do you get any related event log from Event Viewer for why the third database cannot be mounted?

    If this issue only be caused by the disk space, you can use Windows Server Backup to back up Exchange data and select a VSS full backup. It allows the transaction logs for the databases on the selected volumes to be truncated at the completion of a successful backup.

    For your issues about restore mailboxes to another database, you have to create new mailboxes as target mailboxes on the 4th database to restore specific databases. You can check this for detailed steps about restoring mailboxes: Restore data using a recovery database

    Here is a blog about Restoring a Mailbox from an Exchange Server 2013 Recovery Database, you may get useful information from it.

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.

    Regards,

    Lydia Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, July 22, 2019 2:40 AM
    Moderator
  • Hi,

    1) Have you checked database health. Is is dirty shutdown or clean shutdown.

    Use ESEUTIL /MH command to check database health.

    eseutil /mh "D:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group\Mailbox Database.edb"
    (Assuming Exchange 2010 is installed on the D:\.)

    2) What error it is throwing when you try to mount database.

    HP

    Monday, July 22, 2019 9:52 AM
  • Hi,

    Is there any update on this thread? Please let us know if you would like further assistance. 

    If you have solved your problem, could you share with us? Maybe it will help more people with similar problems. 

    Regards,

    Lydia Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, July 26, 2019 1:25 AM
    Moderator