locked
Extreamly strange error that I cannot locate any solution through Internet!! RRS feed

  • Question

  • Here is how I recieve this error:

    We've got some email template files which were saved in .msg format (Outlook Message format unicode) and the file properties were set to "Read Only". These templates are shared within our department, my team members can open and use them to send emails with both Outlook 2007 and 2010 with no problems. Every time after they send the email, the content of the templates won't be modified. Because we need to send a lot of email with similar contents repeatly every day. But, the error shows up as below while I sending the emails with them with Outlook 2010:

    I've researched this issue last year with no luck. Any ideas?

    Wednesday, August 29, 2012 9:06 AM

All replies

  • Hi,

    Where is the template stored? Does the user have write access to that location? Does this alert show when you open .msg file?

    Right click this shared file, check your name and permission on the list.

    Follow the steps given below to edit or modify outlook templates:-
    1.     Start Microsoft Outlook 2010. Choose the "Developer" ribbon from the top of the Outlook screen, point to "Forms" and click "Choose Form" to open the Choose Form dialog box.
    2.     Choose "User Templates in File System" from the "Look in" drop-down menu at the top. The templates you have previously created will display below the drop-down list.
    3.     Select the template you want to edit from the list by clicking on it. Click the "Open" button to close the Choose Form dialog box and open the template you have chosen in Outlook.
    4.     Edit the Outlook template to reflect the changes you want to make to the template.
    5.     Click the Office button at the top left of Outlook and choose "Save As" to open the Save As dialog box. You can rename the template or change the location where it's saved. Click the "Save" button when you are finished saving the template.
     
    For more information on how to manage templates in office programs, you can check the article below:-
    http://support.microsoft.com/kb/924460

    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Thursday, August 30, 2012 11:02 AM
  • Thanks Tony. I'm afraid that this is not the answer that can fix my issue. I've already checked it before. Let me provide you more details.

    1. These templates were created years ago by someone else and are stored in the shared folder from our team server and everyone can copy them to their own PCs and send emails with them without problems, only me who occurs this error.

    2. Please note, they were saved in .msg format (Outlook Message format unicode) instead of .oft format and the file properties were set to "Read Only". So technically they are not the actual "Template" files you defined. The reason we use .msg format instead of .oft template format is simply because that the value of "From" field can be set and saved in .msg format; while it can't be do so by saving in .oft format (if you choose a sender in the From field and then save as a oft file; when you open it, you will find out that the value can't be saved. To my knowledge, this is by design).

    3. Yes, I also noticed that the issue might be caused by the files permissions. At first, I find my domain alias is not listed in any template file after they were copied from the server. I checked the same templates copied from server on my colleague's computer, his domain alias was added to the permission field (Security tab of the file properties) automatically. That's weird!!!!! My domain alias has already been added to local Administrator group. I should be able to access to any files and programs without any permission problem. After that, I logon to my local admin account and add my domain alias to the Administrator group again. And now I can manually add my domain alias in to the permission field. But the issue still persists. And I also find that if I copy the files from the server to my computer again, my domain alias is still not added to the permission field automatically. Is this the cause?

    • Edited by MS_OLC Friday, August 31, 2012 12:56 AM
    Friday, August 31, 2012 12:54 AM
  • anyone else?
    Tuesday, September 4, 2012 6:10 AM
  • bump
    Thursday, September 6, 2012 5:52 AM
  • According to this,  try this:

    1.Modify the .msg file permission on server, add your alias into security tab with Full Control.
    2.If it still not working, create a new .msg file and share for further testing.

    Thanks.

    Cheers,

    Tony Chen

    Friday, September 7, 2012 3:52 PM
  • According to this,  try this:

    1.Modify the .msg file permission on server, add your alias into security tab with Full Control.
    2.If it still not working, create a new .msg file and share for further testing.

    Thanks.

    Cheers,

    Tony Chen


    What do you mean by "create a new .msg file and share for further testing"? I've tried create a .msg file on my computer, the new .msg file has the same issue. Can you please be more specific?
    • Marked as answer by MS_OLC Saturday, September 8, 2012 8:39 AM
    • Unmarked as answer by MS_OLC Saturday, September 8, 2012 8:39 AM
    • Edited by MS_OLC Saturday, September 8, 2012 8:40 AM
    Saturday, September 8, 2012 8:39 AM
  • "These templates were created years ago by someone else"

    I suspect that the creator uses early Office version, like Office 2003 SP2, to create MSG template and that might cause some compatibility problems. Please check the MSG format text. In my database, we may receive the following error message when you set different format text.

    *********************

    If you open a read-only HTML formatted e-mail message that is saved to your hard disk drive as a .msg file, and then you try to forward the e-mail message, you receive the following error message:
    Internal MAPI error: An invalid parameter was passed to a MAPI function. Contact your administrator.

    If you change a plain text read-only e-mail message and then forward the e-mail message, you receive the following error message:
    A resource is busy or you lack sufficient access rights or permissions

    If you edit an RTF read-only e-mail message then forward the e-mail message, you receive the following error message:
    This message cannot be modified. You may not have permission to modify the message. To save your changes, click Save As on the File menu.

    **************************

    This problem is by design when you try to change a read-only e-mail message.

    (However, if you try to reply to a read-only HTML formatted e-mail message or to a read-only plain text formatted e-mail message, you do not receive an error message.)

    To work around this problem, we can reply to the e-mail message instead of forwarding the e-mail message. When you reply to the e-mail message, change the recipient name that is in the To field to the appropriate recipient that you want to send the message to.

    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com
    .


    Tuesday, September 11, 2012 2:31 AM
  • "These templates were created years ago by someone else"

    I suspect that the creator uses early Office version, like Office 2003 SP2, to create MSG template and that might cause some compatibility problems. Please check the MSG format text. In my database, we may receive the following error message when you set different format text.

    *********************

    If you open a read-only HTML formatted e-mail message that is saved to your hard disk drive as a .msg file, and then you try to forward the e-mail message, you receive the following error message:
    Internal MAPI error: An invalid parameter was passed to a MAPI function. Contact your administrator.

    If you change a plain text read-only e-mail message and then forward the e-mail message, you receive the following error message:
    A resource is busy or you lack sufficient access rights or permissions

    If you edit an RTF read-only e-mail message then forward the e-mail message, you receive the following error message:
    This message cannot be modified. You may not have permission to modify the message. To save your changes, click Save As on the File menu.

    **************************

    This problem is by design when you try to change a read-only e-mail message.

    (However, if you try to reply to a read-only HTML formatted e-mail message or to a read-only plain text formatted e-mail message, you do not receive an error message.)

    To work around this problem, we can reply to the e-mail message instead of forwarding the e-mail message. When you reply to the e-mail message, change the recipient name that is in the To field to the appropriate recipient that you want to send the message to.

    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com
    .



    

    Thanks for your efforts, Tony. I don't think this issue is caused by the compatibilities. As I mentioned in my first post, my colleagues who are using Office 2007 or 2010 can use these .msg files for sending emails without any problem. And we don't use them for forwarding or replying emails, but for sending new emails. They were made to be "templates" which we can use to send new emails. Here are the procedures on how we use these "templates":

    1. Open the any one of the templates;

    2. Enter the receptionist's email address, modify the subject and add some information to the body and then we can send it.

    3. After sending, a copy of the sent email will be saved automatically in Outlook "sent" box. And the template file won't be changed due to its read-only property.

    According to my colleagues, there is no any error message or prompt shows up while composing emails with these "templates". However, this just not work in my computer. I assume that this issue might relate to my Outlook settings. I did a fresh install of Windows 7 several months ago and restore Outlook settings from the backup. I imported Outlook settings from a registry backup file which can restored all my settings of Options. If that's the case, is there any way that I can reset Outlook' settings?

    Tuesday, September 11, 2012 2:24 PM
  • "If that's the case, is there any way that I can reset Outlook' settings?"

    You may create a new Outlook profile and re-setup this account for testing.

    Cheers,

    Tony Chen

    Wednesday, September 12, 2012 5:31 AM
  • "If that's the case, is there any way that I can reset Outlook' settings?"

    You may create a new Outlook profile and re-setup this account for testing.

    Cheers,

    Tony Chen


    I've tested these "template" files on my test machine, they work fine. And I've tried creating new Outlook profiles for testing, the settings cannot be reset! So there should be something wrong with my outlook or OS. Do you  have any other workaround to reset Outlook without reinstallation?
    Friday, September 14, 2012 3:15 PM
  • Creating a new mail profile is reset behavior in a sense. This point you may try run Outlook with the command "Outlook.exe /firstrun"


    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    • Marked as answer by Tony Chen CHN Monday, October 8, 2012 9:41 AM
    • Unmarked as answer by Tony Chen CHN Monday, October 8, 2012 9:42 AM
    Monday, September 17, 2012 2:19 AM
  • Creating a new mail profile is reset behavior in a sense. This point you may try run Outlook with the command "Outlook.exe /firstrun"


    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.


    Hi Tony, I just came across the root cause in Office 2013. When I check the
    option "Always check spelling before sending" in the "Mail" options, this error
    shows up! Let me show you how to reproduce this issue, or maybe the bug:

    1. Create a new message.

    2. Enter random email address of the recipient, random title, random body
    content.

    3. Save the message as "Outlook Message Format" and then close it.

    4. Set the message file as a "read-only" one.

    5. Have the "Always check spelling before sending" option checked.

    5. Open this message file, click "Send" without changing anything, then the
    message will be sent without any problem.

    6. Open and modify the title, recipient, body content of the message, hit
    "Send" button, the error pops up! But if you uncheck the "Always check spelling before sending" option, the modified the message can be sent without any problem!!

    As far as I know, this issue can be reproduced both in Outlook 2010 and 2013. If you can reproduce the issue on your side and cannot figure out the root cause, please consider it as a bug and report it to Outlook team for further investigation, thanks!

    
    
    
    
    
    

    • Edited by MS_OLC Thursday, November 22, 2012 5:07 PM
    • Proposed as answer by Tony Chen CHN Friday, November 23, 2012 5:58 AM
    Thursday, November 22, 2012 5:07 PM
  • Thank you for your feedback, MS_OLC.

    Cheers,

    Tony Chen

    Friday, November 23, 2012 5:58 AM