none
Exchange 2013 - Outlook 2010 Cached mode - Error 0x8004011C and 0x80040115 RRS feed

  • Question

  • Hello all,

    Following problem: Exchange server 2013 installed on an windows Server 2012. Client connecting with Outlook 2007 and 2010. All users using cached mode because they are out of the office a lot of time. The problem we have is if the user is on the road , sending an recieving mail is not a problem. While they are in the office the outlook client updates the folders and says "Online". When the user sends a message the message is stuck in the outbox. When clicking on send and recive we got an eror "unknow error 0x8004011C" and while transmitting error 0x80040115 for this action the exchange server should be online... but the server is online because the folders are beeing updated. Looking into autodiscovery and so all url's are correct.

    Anyone having a tip ?

    many thanks

    Chris

    Friday, January 25, 2013 10:37 AM

Answers

All replies

  • Hello,

    Thank you for your post.

    This is a quick note to let you know that we are performing research on this issue.

    Thanks,

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Simon Wu
    TechNet Community Support

    Monday, January 28, 2013 3:35 AM
    Moderator
  • Hi Chirs,

    I suggest you to refer to following post. Although it describes the issue which happens on Exchange 2010. I hope it useful to you:

    Sending mail - 0x80040115

    http://social.technet.microsoft.com/Forums/en-AU/exchangesvrclients/thread/7b401583-1519-4b64-893d-cb53c59d93a8

    -----

    We can refer to following article which describes the error "(0x80040115)". And maybe it can give you some ideas:

    http://support.microsoft.com/kb/2277593

    -----

    Hope all above helpful to you.

    Regards,

    Jerry Ye

    --------------------------------------------------------------

    Exchange 2013 | Exchange 2010 | Exchange 2007 | Outlook 2013 | Outlook 2010 | Outlook 2007

    Finding problems is to make progress & Solving problems is to keep advance

    Monday, January 28, 2013 8:09 AM
  • Hi Jerry & Simon

    I have been looking into those artikels to. My impression is because of MAPI is now only done by using  RPC over HTTPS , I think it has something todo with encryption/authentication . I have change in outlook the following settings: in the security tab of the account , if you use autodiscover it puts logon network security on anonymous authentication and so no encryption between Outlook and Exchange. If you now put negotiate Authentication and enable the encryption between Outlook and Exchange the error disapears. I didn't hear the customer back for the moment. The question is if it is so how can I change the settings on autodiscover so the client recieve these settings ?

    Greetings
    chris

    Monday, January 28, 2013 8:20 AM
  • Hi Chris,

    Thank you for your quick reply.

    From your description "If you use autodiscover it puts logon network security on anonymous authentication and so no encryption between Outlook and Exchange", do you mean "Encrypt data between Microsoft Outlook and Microsoft Exchange" is not checked by defult in your environment?

    And Logon Network security type is Anonymous Authentication by default?

    As I know, "Encrypt data between..." is selected by defualt and the default Logon network security type is Negotiate Authentication.

    Could you please let me know the true situation in your environment?

    Regards,

    Jerry Ye

    --------------------------------------------------------------

    Exchange 2013 | Exchange 2010 | Exchange 2007 | Outlook 2013 | Outlook 2010 | Outlook 2007

    Finding problems is to make progress & Solving problems is to keep advance

    Monday, January 28, 2013 8:57 AM
  • Hi Chris,

    I suggest you to to try following cmdlets to change Autodiscover and OutlookAnywhere Authentication. We can set their Authentication method to default type:

    1). Set-AutodiscoverVirtualDirectory -Identity 'autodiscover(default Web Site)' -WindowsAuthentication $true -BasicAuthentication $true

    http://technet.microsoft.com/en-us/library/aa998601.aspx

    2). Set-OutlookAnywhere -Identity:CAS01\rpc (Default Web Site) -IISAuthenticationMethods Basic,NTLM

    http://technet.microsoft.com/en-us/library/bb123545.aspx

    -----

    And we can refer to following blog which although describes Exchange 2007 to get more knowledge:

    http://blog.wapnet.nl/tag/autodiscover/

    -----

    Hope helpful to you.

    Regards,

    Jerry Ye

    --------------------------------------------------------------

    Exchange 2013 |Exchange 2010 | Exchange 2007| Outlook 2013 |Outlook 2010 | Outlook 2007

    Finding problems is to make progress & Solving problems is to keep advance

    Monday, January 28, 2013 9:04 AM
  • Hi Jerry,

    Correct , I think the error is comming from that setting. The customer is now already running the morning without calling us that sending messages doesn't work.

    Greetings

    Chris

    Monday, January 28, 2013 9:47 AM
  • Hi Chris,

    Thank you for your reply.

    If so, then I suggest you to try those cmdlets on Exchange server side.

    If there is any result or update, please feel free to let me know.

    Regards,

    Jerry Ye

    --------------------------------------------------------------

    Exchange 2013 |Exchange 2010 | Exchange 2007| Outlook 2013 |Outlook 2010 | Outlook 2007

    Finding problems is to make progress & Solving problems is to keep advance

    Monday, January 28, 2013 9:57 AM
  • Hello,

    I have exactly the same problem :(

    Fresh Exchange 2013 installation on Windows Server 2012. Two users (only two) of the organization can NOT send emails from their Outlook 2010 SP1 client : messages are stuck in Outbox... But incoming emails are perfectly well received ! Send/receive window only shows 0x8004011C (unknown error) or 0x80040115 (The connection to Microsoft Exchange is unavailable) errors. In the status bar, Outlook says "Connected to Microsoft Exchange" (That's absolutely crazy !). Profile settings : cached mode, encryption enabled, Outlook anywhere enabled (since a direct RPC connection is no longer possible with Exchange 2013), NTLM Authentification. Complete deletion and recreation of Outlook profile does not solve anything. When these users log on to OWA, they can send messages without any problems.

    Could anyone help me ?

    Monday, January 28, 2013 4:45 PM
  • Hi Vincent

    The Error messages translates to:

    C:\>err 0x8004011C
    # for hex 0x8004011c / decimal -2147221220
      ecProfileNotConfigured                                         ec.h
      ecNotConfigured                                                ec.h
      MAPI_E_UNCONFIGURED                                            mapicode.h
    # 3 matches found for "0x8004011C"

    C:\>err 0x80040115
    # for hex 0x80040115 / decimal -2147221227
      ecRpcFailed                                                    ec.h
      ecNetwork                                                      ec.h
      MAPI_E_NETWORK_ERROR                                           mapicode.h
    # as an HRESULT: Severity: FAILURE (1), FACILITY_ITF (0x4), Code 0x115
    # for hex 0x115 / decimal 277
      ERROR_EA_TABLE_FULL                                            winerror.h
    # The extended attribute table file is full.
    # 4 matches found for "0x80040115"

    > Do you see any change in behavior with the "Outlook online mode"?

    Cheers

    Aravind

    Thursday, January 31, 2013 10:29 AM
  • Ok, we have EXACT issue also - newly installed Exchange 2013 on a new Server 2012.  Small company under 30 users.   

    Our problem MIRRORS the post above, except it is happening with more than 2 users:

    ________

    Fresh Exchange 2013 installation on Windows Server 2012. Two users (only two) of the organization can NOT send emails from their Outlook 2010 SP1 client : messages are stuck in Outbox... But incoming emails are perfectly well received ! Send/receive window only shows 0x8004011C (unknown error) or 0x80040115 (The connection to Microsoft Exchange is unavailable) errors. In the status bar, Outlook says "Connected to Microsoft Exchange" (That's absolutely crazy !). Profile settings : cached mode, encryption enabled, Outlook anywhere enabled (since a direct RPC connection is no longer possible with Exchange 2013), NTLM Authentification. Complete deletion and recreation of Outlook profile does not solve anything. When these users log on to OWA, they can send messages without any problems.

    Could anyone help me

    ________

    I will add that when switching to ONLINE mode, this problem does not surface.    Also no problems with OWA, active sync, etc..

    This is a big issue for us and our customer is becoming frustrated.   Anyone have an update, info to share or something to try?

    We have a couple cases open atm, none have helped.

    thx!


    • Edited by Tony DeMarzo Thursday, February 21, 2013 2:03 PM
    Thursday, February 21, 2013 2:02 PM
  • Anyone else out there with this issue?   Very unhappy users as they took their notebooks out of the office for the weekend and a few experienced the problem with outgoing emails getting stuck in the outbox.   "Use OWA" is not an answer anyone wants to hear.   Any suggestions???

    /desperate

    thx.

    Monday, February 25, 2013 4:18 AM
  • We have the same issue. Clients - Outlook 2010, 2013. 

    Users can send mail via outlook only without cached mode. All users. 

    Tuesday, February 26, 2013 10:21 PM
  • We are experiencing the same issue with Outlook 2010 and Outlook 2013 on Exchange 2013 on Windows Server 2012. The cause seems to be linked to additional mailboxes - when manually added to accounts, rather than letting Outlook auto-add after a user gets given FullAccess permissions. Remove additional mailboxes and restart Outlook. Possibly linked to SendAs permissions on mailboxes that users are given FullAccess to, but it's very inconsistent so haven't been fully able to establish one way or another.

    Same configuration doesn't affect Exchange 2010, seems like a Exchange 2013 bug to me.


    • Proposed as answer by Tony DeMarzo Tuesday, March 5, 2013 9:31 PM
    Wednesday, February 27, 2013 12:25 PM
  • Thank you Adrian for workaround!

    • Proposed as answer by Mikrodots Thursday, February 28, 2013 9:04 PM
    • Unproposed as answer by Mikrodots Thursday, February 28, 2013 9:04 PM
    Wednesday, February 27, 2013 8:34 PM
  • Needed to take it one step further - removed additional mailboxes from Outlook as Adrian recommends, then a redo in EAC for delegation on each mailbox - not 100% confirmed, but seems to clear this up.

    NOTE: Exchange 2013 on Windows 2012 coexisting with Exchange 2010 - mailboxes were migrated from 2010.

    Also - doesn't look like groups are available for delegation... they are there from the migration, but I can't seem to add groups for delegation in 2013, need to research more..

    Mike Doherty

    Thursday, February 28, 2013 9:14 PM
  • Adrian!!  You rock.   This was the root cause for sure.   After previously failing within minutes to hours with cached mode outbox issues, we have now gone since last Thursday with no problems at all.   

    Tuesday, March 5, 2013 9:31 PM
  • Brilliant Adrian. Had me stumped for 3 days straight. Very time consuming fix however, I had around 40 users I had to go around removing all the additional mailboxes and readding them. God forbid if you are in a large organisation.


    Wednesday, March 20, 2013 2:55 PM
  • Anyone implemented CU1 yet? Have you noticed whether this issue has been resolved? Still trying to find a definitive list of bugs fixed...
    Wednesday, April 3, 2013 2:25 AM
  • Hi Adrian,

    Today i will install CU1 in the test enviroment before installing it live.

    Hopefully it will solve a lot of problems.

    Greetings

    Chris

    Wednesday, April 3, 2013 6:19 AM
  • Problems not solved with the CU1 version... i have the feeling they even get worse...

    Friday, April 5, 2013 10:17 AM
  • Greetings,

    We are seeing the same issue in Exchange 2013 CU1 with Exchange 2010 coexist.  I had to go into my Outlook profile and manually change the security settings, and have seem some odd issues trying to connect to public folders and download the address book that are still on the Exchange 2010 environment.  Changing the security setting seems to be the fix for both of these.

    Odd that these settings are not getting populated correctly when creating a new Outlook profile and letting autodiscover setup the account.  I am connecting to Exchange 2013 with Outlook 2013.

    Also, how are others manually adding an exchange profile since with 2013 you are unable to enter in the FQDN of the CAS server since it appears to now be using a GUID formatted name?  You pretty much have to rely on Autodiscover to properly configure the account, which isn't really a big deal, but plays a major role in proper auto configuration of the Outlook profile.

    Cheers

    Friday, April 5, 2013 12:22 PM
  • Well , I have now a working system : I have also changed this in to the registery and recreated the outlook profile and now all outlooks connects without asking for password. The GUID name of the server is standard now , I did read it in a post from the exchange team.

    Following key added :

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
    "lmcompatibilitylevel"=dword:00000001

    Value

    Meaning

    0

    Clients use LM and NTLM authentication, but they never use NTLMv2 session security. Domain controllers accept LM, NTLM, and NTLMv2 authentication.

    1

    Clients use LM and NTLM authentication, and they use NTLMv2 session security if the server supports it. Domain controllers accept LM, NTLM, and NTLMv2 authentication.

    2

    Clients use only NTLM authentication, and they use NTLMv2 session security if the server supports it. Domain controller accepts LM, NTLM, and NTLMv2 authentication.

    3

    Clients use only NTLMv2 authentication, and they use NTLMv2 session security if the server supports it. Domain controllers accept LM, NTLM, and NTLMv2 authentication.

    4

    Clients use only NTLMv2 authentication, and they use NTLMv2 session security if the server supports it. Domain controller refuses LM authentication responses, but it accepts NTLM and NTLMv2.

    5

    Clients use only NTLMv2 authentication, and they use NTLMv2 session security if the server supports it. Domain controller refuses LM and NTLM authentication responses, but it accepts NTLMv2.

    Friday, April 5, 2013 12:25 PM
  • Also...  I tested connecting to my mailbox that is on Exchange 2013 with Outlook 2010 and the proper Security Settings were pulled down into Outlook under the security Tab:

    Outlook 2010 Profile Security Settings

    Encrypt Data Between Microsoft Outlook and Microsoft Exchange - Checked
    Logon Network Security:  Negotiate Authentication

    Outlook 2013 Profile Security Settings ( Do not work.  Outlook prompts for password )
    Encrypt Data Between Microsoft Outlook and Microsoft Exchange - NOT Checked
    Logon Network Security:  Anonymous Authentication

    Cheers

    Friday, April 5, 2013 1:04 PM
  • Hello,

    I have similar issue. Outlook 2007 / with 1 additional mailbox in Cached mode. The only working solution in my case is to use Online mode. After changing to online mode all is working fine.

    With regards


    Zbyněk

    Thursday, April 18, 2013 8:40 AM
  • Well , I have now a working system : I have also changed this in to the registery and recreated the outlook profile and now all outlooks connects without asking for password. The GUID name of the server is standard now , I did read it in a post from the exchange team.

    Following key added :

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
    "lmcompatibilitylevel"=dword:00000001

    Value

    Meaning

    0

    Clients use LM and NTLM authentication, but they never use NTLMv2 session security. Domain controllers accept LM, NTLM, and NTLMv2 authentication.

    1

    Clients use LM and NTLM authentication, and they use NTLMv2 session security if the server supports it. Domain controllers accept LM, NTLM, and NTLMv2 authentication.

    2

    Clients use only NTLM authentication, and they use NTLMv2 session security if the server supports it. Domain controller accepts LM, NTLM, and NTLMv2 authentication.

    3

    Clients use only NTLMv2 authentication, and they use NTLMv2 session security if the server supports it. Domain controllers accept LM, NTLM, and NTLMv2 authentication.

    4

    Clients use only NTLMv2 authentication, and they use NTLMv2 session security if the server supports it. Domain controller refuses LM authentication responses, but it accepts NTLM and NTLMv2.

    5

    Clients use only NTLMv2 authentication, and they use NTLMv2 session security if the server supports it. Domain controller refuses LM and NTLM authentication responses, but it accepts NTLMv2.

    Did you change the registry on the exchange 2013 sever or the client computers?

    Did this fix the cached mode to work now with out prompting for password?

    Thursday, April 25, 2013 12:35 PM
  • We are experiencing the same issue with Outlook 2010 and Outlook 2013 on Exchange 2013 on Windows Server 2012. The cause seems to be linked to additional mailboxes - when manually added to accounts, rather than letting Outlook auto-add after a user gets given FullAccess permissions. Remove additional mailboxes and restart Outlook. Possibly linked to SendAs permissions on mailboxes that users are given FullAccess to, but it's very inconsistent so haven't been fully able to establish one way or another.

    Same configuration doesn't affect Exchange 2010, seems like a Exchange 2013 bug to me.


    Spot on, had the same problem and could resolve it by removing the linked mailbox. The exact same configuration, actually the same mailbox with linked mailbox on Exchange 2010 didn't have the problem.

    Exchange 2013 CU1 running on Windows Server 2012, so it looks like CU1 doesn't fix it.

    Friday, May 10, 2013 2:08 PM
  • Issue still comes up after above fixes have been applied. I've been able to temporarily fix the issue by iisreset. Not a good fix but gets the customer back on with Outlook.

    OutlookAnywhere settings are both now set to Negotiate:

    ExternalClientAuthenticationMethod : Negotiate
    InternalClientAuthenticationMethod : Negotiate
    IISAuthenticationMethods           : {Basic, Ntlm, Negotiate}

    Friday, May 10, 2013 3:29 PM
  • Hi I have just installed a coexisitance 2013 with our 2007 exchange environment. I have installed the prerequisites and followed the deployment guide. I have a Cas and and mailbox server 2013 and cluster 2007 with single cas. With owa everything works fine i can access mailboxes on the new and old mailbox servers i can mail everything inside and outside of our network and recieve all mail. The prroblem is getting my outlook clients in our network to connect they cant seem to resolve the new 2013 mailbox server, even if i configure the client manually. The autodicover gives me a weird server name what looks like a sid account number @ourdomain.com eg: 57282-8173-34889111934@ourdomain.com i have this for new mailboxes and migrated mailboxes to 2013. 2007 mailboxes work fine with outlook 2007 and 2013. Why cant my outlook clients automatically change the profile and server settings corrctly?
    Monday, June 17, 2013 11:28 PM
  • Hello, This is normal behavior. There is no mailbox server in autodiscover response anymore. Instead there is a GUID @domain.suffix, which points Outlook to the right mailbox server. It also has possitive impact on user experience, since user will not get "Your administrator has made a change and restart of Outlook is required" message.

    In Excahnge 2013 Mapi connectivity is not allowed for clients anymore. Do you have RPC over HTTPS (Outlook Anywhere) enabled for your clients?

    Regards


    Zbyněk

    Tuesday, June 18, 2013 6:57 AM
  • Thanks, Adrian!  That fixed my issue (removing the additional mailbox) - was driving me nuts!
    Thursday, March 27, 2014 4:41 PM
  • Dude, Thank You So Much, been trying to work on this for Weeks now. Now when I add the mailbox again, the issue happens again, how do we prevent this from happening? Just change the SendAs permissions on mailboxes on Exchange 2007? Did that work for you?
    Wednesday, August 3, 2016 7:24 PM