none
User NOT warned if another user has opened a file for editing

    Question

  • Hello,
    Some of my users are experiencing a record locking issue.  Basically, When they open certain files, they are NOT warned that the file is already open for use by another user. This seems to happen with Word and Excel 2007 files (docx and xlsx).

    Here are some specifics:
    Office 2007 SP2
    Windows 7 x64
    Normal Windows domain
    Files are stored on Windows 2008R2 server
    We are NOT using DFS-R

    Here's the scenario:  
    1) User1 opens the xlsx file and makes some changes.  
    2) User2 then opens the SAME file, makes changes and closes the file. 
    3) User2 is never warned that User1 has the file open for editing.
    3) When User1 saves the file, they are prompted to "Save a copy" or "Overwrite changes"

    So, I guess what I'm asking is - does anyone know how to turn off whatever "feature" Microsoft has created to allow this type of simultaneous editing?   It seems that Microsoft has changed the default behavior for opening a file that already has a lock on it.  It used to be that when User2 opened a file that was open by User1, they would immediately get a warning box that told them the file was open and they could select "Open Read only" , "Notify", or "Cancel".  Well, that doesn't seem to be happening anymore.  I am trying to get to the bottom of when and why this file locking behavior changed.  My real question is why do users no longer receive a warning message when they open a file informing them that someone else has the file open.

    This dialog box is what I'm trying to get back.  I realize that some may see this as a reduciton in functionality but, for my users it offers a level of protection against inadvertently overwritting someone's changes. 
    Wednesday, June 29, 2011 1:44 PM

All replies

  • there is some setup in the excel to "allow changes by more than one user at the same time."

    You can try to disable that in your excel file.

    http://www.techonthenet.com/excel/questions/shared.php

     

    cheers :)

    • Marked as answer by Harry Yuan Friday, July 1, 2011 8:31 AM
    • Unmarked as answer by ScottB35e0 Friday, July 1, 2011 1:27 PM
    Wednesday, June 29, 2011 3:52 PM
  • That setting is not set.  I wouldn't have believed this was possible if I hadn't experienced it myself.  However, it's true...

     

    This is also happening on Word files.  

    Friday, July 1, 2011 1:28 PM
  • Did you change the opportunistic locking settings on the server? See http://support.microsoft.com/kb/296264 


    Is the "owner file" like ~$filename.docx or ~$filename.xlsx created? See http://support.microsoft.com/kb/211632
    Wednesday, July 6, 2011 2:05 PM
  • Hello,

    You can create a workaround,

    by making a macro that opens the file,

    and eventually assign a key combination to that macro.

    Example:

    Sub YourSub()
        Workbooks.Open Filename:="Your path\YourFile.xlsx", UpdateLinks:=3, Notify:=yes
    End Sub

    The key here is "Notify:=yes".

    If the file has been opened by another user,

    Excel will definitely give you a warning.

    Since we encountered this problem with only 2 files on our whole server,

    for us this was a workaround.

    Kind regards.

    Thursday, September 12, 2013 12:58 PM