none
AutoArchive policy RRS feed

  • Question

  • Hi there

    We have a mailbox where we wish to AutoArchive emails that are in the inbox after a set amount of days. We configured the policy but it hasnt worked. Can you confirm the correct way to do this?

    Kind regards

    George

    Friday, November 8, 2019 11:18 AM

Answers

  • Hi,

    What’s the type of your retention tag? The RPT will apply to the inbox automatically, but if you use the personal tag, you have to apply it manually.

    What’s the retention age you set on the tag and when did you get the email you want to archive?

    You can get the setting of tag through the following command, and check the parameter, such as retentionenable, retentionaction, agelimitforretention, and so on. 

    get-retentionpolicytag –Identity "tag name" | fl

    Then check the policy use the following command and check the retentionpolicytaglinks parameter.

    get-retentionpolicy –Identity "policy name" | fl

    Confirm you have applied the policy to the specify mailbox with the following command:

    get-mailbox –Identity "mailbox name" | fl *retentionpolicy*

    The Managed Folder Assistant (MFA) is a mailbox assistant processes to process mailboxes that have a Retention Policy applied, add the Retention Tags included in the policy to the mailbox, and process items in the mailbox. If the items have a retention tag, the assistant tests the age of those items. If an item has exceeded its retention age, it takes the specified retention action.

    If you have confirmed all above, you can run the MFA to force the policy to apply:

    Start-ManagedFolderAssistant -Identity <mailbox identity>

    Regards,

    Vera Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, November 11, 2019 6:35 AM

All replies

  • Hi,

    What’s the type of your retention tag? The RPT will apply to the inbox automatically, but if you use the personal tag, you have to apply it manually.

    What’s the retention age you set on the tag and when did you get the email you want to archive?

    You can get the setting of tag through the following command, and check the parameter, such as retentionenable, retentionaction, agelimitforretention, and so on. 

    get-retentionpolicytag –Identity "tag name" | fl

    Then check the policy use the following command and check the retentionpolicytaglinks parameter.

    get-retentionpolicy –Identity "policy name" | fl

    Confirm you have applied the policy to the specify mailbox with the following command:

    get-mailbox –Identity "mailbox name" | fl *retentionpolicy*

    The Managed Folder Assistant (MFA) is a mailbox assistant processes to process mailboxes that have a Retention Policy applied, add the Retention Tags included in the policy to the mailbox, and process items in the mailbox. If the items have a retention tag, the assistant tests the age of those items. If an item has exceeded its retention age, it takes the specified retention action.

    If you have confirmed all above, you can run the MFA to force the policy to apply:

    Start-ManagedFolderAssistant -Identity <mailbox identity>

    Regards,

    Vera Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, November 11, 2019 6:35 AM
  • Hi Vera

    Thanks for your reply. I have created a new policy and applied that to my mailbox. I have added tow tags to the policy; an existing tag called "Default 2 year move to archive" and a new tag I created called "1 Day delete". Both tags are listed as Default.

    I run the commands you suggested and the results are below:

    get-retentionpolicytag -Identity "1 Day Delete" | fl

    RunspaceId                            : 7b755fe2-7f22-4f91-8fd9-43d4a795ce18
    MessageClassDisplayName               : All Mailbox Content
    MessageClass                          : *
    Description                           : Managed Content Settings
    RetentionEnabled                      : False
    RetentionAction                       : PermanentlyDelete
    AgeLimitForRetention                  : 30.00:00:00
    MoveToDestinationFolder               :
    TriggerForRetention                   : WhenDelivered
    MessageFormatForJournaling            : UseTnef
    JournalingEnabled                     : False
    AddressForJournaling                  :
    LabelForJournaling                    :
    Type                                  : All
    IsDefaultAutoGroupPolicyTag           : False
    IsDefaultModeratedRecipientsPolicyTag : False
    SystemTag                             : False
    LocalizedRetentionPolicyTagName       : {}
    Comment                               :
    RetentionId                           : 81254c5b-3500-498c-aeb5-25675f495289
    LocalizedComment                      : {}
    MustDisplayCommentEnabled             : False
    LegacyManagedFolder                   :
    AdminDisplayName                      :
    ExchangeVersion                       : 1.0 (14.0.100.0)
    Name                                  : 1 Day Delete
    DistinguishedName                     : CN=1 Day Delete,CN=Retention Policy Tag Container,CN=domain,CN=Microsoft
                                            Exchange,CN=Services,CN=Configuration,DC=domain,DC=local
    Identity                              : 1 Day Delete
    Guid                                  : 81254c5b-3500-498c-aeb5-25675f495289
    ObjectCategory                        : domain.local/Configuration/Schema/ms-Exch-ELC-Folder
    ObjectClass                           : {top, msExchELCFolder}
    WhenChanged                           : 11/11/2019 10:24:56
    WhenCreated                           : 11/11/2019 10:24:56
    WhenChangedUTC                        : 11/11/2019 10:24:56
    WhenCreatedUTC                        : 11/11/2019 10:24:56
    OrganizationId                        :
    Id                                    : 1 Day Delete
    OriginatingServer                     : svr12.domain.local
    IsValid                               : True
    ObjectState                           : Unchanged

    get-retentionpolicy -Identity "Hustings Policy" | fl

    RunspaceId                  : 7b755fe2-7f22-4f91-8fd9-43d4a795ce18
    RetentionId                 : 14aa69fc-265c-48d5-b799-6a692cd93adf
    RetentionPolicyTagLinks     : {1 Day Delete, Default 2 year move to archive}
    IsDefault                   : False
    IsDefaultArbitrationMailbox : False
    AdminDisplayName            :
    ExchangeVersion             : 1.0 (14.0.100.0)
    Name                        : Hustings Policy
    DistinguishedName           : CN=Hustings Policy,CN=Retention Policies Container,CN=domain,CN=Microsoft
                                  Exchange,CN=Services,CN=Configuration,DC=sdomain,DC=local
    Identity                    : Hustings Policy
    Guid                        : 14aa69fc-265c-48d5-b799-6a692cd93adf
    ObjectCategory              : contoso.local/Configuration/Schema/ms-Exch-Mailbox-Recipient-Template
    ObjectClass                 : {top, msExchRecipientTemplate, msExchMailboxRecipientTemplate}
    WhenChanged                 : 11/11/2019 10:25:57
    WhenCreated                 : 11/11/2019 10:16:51
    WhenChangedUTC              : 11/11/2019 10:25:57
    WhenCreatedUTC              : 11/11/2019 10:16:51
    OrganizationId              :
    Id                          : Hustings Policy
    OriginatingServer           : svr12.domain.local
    IsValid                     : True
    ObjectState                 : Unchanged

    get-mailbox -Identity "Hustings" | fl *retentionpolicy*

    RetentionPolicy : Hustings Policy

    If it wasn't obvious from the information above, the mailbox is called Hustings and the policy is called Hustings Policy.

    When I check the policy status through OWA the Inbox states "Use Parent Folder Policy" and when I check the parent folder I can see that both policies are applied.

    I checked the Inbox this morning and all emails are still present.

    Kind regards

    David

    Tuesday, November 12, 2019 11:33 AM
  • Hi David,

    Your domain information has been covered, please remember to cover your personal information when you post the information next time.

    1. According to the information you replied, the retention age you set on the “1 Day Delete” tag is 30 days other than 1 day. Please check if you have a wrong setting, or the information you posted is not about the“1 Day Delete” tag.

    2. The DPT is applied automatically to entire mailbox . A DPT applies to untagged items, which are mailbox items that don't have a retention tag applied directly or by inheritance from the folder.

    Logically, you can apply the policy which includes both archive and deletion tags, but the DPT with the move to archive action must have a lower retention age than the DPT with a deletion action.

    The retention age you set on the archive tag is higher than the deletion tag, it’s conflicting. For the detail, please refer to Retention policies.

    3. According to your needs, you needn’t add the deletion tag to the policy unless you want to delete the archive emails later. Archive mailboxes don't have a separate retention policy. The same retention policy is applied to the primary and archive mailbox. Additionally, please confirm that the user has an archive mailbox.

    It’s enough to use the DPT with archive action to archive your emails.

    Regards,

    Vera Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, November 14, 2019 6:13 AM
  • Hi Vera

    Thanks for your reply. You are correct, I had made a mistake with the AgeLimitForRetention set at 30 days. The policy now works perfectly.

    Thank you for your help.

    Kind regards

    David

    Tuesday, November 19, 2019 10:46 AM
  • I’m glad that you have solved your problem. The following is a brief summary of this issue so that others may get help from this approach.

    Issue Symptom
    ==========================================
    The policy used to AutoArchive emails and delete emails is not worked.

    Possible Cause
    ==========================================
    The setting of the retention tags. 

    Solution
    ==========================================
    1. The troubleshooting process:
    You can get the setting of tag through the following command, and check the parameter, such as retentionenable, retentionaction, agelimitforretention, and so on.

    get-retentionpolicytag –Identity "tag name" | fl


    Then check the policy use the following command and check the retentionpolicytaglinks parameter.

    get-retentionpolicy –Identity "policy name" | fl


    Confirm you have applied the policy to the specify mailbox with the following command:

    get-mailbox –Identity "mailbox name" | fl *retentionpolicy*


    If you have confirmed all above, you can run the MFA to force the policy to apply:

    Start-ManagedFolderAssistant -Identity <mailbox identity>



    2. About this issue, it’s caused by the tag setting. Just configure the associate parameter with a right value.

    Regards,

    Vera Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.



    Friday, November 22, 2019 7:33 AM