none
Office 2010 : Install fails with "Windows Installer installed the product. Product Name: Microsoft Office Shared MUI (English) 2010" ..."Installation success or error status: 1603" RRS feed

  • Question

  • I have a scenario where a machine (which previously had Office 2003 on it - but which was remvoed before the Office 2010 install) refuses to intall office.

    What should be a trivial installation is simply not working and proving a complete PITA to get to the bottom of!

    The install fails with the following error in the event log:

    "Windows Installer installed the product. Product Name: Microsoft Office Shared MUI (English) 2010.
    Product Version: 14.0.4763.1000. Product Language: 1033. Installation success or error status: 1603
    "

    I can see that 1603 = "Fatal error during installation"
    (not very helpful !)

    When the install fails, Office dosn't show up in Add/Remove programs and I have to run the cleanup tool to remove it from here:
    290301 : How do I uninstall Office 2003, Office 2007 or Office 2010 suites if I cannot uninstall it from Control Panel?

    I've also removed all directories and registry entries and the installation still fails.

    I'm struggling to know what else to try in order to get this working (i.e. just install the product!)

    My "guess" is that other software components on this machine "may" be stopping the install from working correctly, but the installation / errors coming back are extremly unhelpful in terms of pinpointing the root cause.

    Anyone else seen this / know how to troublesghoot fruther / resolve?

    Thanks
    - AL

    (As a side-note - why isn't the removal tool included with Office 2010 rather than as a seperate download ?!
    Ok - I can see /unisntall - but I think there shoudl be a "/uninstall all" to force a removal in a sceanrio like this)

    Monday, July 19, 2010 1:24 PM

Answers

All replies

  • Found the solution to this.

    It was due to a "left-over" file Rgstrtn.lck which dosnt get deleted (even by the office 2010 removal tool)

    Deleting that file resovled the issue for me (seems like a bug to me and the !)

    http://support.microsoft.com/kb/927153

    - AL

    • Marked as answer by Sally Tang Tuesday, July 20, 2010 6:45 AM
    Monday, July 19, 2010 4:42 PM
  • Worked like a charm, thank you so much.

    Tuesday, October 29, 2013 3:51 PM
  • Wow, I've been working all day trying to fix this. I've probably tried about 30 different "solutions".  Finally this solution worked!!

    THANK YOU!!

    Monday, November 18, 2013 7:52 PM
  • Thank you so much !!!!

    I looked at so many different unsuccessful solution before testing yours.

    I cannot understand why the official Microsoft removal tool is not able to do this itself.

    Thanks again !

    Thursday, January 4, 2018 6:33 PM