MySite user profile site creation of My Content page is created as provisioned failed (unprovisioned)


  • I've been trying to troubleshoot our User Profile Sync and have noticed the profile pages weren't getting updated with everything.  Most content was but things like memberships and the content tabs weren't.  I also saw this error in ULS:

    ProfSynch: Exception attempting to enumerate site 25a72070-4249-4698-ae99-c2a45d25b08e for ContentDB 23a6e3ef-6d56-4bde-825e-95c6924e2f91: Microsoft.Office.Server.UserProfiles.ProfileSynchronizationInternalException: ProfSynch: The site with ID 25a72070-4249-4698-ae99-c2a45d25b08e cannot be synchronized due to an unprovisioned root web.
         at Microsoft.Office.Server.UserProfiles.SiteSynchronizerCollection.GetSynchInfoForSite(SqlDataReader dr, SynchInfo info)
         at Microsoft.Office.Server.UserProfiles.SiteSynchronizerCollection.<get_Elements>d__0.MoveNext()

    I checked in the MySite database under the webs table and noticed all the My Content sites for all of our users had the flag column with the number 1315 in them - (meaning unprovisioned as the error above states).  Cross checking with the User Sync Profile database under the SiteSynch table I noticed all of the sites have NULL for the value under both the LastSynch and ChangeToken columns (The User Profile Service Application - User Profile to SharePoint Full Synchronization  timer job takes care of populating that).  With that information I decided to run proc_markasprovisioned stored procedure against a couple of the sites, which marked them with the flag of 1059 (provisioned) and stopped the error.  This also let the timer job run thru and populate the profile site for the user.  Question is, why are they failing provisioning in the first place?  Anyone have a clue as where to go with this one?


    Wednesday, September 15, 2010 9:40 PM

All replies

  • Are the users creating the sites using the link from their name's context menu off the site?  If not, then perhaps the sites really were not provisioned yet since the user generally will create their own mysite. 

    Perhaps you need to ellaborate on how the MySites are being created in the first place as I'm not sure that the user profile sync does this by itself.

    Dan Luciano - Sogeti USA - MCP, MCTS WSS 3.0 and MOSS 2007 Configuration WSS 3.0 Applicaton Development <--If you find this post helpful, mark helpful to the left!-->
    Thursday, September 16, 2010 3:09 AM
  • Dan,

    Yes, it happens when the users first create the site by hitting the "my content" link off of their MySite page.  It creates the site, and they can view it just fine it seems.  I wasn't suggesting that the user profile sync was creating the site, just that it errors out with that error when it is created and unprovisioned.

    Thursday, September 16, 2010 1:29 PM
  • I'm getting the same error.
    My users are also creating MyContent sites by clicking the link off their MySite page.
    I believe, due to the unprovisioning, the Search isn't working properly. Or is this another symptom ?

    Friday, February 11, 2011 7:43 PM
  • Same situation here. All "My Sites" have value 1315 in Column "Flag". I think calling proc_markasprovisioned manually is not the supported way to provision these wwebs!?

    As i can see (Google) many users have problems with this, this must be an genereal issue within SharePoin 2010. But i cannot find the root of this issue...
    Any ideas?


    Daniel Schmitz
    Friday, April 15, 2011 7:52 AM
  • Exactly the same problem here. Will try the "proc_markasprovisioned stored procedure" solution as outlined above but hope we get a supported solution to this soon.
    Thursday, May 12, 2011 9:38 AM
  • We have the same problem with all personal my sites (SPSPERS site definition), they work fine and all have a root web in the personal site collection. Any hint at what can cause this are welcome, such as feature stapling issues.
    Wednesday, September 21, 2011 6:38 PM
  • Having the exact same issue. My users are creating their My Sites by clicking the My Content link and my log files are filled with "ProfSynch: The site with ID XXXXXXXXXXXXX cannot be synchronized due to an unprovisioned root web" errors. Would like to find a solution to this.
    Thursday, December 22, 2011 11:06 AM
  • I started seeing this error after I applied the December 2011 CU. Anyone know of a fix?
    Friday, January 20, 2012 10:00 PM
  • We are having this same one.. Any news for a fix? Other than running  proc_markasprovisioned ?
    Wednesday, February 01, 2012 9:42 AM
  • We're seeing the same issue. We've deleted and recreated both the mysites host and user profile service to no avail. Verbose logging doesn't reveal any errors as the my sites are created - and they appear to be fully functional. The only sign that there's any sort of problem is the ProfSynch error.

    Any news of a supported fix - or even some understanding as to what is happening to cause the problem - gratefully received.

    Wednesday, March 21, 2012 5:11 PM
  • We are seeing this issue also.

    We are running 2010 SP1 and June 2011 CU.

    Our users are creating personal sites by clicking the My Content link - the sites themselves create fine, and work fine.

    We are also seeing the Memberships tab on some users profiles is either empty or contains out of date information.

    Running stsadm -o sync -listolddatabases 0 shows that all our contentDBs are in sync.

    Wednesday, November 28, 2012 12:16 PM
  • Further update - I'm doing some testing on a lab setup - SP1 and June 2011 CU, everything out of the box, and the personal site for the setup account is fine, but the personal site created by a normal user shows the 1315 flag.

    I'm in the process of deploying the October 2012 CU, just to see if either the existing personal site still flags 1315, or at least to see if a personal site created in future has the issue.

    Will update later.

    Friday, November 30, 2012 1:43 PM
  • The October 2012 CU has now been installed, and any newly created personal sites are provisioned correctly (flag 1059) and are showing as synced correctly in the User Profile database.

    Next thing to figure out - how to fix existing personal site collections...

    • Edited by RobEllis Tuesday, December 11, 2012 9:20 AM corrected CU details - 2012, not 2010!
    Friday, November 30, 2012 4:26 PM
  • Did you ever find a fix for this?  All of my newly created mysites are provisioned correctly (flag 1059) but I still have a ton of other sites filling up my ULS with profsynch errors.  I'm not sure how to correctly run the proc_markasprovisioned or if eventually I'll be forced to fix the sites that way :(

    Jennifer Knight (MCITP, MCPD)

    Monday, December 10, 2012 10:10 PM
  • I've not managed to find a fix for existing sites so far - I've tried various things - moving them to a newly created content DB, resetting to site definition, etc, but nothing seems to work.

    Do you have issues with the memberships being incorrect / blank / out of date, etc?  We have that, but only for some users, but with no obvious pattern.  We don't know whether the memberships issues are related to the provisioning issue.

    Tuesday, December 11, 2012 9:20 AM
  • So it would seem that this bug is corrected in or prior to the Oct 2010 CU?  I still can not find a "supported" fix from Microsoft for the sites that were created prior to applying the CU.  Anyone?
    Wednesday, March 06, 2013 7:31 PM
  • Just an fyi:  I tried setting the property in powershell, and its 'ReadOnly'

    PS $site=Get-SPSite

    PS $site.rootweb.provisioned


    PS $site.rootweb.provisioned=$true

    "Provisioned" is a ReadOnly property.
    At line:1 char:15
    + $site.rootweb. <<<< provisioned=$true
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : PropertyAssignmentException

    Friday, March 08, 2013 5:02 PM